summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2015-09-14 06:36:35 -0400
committerChris Severance2015-09-14 06:36:35 -0400
commit506b232c2e8af0373d2ae2a619ce0f408e352fa5 (patch)
tree244d6e734058b1f87751a91aa24572c940fad884
parent77f6f3d41ab2bd80a535a5d308987c7e08adaf87 (diff)
downloadaur-506b232c2e8af0373d2ae2a619ce0f408e352fa5.tar.gz
Update to 1.15.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD27
2 files changed, 23 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 75a59d7d530a..60199d3aceaa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = le
pkgdesc = A text editor in memorial to Norton Editor with block and binary operations
- pkgver = 1.14.9
+ pkgver = 1.15.1
pkgrel = 1
- url = https://directory.fsf.org/wiki/Le_editor
+ url = https://github.com/lavv17/le
arch = i686
arch = x86_64
license = GPL3
- source = http://lav.yar.ru/download/le/le-1.14.9.tar.gz
- sha256sums = db5baabc1b80c42504d64484a83d48388ecbb3b216a7de9c67fea8b19f1c95bd
+ source = git://git.sv.gnu.org/gnulib
+ source = le-1.15.1.tar.gz::https://github.com/lavv17/le/archive/v1.15.1.tar.gz
+ sha256sums = SKIP
+ sha256sums = 497c2bc0176ee91033dd87c57c90f1d2bf9acc29b32585cfb4c1d32e6ce34834
pkgname = le
depends = gcc-libs
diff --git a/PKGBUILD b/PKGBUILD
index 969dba01d2cb..56d7e1e96078 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,31 +4,37 @@
# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
set -u
+_gitauth='lavv17'
_pkgname='le'
pkgname="${_pkgname}"
-pkgver=1.14.9
+pkgver=1.15.1
pkgrel=1
pkgdesc='A text editor in memorial to Norton Editor with block and binary operations'
arch=('i686' 'x86_64')
-url='https://directory.fsf.org/wiki/Le_editor'
+#url='https://directory.fsf.org/wiki/Le_editor'
+url="https://github.com/${_gitauth}/${_pkgname}"
license=('GPL3')
+_verwatch=("${url}/releases" "${url#*github.com}/archive/v\(.*\)\.tar\.gz" 'l')
_srcdir="${_pkgname}-${pkgver}"
#source=("http://fossies.org/linux/misc/${_pkgname}-${pkgver}.tar.xz")
-source=("http://lav.yar.ru/download/le/${_pkgname}-${pkgver}.tar.gz")
-sha256sums=('db5baabc1b80c42504d64484a83d48388ecbb3b216a7de9c67fea8b19f1c95bd')
+#source=("http://lav.yar.ru/download/le/${_pkgname}-${pkgver}.tar.gz")
+source=('git://git.sv.gnu.org/gnulib' "${_pkgname}-${pkgver}.tar.gz::https://github.com/${_gitauth}/${_pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('SKIP'
+ '497c2bc0176ee91033dd87c57c90f1d2bf9acc29b32585cfb4c1d32e6ce34834')
if [ "${pkgname%-git}" != "${pkgname}" ]; then # this is easily done with case
+ unset _verwatch
makedepends=('git')
provides=("${_pkgname}=${pkgver%%.r*}")
conflicts=("${_pkgname}")
_srcdir="${_pkgname}"
- source=('git://git.sv.gnu.org/gnulib' 'git://github.com/lavv17/le.git')
+ source=('git://git.sv.gnu.org/gnulib' "${url//https:/git:}.git")
:;sha256sums=('SKIP' 'SKIP')
pkgver() {
set -u
cd "${_srcdir}"
#printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)" | sed 's|-|.|g'
- git describe --long | sed -e 's/\([^-]*-g\)/r\1/' -e 's/-/./g'
+ git describe --long | sed -e 's:^v::g' -e 's/\([^-]*-g\)/r\1/' -e 's/-/./g'
set +u
}
fi
@@ -38,11 +44,12 @@ prepare() {
cd "${_srcdir}"
if [ -z "${SKIP_PREPARE:-}" ]; then
if [ -s 'autogen.sh' ]; then
- chmod 770 "${srcdir}/gnulib/gnulib-tool"
- PATH="$PATH:${srcdir}/gnulib"
- ./autogen.sh
+ #chmod 770 "${srcdir}/gnulib/gnulib-tool"
+ PATH="$PATH:${srcdir}/gnulib" \
+ ./autogen.sh --prefix='/usr'
+ else
+ ./configure --prefix='/usr'
fi
- ./configure --prefix='/usr'
fi
set +u
}