summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2017-08-27 14:09:12 -0400
committerChris Severance2017-08-27 14:09:12 -0400
commit1d8a2251ae5df468c573e645e83c3f65a8c3dd54 (patch)
treebcc8b8ccc3df60e231630716dec09ffa44c60987
parentf9e89b5b044dc5cdc7156f79e80bf657ee8b03ae (diff)
downloadaur-1d8a2251ae5df468c573e645e83c3f65a8c3dd54.tar.gz
Update to 1.16.5
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD37
2 files changed, 22 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 240c0c716a41..616c82650936 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
# Generated by mksrcinfo v8
-# Sat Jun 11 22:16:49 UTC 2016
+# Sun Aug 27 18:09:11 UTC 2017
pkgbase = le-git
pkgdesc = A text editor in memorial to Norton Editor with block and binary operations
- pkgver = 1.16.3.r0.g5bb2515
+ pkgver = 1.16.5.r0.g895395e
pkgrel = 1
url = https://github.com/lavv17/le
arch = i686
arch = x86_64
license = GPL3
makedepends = git
- provides = le=1.16.3
+ provides = le=1.16.5
conflicts = le
source = git://git.sv.gnu.org/gnulib
source = git://github.com/lavv17/le.git
diff --git a/PKGBUILD b/PKGBUILD
index 182be3a33059..a70787f3b2c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,20 +7,24 @@ set -u
_gitauth='lavv17'
_pkgname='le'
pkgname="${_pkgname}-git"
-pkgver=1.16.3.r0.g5bb2515
+pkgver=1.16.5.r0.g895395e
pkgrel=1
pkgdesc='A text editor in memorial to Norton Editor with block and binary operations'
arch=('i686' 'x86_64')
#url='https://directory.fsf.org/wiki/Le_editor'
url="https://github.com/${_gitauth}/${_pkgname}"
license=('GPL3')
+makedepends=('git')
_verwatch=("${url}/releases" "${url#*github.com}/archive/v\(.*\)\.tar\.gz" 'l')
_srcdir="${_pkgname}-${pkgver}"
#source=("http://fossies.org/linux/misc/${_pkgname}-${pkgver}.tar.xz")
#source=("http://lav.yar.ru/download/le/${_pkgname}-${pkgver}.tar.gz")
-source=('git://git.sv.gnu.org/gnulib' "${_pkgname}-${pkgver}.tar.gz::https://github.com/${_gitauth}/${_pkgname}/archive/v${pkgver}.tar.gz")
+source=(
+ 'git://git.sv.gnu.org/gnulib'
+ "${_pkgname}-${pkgver}.tar.gz::https://github.com/${_gitauth}/${_pkgname}/archive/v${pkgver}.tar.gz"
+)
sha256sums=('SKIP'
- '23a826afdea4fd43167367c25625ca52aaa2c941c1710990a6dc59fac7eddaed')
+ 'db4b8bea597d3814d22807f2b87d94e68a6bcdc586c9e94436af43ec058c1fa1')
if [ "${pkgname%-git}" != "${pkgname}" ]; then # this is easily done with case
unset _verwatch
@@ -39,23 +43,20 @@ pkgver() {
}
fi
-prepare() {
- set -u
- cd "${_srcdir}"
- if [ -s 'autogen.sh' ]; then
- #chmod 770 "${srcdir}/gnulib/gnulib-tool"
- PATH="$PATH:${srcdir}/gnulib" \
- ./autogen.sh --prefix='/usr'
- else
- ./configure --prefix='/usr'
- fi
- set +u
-}
-
build() {
set -u
cd "${_srcdir}"
- make -s -j "$(nproc)"
+ if [ ! -s 'Makefile' ]; then
+ if [ -s 'autogen.sh' ]; then
+ #chmod 770 "${srcdir}/gnulib/gnulib-tool"
+ PATH="$PATH:${srcdir}/gnulib" \
+ ./autogen.sh --prefix='/usr'
+ else
+ ./configure --prefix='/usr'
+ fi
+ fi
+ local _nproc="$(nproc)"; _nproc=$((_nproc>8?8:_nproc))
+ nice make -s -j "${_nproc}"
set +u
}
@@ -63,7 +64,7 @@ package() {
set -u
depends=('gcc-libs' 'ncurses')
cd "${_srcdir}"
- make DESTDIR="${pkgdir}" install
+ make -j1 DESTDIR="${pkgdir}" install
set +u
}
set +u