summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-08-03 18:37:12 +0800
committerSainnhepark2020-08-03 18:37:12 +0800
commit1fffac0048954588846d80e9685987b948449946 (patch)
treef0f67913b2d1316df4e1d20975273adb9c599d30
parentba56e87b7641ce0d92e71f67356faac76dd2cae0 (diff)
downloadaur-1fffac0048954588846d80e9685987b948449946.tar.gz
remove hook
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--leaderf-neovim-doc.hook11
-rw-r--r--leaderf-vim-doc.hook11
4 files changed, 4 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f661b2e308c5..0e350a53ff34 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,11 +8,7 @@ pkgbase = leaderf-git
makedepends = git
makedepends = python
source = leaderf::git+https://github.com/Yggdroot/LeaderF.git
- source = leaderf-vim-doc.hook
- source = leaderf-neovim-doc.hook
sha256sums = SKIP
- sha256sums = d125b79fe4f7e6d205010a96acf78ac63814c26d98050a46f8e627993ff033ea
- sha256sums = d7a7798ed8902de98c777f8770acd034e277f89478dc13eef77e491f2e99868d
pkgname = vim-leaderf-git
depends = vim
diff --git a/PKGBUILD b/PKGBUILD
index f1c859a45861..75bcb700732e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,12 +9,8 @@ pkgdesc='An efficient fuzzy finder that helps to locate files, buffers, mrus, gt
arch=('any')
url='https://github.com/Yggdroot/LeaderF'
license=('Apache')
-source=("${_pkgname}::git+https://github.com/Yggdroot/LeaderF.git"
- "${_pkgname}-vim-doc.hook"
- "${_pkgname}-neovim-doc.hook")
-sha256sums=('SKIP'
- 'd125b79fe4f7e6d205010a96acf78ac63814c26d98050a46f8e627993ff033ea'
- 'd7a7798ed8902de98c777f8770acd034e277f89478dc13eef77e491f2e99868d')
+source=("${_pkgname}::git+https://github.com/Yggdroot/LeaderF.git")
+sha256sums=('SKIP')
makedepends=('git'
'python')
@@ -26,7 +22,6 @@ pkgver() {
build() {
cd "${srcdir}/${_pkgname}"
bash install.sh
- touch doc/tags
}
package_vim-leaderf-git() {
@@ -37,11 +32,11 @@ package_vim-leaderf-git() {
_variant='vim'
cd "${srcdir}/${_pkgname}"
+ vim -es --cmd ":helptags doc" --cmd ":q"
find autoload doc plugin syntax -type f -exec \
install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
install -Dm 644 "${srcdir}/${_pkgname}/LICENSE" \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm 644 "${srcdir}/${_pkgname}-${_variant}-doc.hook" "${pkgdir}/usr/share/libalpm/hooks/${_pkgname}-${_variant}-doc.hook"
}
package_neovim-leaderf-git() {
@@ -52,9 +47,9 @@ package_neovim-leaderf-git() {
_variant='neovim'
cd "${srcdir}/${_pkgname}"
+ nvim -es --cmd ":helptags doc" --cmd ":q"
find autoload doc plugin syntax -type f -exec \
install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
install -Dm 644 "${srcdir}/${_pkgname}/LICENSE" \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm 644 "${srcdir}/${_pkgname}-${_variant}-doc.hook" "${pkgdir}/usr/share/libalpm/hooks/${_pkgname}-${_variant}-doc.hook"
}
diff --git a/leaderf-neovim-doc.hook b/leaderf-neovim-doc.hook
deleted file mode 100644
index 856b945cbb27..000000000000
--- a/leaderf-neovim-doc.hook
+++ /dev/null
@@ -1,11 +0,0 @@
-[Trigger]
-Operation = Install
-Operation = Upgrade
-Operation= Remove
-Type = Path
-Target = usr/local/share/nvim/site/pack/leaderf/start/leaderf/doc/
-
-[Action]
-Description = Updating Vim help tags...
-Exec = /usr/bin/nvim -es --cmd ":helptags /usr/local/share/nvim/site/pack/leaderf/start/leaderf/doc" --cmd ":q"
-When = PostTransaction
diff --git a/leaderf-vim-doc.hook b/leaderf-vim-doc.hook
deleted file mode 100644
index 63f0d0a4cad7..000000000000
--- a/leaderf-vim-doc.hook
+++ /dev/null
@@ -1,11 +0,0 @@
-[Trigger]
-Operation = Install
-Operation = Upgrade
-Operation= Remove
-Type = Path
-Target = usr/share/vim/vimfiles/pack/leaderf/start/leaderf/doc/
-
-[Action]
-Description = Updating Vim help tags...
-Exec = /usr/bin/vim -es --cmd ":helptags /usr/share/vim/vimfiles/pack/leaderf/start/leaderf/doc" --cmd ":q"
-When = PostTransaction