summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-12-25 17:58:28 +0800
committerzxp198210052023-12-25 17:58:28 +0800
commit33d2aa6181ddd6c3c518549ae9ea09883d6084b5 (patch)
tree7a4a3d7956332c52b9c73606c1749f10af797374
parentba4899c7c4110534a0e2fa3d8fd2db701e4b8461 (diff)
downloadaur-33d2aa6181ddd6c3c518549ae9ea09883d6084b5.tar.gz
update to 2.8.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD6
-rw-r--r--leafview.sh9
3 files changed, 15 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c83de25d2a2b..d791271dd040 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = leafview-bin
pkgdesc = A minimalist image viewer based on Leaflet.js and Electron.
- pkgver = 2.8.0
+ pkgver = 2.8.1
pkgrel = 1
url = https://github.com/sprout2000/leafview
arch = x86_64
license = MIT
depends = electron28
depends = hicolor-icon-theme
- provides = leafview=2.8.0
+ provides = leafview=2.8.1
conflicts = leafview
- source = leafview-2.8.0.deb::https://github.com/sprout2000/leafview/releases/download/v2.8.0/LeafView-2.8.0-linux-amd64.deb
- source = LICENSE-2.8.0.md::https://raw.githubusercontent.com/sprout2000/leafview/v2.8.0/LICENSE.md
+ source = leafview-2.8.1.deb::https://github.com/sprout2000/leafview/releases/download/v2.8.1/LeafView-2.8.1-linux-amd64.deb
+ source = LICENSE-2.8.1.md::https://raw.githubusercontent.com/sprout2000/leafview/v2.8.1/LICENSE.md
source = leafview.sh
- sha256sums = ef211546ccc2f7b417f59703439cfa7491c0326dc73593b680ec7d888d7da2be
+ sha256sums = f150fca4a201624792088c3a79c2ea30a7cf1776d81ff79d77d5f427697e591f
sha256sums = b68f9bc26df0993fe2680014cb2f0c968a910071d496be05fe040ebeaac84961
- sha256sums = 8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84
+ sha256sums = 5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf
pkgname = leafview-bin
diff --git a/PKGBUILD b/PKGBUILD
index f1b686f0dd4d..57819b2ee18c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=leafview-bin
_pkgname=LeafView
-pkgver=2.8.0
+pkgver=2.8.1
_electronversion=28
pkgrel=1
pkgdesc="A minimalist image viewer based on Leaflet.js and Electron."
@@ -19,9 +19,9 @@ source=(
"LICENSE-${pkgver}.md::https://raw.githubusercontent.com/sprout2000/leafview/v${pkgver}/LICENSE.md"
"${pkgname%-bin}.sh"
)
-sha256sums=('ef211546ccc2f7b417f59703439cfa7491c0326dc73593b680ec7d888d7da2be'
+sha256sums=('f150fca4a201624792088c3a79c2ea30a7cf1776d81ff79d77d5f427697e591f'
'b68f9bc26df0993fe2680014cb2f0c968a910071d496be05fe040ebeaac84961'
- '8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84')
+ '5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
diff --git a/leafview.sh b/leafview.sh
index 2ec4412e5c4f..c77c53567639 100644
--- a/leafview.sh
+++ b/leafview.sh
@@ -1,14 +1,17 @@
-#!/bin/bash
+#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
+_ASAR="${_APPDIR}/@appasar@"
export PATH="${_APPDIR}:${PATH}"
-export ELECTRON_IS_DEV=0
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
-_ASAR="${_APPDIR}/@appasar@"
+export ELECTRON_IS_DEV=0
+export NODE_ENV=production
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" "$@"
+ exit
else
cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
+ exit
fi \ No newline at end of file