summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-02-03 23:20:56 +0800
committerzxp198210052024-02-03 23:20:56 +0800
commit8860da728594a4391a17747ebfbe8f649fa45416 (patch)
treed1e5e413768df0993bdb4cf751f2a1b1b56e5916
parent5b0e7eae77e6c0e9753a9d4797d5dbccdd749e6b (diff)
downloadaur-8860da728594a4391a17747ebfbe8f649fa45416.tar.gz
update to 2.8.5
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD8
-rw-r--r--leafview.sh6
3 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 354563c49e63..8a4a3628f903 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = leafview-bin
pkgdesc = A minimalist image viewer based on Leaflet.js and Electron.
- pkgver = 2.8.4
+ pkgver = 2.8.5
pkgrel = 1
url = https://github.com/sprout2000/leafview
arch = x86_64
license = MIT
depends = electron28
depends = hicolor-icon-theme
- provides = leafview=2.8.4
+ provides = leafview=2.8.5
conflicts = leafview
- source = leafview-2.8.4.deb::https://github.com/sprout2000/leafview/releases/download/v2.8.4/LeafView-2.8.4-linux-amd64.deb
- source = LICENSE-2.8.4.md::https://raw.githubusercontent.com/sprout2000/leafview/v2.8.4/LICENSE.md
+ source = leafview-2.8.5.deb::https://github.com/sprout2000/leafview/releases/download/v2.8.5/LeafView-2.8.5-linux-amd64.deb
+ source = LICENSE-2.8.5.md::https://raw.githubusercontent.com/sprout2000/leafview/v2.8.5/LICENSE.md
source = leafview.sh
- sha256sums = 160c8c22314f890d852583bfb3d8450c19d5637f313fedc0951ec350ef2ba212
+ sha256sums = 76ae55dbe2d583c34672351e7d9b64bbd1a01daceca7a0f4058294e4097fb3db
sha256sums = 17db9845cf37bf3bd6b48095f3c87e40d25f3b48d4d0c38c2e740d45f024e56e
- sha256sums = 1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8
+ sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
pkgname = leafview-bin
diff --git a/PKGBUILD b/PKGBUILD
index faf8c42492f2..a7ca8a01244f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=leafview-bin
_pkgname=LeafView
-pkgver=2.8.4
+pkgver=2.8.5
_electronversion=28
pkgrel=1
pkgdesc="A minimalist image viewer based on Leaflet.js and Electron."
@@ -19,13 +19,13 @@ source=(
"LICENSE-${pkgver}.md::https://raw.githubusercontent.com/sprout2000/leafview/v${pkgver}/LICENSE.md"
"${pkgname%-bin}.sh"
)
-sha256sums=('160c8c22314f890d852583bfb3d8450c19d5637f313fedc0951ec350ef2ba212'
+sha256sums=('76ae55dbe2d583c34672351e7d9b64bbd1a01daceca7a0f4058294e4097fb3db'
'17db9845cf37bf3bd6b48095f3c87e40d25f3b48d4d0c38c2e740d45f024e56e'
- '1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8')
+ '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
- -e "s|@appasar@|app.asar|g" \
+ -e "s|@runname@|app.asar|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data.tar.xz"
sed "s|/opt/${_pkgname}/${pkgname%-bin}|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
diff --git a/leafview.sh b/leafview.sh
index 0d20cddc70ca..f9ced1432cfc 100644
--- a/leafview.sh
+++ b/leafview.sh
@@ -1,14 +1,14 @@
#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
-_ASAR="${_APPDIR}/@appasar@"
+_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_ASAR}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
else
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file