summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-09-21 18:25:53 +0800
committerzxp198210052023-09-21 18:25:53 +0800
commit9fdc28b172698e3313c312e82958c3b7dbf9aa28 (patch)
treebe910ed35a1ae82dec95460206667a772ee68583
parentcf5b9b7f29b740d2f2b7f55e342f82c19dc3c718 (diff)
downloadaur-9fdc28b172698e3313c312e82958c3b7dbf9aa28.tar.gz
update to 2.6.3
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
-rw-r--r--leafview.sh2
3 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 70f0e313c10c..60c38f417175 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = leafview-bin
pkgdesc = A minimalist image viewer based on Leaflet.js and Electron.
- pkgver = 2.6.2
+ pkgver = 2.6.3
pkgrel = 1
url = https://github.com/sprout2000/leafview
arch = x86_64
@@ -8,13 +8,13 @@ pkgbase = leafview-bin
depends = bash
depends = electron26
depends = hicolor-icon-theme
- provides = leafview=2.6.2
+ provides = leafview=2.6.3
conflicts = leafview
- source = leafview-2.6.2.deb::https://github.com/sprout2000/leafview/releases/download/v2.6.2/LeafView-2.6.2-linux-amd64.deb
- source = LICENSE::https://raw.githubusercontent.com/sprout2000/leafview/v2.6.2/LICENSE.md
+ source = leafview-2.6.3.deb::https://github.com/sprout2000/leafview/releases/download/v2.6.3/LeafView-2.6.3-linux-amd64.deb
+ source = LICENSE::https://raw.githubusercontent.com/sprout2000/leafview/v2.6.3/LICENSE.md
source = leafview.sh
- sha256sums = 1e51cdc88ee9ec390455eed535b6fc94b96d28c7d5eb31bd5e7f583d4f44d1c3
+ sha256sums = be7993cd8ae0418588044bde80bb7117dba9f52c2ad3e2216fbdb7b1eb82fe31
sha256sums = f172a0a7953ce3cda2b0cb38f6a3d28e7dfa9824a8c62de981520af32b9c138f
- sha256sums = f656dd4bcac72e33542483aeefaaea49d7fca6fcdf3ff0333081a35602c7568d
+ sha256sums = f82f53478b857c64d80fdbf56e24b9abef7961b13b60dd67a926a326b3934c33
pkgname = leafview-bin
diff --git a/PKGBUILD b/PKGBUILD
index 9b857dd673a1..e2cdf930c0a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=leafview-bin
_pkgname=LeafView
-pkgver=2.6.2
+pkgver=2.6.3
pkgrel=1
pkgdesc="A minimalist image viewer based on Leaflet.js and Electron."
arch=("x86_64")
@@ -13,16 +13,16 @@ depends=('bash' 'electron26' 'hicolor-icon-theme')
source=("${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${_pkgname}-${pkgver}-linux-amd64.deb"
"LICENSE::https://raw.githubusercontent.com/sprout2000/leafview/v${pkgver}/LICENSE.md"
"${pkgname%-bin}.sh")
-sha256sums=('1e51cdc88ee9ec390455eed535b6fc94b96d28c7d5eb31bd5e7f583d4f44d1c3'
+sha256sums=('be7993cd8ae0418588044bde80bb7117dba9f52c2ad3e2216fbdb7b1eb82fe31'
'f172a0a7953ce3cda2b0cb38f6a3d28e7dfa9824a8c62de981520af32b9c138f'
- 'f656dd4bcac72e33542483aeefaaea49d7fca6fcdf3ff0333081a35602c7568d')
-prepare() {
+ 'f82f53478b857c64d80fdbf56e24b9abef7961b13b60dd67a926a326b3934c33')
+build() {
bsdtar -xf "${srcdir}/data.tar.xz"
sed "s|/opt/${_pkgname}/${pkgname%-bin} %U|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
- install -Dm644 "${srcdir}/opt/${_pkgname}/resources/app.asar" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.asar"
+ install -Dm644 "${srcdir}/opt/${_pkgname}/resources/app.asar" -t "${pkgdir}/opt/${pkgname%-bin}/resources"
install -Dm644 "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
for _icons in 16x16 32x32 48x48 64x64 128x128 256x256 512x512 1024x1024;do
install -Dm644 "${srcdir}/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
diff --git a/leafview.sh b/leafview.sh
index 0b612c3ca9a1..a21c69e450df 100644
--- a/leafview.sh
+++ b/leafview.sh
@@ -1,6 +1,6 @@
#!/bin/bash
_ELECTRON=/usr/bin/electron26
-_ASAR="/opt/leafview/leafview.asar"
+_ASAR="/opt/leafview/resources/app.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
exec ${_ELECTRON} ${_ASAR} "$@"
else