summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-11-02 09:22:47 +0800
committerzxp198210052023-11-02 09:22:47 +0800
commita6b40c3191c845facc2c8d372bfc88c45463a56c (patch)
treec6cef8c0124462f428154fb05d754ce39ec68d8d
parent484bfcde3f5c73f0b46921820e8ce71c04460948 (diff)
downloadaur-a6b40c3191c845facc2c8d372bfc88c45463a56c.tar.gz
update to 2.7.3
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD20
-rw-r--r--leafview.sh5
3 files changed, 23 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 16cc596629d2..800f6161685d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = leafview-bin
pkgdesc = A minimalist image viewer based on Leaflet.js and Electron.
- pkgver = 2.7.2
+ pkgver = 2.7.3
pkgrel = 1
url = https://github.com/sprout2000/leafview
arch = x86_64
@@ -8,13 +8,13 @@ pkgbase = leafview-bin
depends = bash
depends = electron27
depends = hicolor-icon-theme
- provides = leafview=2.7.2
+ provides = leafview=2.7.3
conflicts = leafview
- source = leafview-2.7.2.deb::https://github.com/sprout2000/leafview/releases/download/v2.7.2/LeafView-2.7.2-linux-amd64.deb
- source = LICENSE::https://raw.githubusercontent.com/sprout2000/leafview/v2.7.2/LICENSE.md
+ source = leafview-2.7.3.deb::https://github.com/sprout2000/leafview/releases/download/v2.7.3/LeafView-2.7.3-linux-amd64.deb
+ source = LICENSE::https://raw.githubusercontent.com/sprout2000/leafview/v2.7.3/LICENSE.md
source = leafview.sh
- sha256sums = 20bf172489fa63d648488359ed692e7b822df9f1cff81c2e1108b2ab8662abe8
+ sha256sums = 5267940e5a6d4d16fdf7b69623be0355df8d5056b9532b08719cfd602bda5890
sha256sums = f172a0a7953ce3cda2b0cb38f6a3d28e7dfa9824a8c62de981520af32b9c138f
- sha256sums = 7db08f9d379e88437338bef85f056ec85be9ce542536529540d06a3fa2ffaa5b
+ sha256sums = 5735f93904fd117683d262d02b68075f1e779cf9130184f3cdfce5875e17e859
pkgname = leafview-bin
diff --git a/PKGBUILD b/PKGBUILD
index df6486276c28..dcf5b9da4fea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=leafview-bin
_pkgname=LeafView
-pkgver=2.7.2
+pkgver=2.7.3
pkgrel=1
pkgdesc="A minimalist image viewer based on Leaflet.js and Electron."
arch=("x86_64")
@@ -9,20 +9,26 @@ url="https://github.com/sprout2000/leafview"
license=('MIT')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
-depends=('bash' 'electron27' 'hicolor-icon-theme')
-source=("${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${_pkgname}-${pkgver}-linux-amd64.deb"
+depends=(
+ 'bash'
+ 'electron27'
+ 'hicolor-icon-theme'
+)
+source=(
+ "${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${_pkgname}-${pkgver}-linux-amd64.deb"
"LICENSE::https://raw.githubusercontent.com/sprout2000/leafview/v${pkgver}/LICENSE.md"
- "${pkgname%-bin}.sh")
-sha256sums=('20bf172489fa63d648488359ed692e7b822df9f1cff81c2e1108b2ab8662abe8'
+ "${pkgname%-bin}.sh"
+)
+sha256sums=('5267940e5a6d4d16fdf7b69623be0355df8d5056b9532b08719cfd602bda5890'
'f172a0a7953ce3cda2b0cb38f6a3d28e7dfa9824a8c62de981520af32b9c138f'
- '7db08f9d379e88437338bef85f056ec85be9ce542536529540d06a3fa2ffaa5b')
+ '5735f93904fd117683d262d02b68075f1e779cf9130184f3cdfce5875e17e859')
build() {
bsdtar -xf "${srcdir}/data.tar.xz"
sed "s|/opt/${_pkgname}/${pkgname%-bin} %U|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
- install -Dm644 "${srcdir}/opt/${_pkgname}/resources/app.asar" -t "${pkgdir}/opt/${pkgname%-bin}/resources"
+ install -Dm644 "${srcdir}/opt/${_pkgname}/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
install -Dm644 "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
for _icons in 16x16 32x32 48x48 64x64 128x128 256x256 512x512 1024x1024;do
install -Dm644 "${srcdir}/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
diff --git a/leafview.sh b/leafview.sh
index d141c2f19800..b0b8a55c0333 100644
--- a/leafview.sh
+++ b/leafview.sh
@@ -1,6 +1,9 @@
#!/bin/bash
_ELECTRON=/usr/bin/electron27
-_ASAR="/opt/leafview/resources/app.asar"
+APPDIR="/usr/lib/leafview"
+export PATH="${APPDIR}:${PATH}"
+#export LD_LIBRARY_PATH="${APPDIR}/lib:${LD_LIBRARY_PATH}"
+_ASAR="${APPDIR}/app.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
exec ${_ELECTRON} ${_ASAR} "$@"
else