summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwaaynee2023-11-05 21:14:46 +0100
committerwaaynee2023-11-05 21:14:46 +0100
commitd9e1982381dc1ffe194a96eae27386f94d464ad5 (patch)
tree3823fa3283eea25ba199bc546fcf8644fb1342f1
downloadaur-d9e1982381dc1ffe194a96eae27386f94d464ad5.tar.gz
Added league-dashboard-git
-rw-r--r--.SRCINFO17
-rwxr-xr-xPKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1184c4b86b59
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = league-dashboard-git
+ pkgdesc = A browser dashboard for League of Legends where you can track gold differences of your current game.
+ pkgver = r40.d7b53d9
+ pkgrel = 1
+ url = https://github.com/waaynee/LeagueDashboard
+ arch = x86_64
+ license = MIT
+ depends = git
+ depends = python-flask
+ depends = python-matplotlib
+ depends = python-requests
+ depends = python-waitress
+ provides = league-dashboard
+ source = git+https://github.com/waaynee/LeagueDashboard.git
+ md5sums = SKIP
+
+pkgname = league-dashboard-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..c9e6331532a3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: waayne
+pkgname=league-dashboard-git
+pkgver=r40.d7b53d9
+pkgrel=1
+pkgdesc="A browser dashboard for League of Legends where you can track gold differences of your current game."
+arch=('x86_64')
+conflicts=()
+provides=("league-dashboard")
+url="https://github.com/waaynee/LeagueDashboard"
+license=('MIT')
+depends=('git' 'python-flask' 'python-matplotlib' 'python-requests' 'python-waitress')
+source=("git+https://github.com/waaynee/LeagueDashboard.git")
+md5sums=('SKIP')
+
+_gitname=LeagueDashboard
+
+pkgver() {
+ cd "$(_gitname)"
+ ( set -o pipefail
+ git describe --long --abbrev=7 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+ )
+}
+
+package()
+{
+ cp -r "${srcdir}/LeagueDashboard" "/opt"
+}