summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-03-19 23:46:42 +0300
committerCaleb Maclennan2020-03-19 23:50:35 +0300
commitcabe3a7fbf77a8d3871b946eea4dabc75616f247 (patch)
treefe6689883d9f5a8684ebbd26518205b01aaef354
parent44bb802199441cc1524d92343ab6fff717a722c9 (diff)
downloadaur-cabe3a7fbf77a8d3871b946eea4dabc75616f247.tar.gz
Split meta package into ttf & otf variants
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD49
2 files changed, 48 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db5439849841..5cd48145c8ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,7 +4,9 @@ pkgbase = league-fonts
pkgrel = 2
url = https://www.theleagueofmoveabletype.com
arch = any
- license = custom:OFL
+ license = OFL
+
+pkgname = ttf-league-fonts
depends = ttf-league-spartan
depends = ttf-blackout
depends = ttf-linden-hill
@@ -18,10 +20,27 @@ pkgbase = league-fonts
depends = ttf-league-gothic
depends = ttf-league-mono
depends = ttf-knewave
- depends = ttf-league-script-number-one
+ depends = ttf-league-script
depends = ttf-orbitron
depends = ttf-goudy-bookletter-1911
depends = ttf-sniglet
-pkgname = league-fonts
+pkgname = otf-league-fonts
+ depends = otf-league-spartan
+ depends = otf-blackout
+ depends = otf-linden-hill
+ depends = otf-raleway
+ depends = otf-fanwood
+ depends = otf-sorts-mill-goudy
+ depends = otf-prociono
+ depends = otf-chunk
+ depends = otf-ostrich-sans
+ depends = otf-junction
+ depends = otf-league-gothic
+ depends = otf-league-mono
+ depends = otf-knewave
+ depends = otf-league-script
+ depends = otf-orbitron
+ depends = otf-goudy-bookletter-1911
+ depends = otf-sniglet
diff --git a/PKGBUILD b/PKGBUILD
index 152505e8a175..2dab1f6ca261 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,36 @@
# Maintainer: Caleb Maclennan <caleb@alerque.com>
# Contributor: samæ <samæ at marvid dot fr>
-pkgname=league-fonts
+pkgbase=league-fonts
+pkgname=(ttf-$pkgbase otf-$pkgbase)
pkgver=20171115
pkgrel=2
pkgdesc='A package depending on all the fonts from The League of Moveable Type'
arch=('any')
url='https://www.theleagueofmoveabletype.com'
-license=('custom:OFL')
-depends=('ttf-league-spartan'
- 'ttf-blackout'
- 'ttf-linden-hill'
- 'ttf-raleway'
- 'ttf-fanwood'
- 'ttf-sorts-mill-goudy'
- 'ttf-prociono'
- 'ttf-chunk'
- 'ttf-ostrich-sans'
- 'ttf-junction'
- 'ttf-league-gothic'
- 'ttf-league-mono'
- 'ttf-knewave'
- 'ttf-league-script-number-one'
- 'ttf-orbitron'
- 'ttf-goudy-bookletter-1911'
- 'ttf-sniglet')
-source=()
-sha256sums=()
+license=('OFL')
+_fonts=('league-spartan'
+ 'blackout'
+ 'linden-hill'
+ 'raleway'
+ 'fanwood'
+ 'sorts-mill-goudy'
+ 'prociono'
+ 'chunk'
+ 'ostrich-sans'
+ 'junction'
+ 'league-gothic'
+ 'league-mono'
+ 'knewave'
+ 'league-script'
+ 'orbitron'
+ 'goudy-bookletter-1911'
+ 'sniglet')
-package() {
- :
+package_ttf-league-fonts() {
+ depends=("${_fonts[@]/#/ttf-}")
+}
+
+package_otf-league-fonts() {
+ depends=("${_fonts[@]/#/otf-}")
}