summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-03-19 23:59:01 +0300
committerCaleb Maclennan2020-03-19 23:59:01 +0300
commitf2fc2137cdf12fac69f3546adb38e0f08cafd23f (patch)
tree372d0cca4d445c2a338459aeeda86c792e0b5142
parent14c937055d40ce638e48cf0f315ac30cb18a7709 (diff)
downloadaur-f2fc2137cdf12fac69f3546adb38e0f08cafd23f.tar.gz
Provide split ttf/otf packaging
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
2 files changed, 16 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a514c2c8ac9..c030174a6c18 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
-pkgbase = ttf-league-gothic
+pkgbase = league-gothic-font
pkgdesc = A revival of an old classic, Alternate Gothic #1
pkgver = 20160215
- pkgrel = 4
+ pkgrel = 5
url = https://theleagueofmoveabletype.com/league-gothic
arch = any
groups = lmt-fonts
license = OFL
provides = league-gothic-font
- conflicts = otf-league-gothic
source = ttf-league-gothic-20160215.zip::https://github.com/theleagueof/league-gothic/archive/e6dce2137410648b2229d5d4717de8c1cd5f9b97.zip
sha256sums = f4cc4f754568c4d2b70c3b52a6663677656ee88277901efcdf079b40e8158ab1
pkgname = ttf-league-gothic
+pkgname = otf-league-gothic
+
diff --git a/PKGBUILD b/PKGBUILD
index 067b054eebd4..a1dbf1f45c64 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,31 @@
# Contributor: samæ <samæ at marvid dot fr>
_fnt_name=league-gothic
-pkgname=ttf-$_fnt_name
+pkgbase=$_fnt_name-font
+pkgname=(ttf-$_fnt_name otf-$_fnt_name)
pkgver=20160215
# 20140319
_sha=e6dce2137410648b2229d5d4717de8c1cd5f9b97
-pkgrel=4
+pkgrel=5
pkgdesc='A revival of an old classic, Alternate Gothic #1'
arch=('any')
url="https://theleagueofmoveabletype.com/$_fnt_name"
license=('OFL')
groups=('lmt-fonts')
-provides=('league-gothic-font')
-conflicts=("otf-$_fnt_name")
+provides=("$_fnt_name-font")
source=("$pkgname-$pkgver.zip::https://github.com/theleagueof/$_fnt_name/archive/$_sha.zip")
sha256sums=('f4cc4f754568c4d2b70c3b52a6663677656ee88277901efcdf079b40e8158ab1')
-package() {
+package_ttf-league-gothic() {
cd "$_fnt_name-$_sha"
install -Dm644 -t "$pkgdir/usr/share/fonts/TTF/" webfonts/*.ttf
install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" Open\ Font\ License*.markdown
install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname/" readme.markdown
}
+
+package_otf-league-gothic() {
+ cd "$_fnt_name-$_sha"
+ install -Dm644 -t "$pkgdir/usr/share/fonts/TTF/" *.otf
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" Open\ Font\ License*.markdown
+ install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname/" readme.markdown
+}