summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeRieur2016-04-29 23:41:10 +0400
committerLeRieur2016-04-29 23:41:10 +0400
commit40c855c11c8d3f2c915a37c93378ad0a3a98ac3f (patch)
tree58d87194e5861c59231a461aca60ae7058e7ca2a
downloadaur-40c855c11c8d3f2c915a37c93378ad0a3a98ac3f.tar.gz
initial commit
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD50
-rwxr-xr-xleagueoflegends18
-rw-r--r--leagueoflegends.install11
4 files changed, 110 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1e7e25cf6d00
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = leagueoflegends
+ pkgdesc = A competitive online game set in an imaginative world (Riot Games)
+ pkgver = 20141509
+ pkgrel = 1
+ url = https://leagueoflegends.com
+ install = leagueoflegends.install
+ arch = any
+ makedepends = gendesk
+ makedepends = icoutils
+ depends = winetricks
+ depends = alsa-lib
+ depends = libldap
+ depends = lcms2
+ depends = gnutls
+ depends = mpg123
+ depends = lib32-alsa-lib
+ depends = lib32-libldap
+ depends = lib32-lcms2
+ depends = lib32-gnutls
+ depends = lib32-mpg123
+ optdepends = alsa-plugins
+ optdepends = libpulse
+ optdepends = lib32-alsa-plugins
+ optdepends = lib32-libpulse
+ source = https://riotgamespatcher-a.akamaihd.net/ShellInstaller/EUW/LeagueofLegends_EUW_Installer_9_15_2014.exe
+ source = leagueoflegends
+ sha1sums = c18abec07aea597e0b7b9453018da05f40a1a382
+ sha1sums = 32623d56c2a9e364fc5f682e37259c25f5f88b24
+
+pkgname = leagueoflegends
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d0005d2151e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+pkgname=leagueoflegends
+_pkgname='League of Legends'
+pkgver=20141509
+_pkgver=9_15_2014 # installer version
+pkgrel=1
+pkgdesc='A competitive online game set in an imaginative world (Riot Games)'
+url='https://leagueoflegends.com'
+arch=(any)
+depends=(winetricks alsa-lib libldap lcms2 gnutls mpg123)
+depends_x86_64=(lib32-alsa-lib lib32-libldap lib32-lcms2 lib32-gnutls lib32-mpg123)
+optdepends=(alsa-plugins libpulse)
+optdepends_x86_64=(lib32-alsa-plugins lib32-libpulse)
+makedepends=(gendesk icoutils)
+source=(https://riotgamespatcher-a.akamaihd.net/ShellInstaller/EUW/LeagueofLegends_EUW_Installer_$_pkgver.exe
+ leagueoflegends)
+sha1sums=('c18abec07aea597e0b7b9453018da05f40a1a382'
+ '32623d56c2a9e364fc5f682e37259c25f5f88b24')
+install=$pkgname.install
+
+prepare() {
+ cd $srcdir
+ gendesk -f -n \
+ --pkgname "$pkgname" \
+ --name "$_pkgname" \
+ --pkgdesc "$pkgdesc" \
+ --categories 'Wine;Games'
+}
+
+build() {
+ cd $srcdir
+ wine LeagueofLegends_*_Installer_9_15_2014.exe /extract
+ LD_PRELOAD=/usr/lib32/libjpeg.so.62 msiexec /i LoL.*.msi APPDIR=$(winepath -w $srcdir/LoL) /q
+}
+
+package() {
+ cd $srcdir
+ # games gid is 50
+ install -Dm755 -g 50 leagueoflegends $pkgdir/usr/bin/leagueoflegends
+ install -Dm755 leagueoflegends.desktop $pkgdir/usr/share/applications/leagueoflegends.desktop
+ cd $srcdir/LoL
+ install -dm775 -g 50 $pkgdir/var/games/{,$pkgname}
+ cp -r * $pkgdir/var/games/$pkgname
+ chgrp -R 50 $pkgdir/var/games/$pkgname
+ find $pkgdir/var/games/$pkgname -type d -exec chmod 775 {} +
+ find $pkgdir/var/games/$pkgname -type f -exec chmod 764 {} +
+ cd $srcdir
+ convert LoL/RADS/system/lol.ico lol.png
+ install -Dm644 lol-3.png $pkgdir/usr/share/pixmaps/$pkgname.png
+}
+
diff --git a/leagueoflegends b/leagueoflegends
new file mode 100755
index 000000000000..8a3b8a593dab
--- /dev/null
+++ b/leagueoflegends
@@ -0,0 +1,18 @@
+#!/usr/bin/env sh
+
+if [ ! -d $HOME/.leagueoflegends ]; then
+ mkdir -p $HOME/.leagueoflegends
+ ln -s /var/games/leagueoflegends/lol.launcher.admin.exe $HOME/.leagueoflegends
+ ln -s /var/games/leagueoflegends/lol.launcher.exe $HOME/.leagueoflegends
+ ln -s /var/games/leagueoflegends/RADS $HOME/.leagueoflegends
+fi
+
+[ $(uname -m) = 'x86_64' ] && export WINEARCH=win32 WINEPREFIX=$HOME/.wine32
+winetricks -q adobeair vcrun2005 vcrun2008 d3dx9 d3dx10 wininet corefonts
+#export WINEDLLOVERRIDES='' #dnsapi=' #,wininet='
+if [ $(uname -m) = 'x86_64' ]; then
+ LD_PRELOAD=/usr/lib32/libjpeg.so.62 wine $HOME/.leagueoflegends/lol.launcher.admin.exe
+else
+ wine $HOME/.leagueoflegends/lol.launcher.admin.exe
+fi
+
diff --git a/leagueoflegends.install b/leagueoflegends.install
new file mode 100644
index 000000000000..2d9d68a625ef
--- /dev/null
+++ b/leagueoflegends.install
@@ -0,0 +1,11 @@
+post_install() {
+ echo 'To use leagueoflegends as a normal user, add user to the games group:'
+ echo '# gpasswd -a $USER games'
+ echo 'To make your session aware of this new group without having to log in again, you can use this command before launching leagueoflegends:'
+ echo '$ newgrp games'
+}
+
+post_upgrade() {
+ post_install
+}
+