summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimofey Titovets2016-11-08 04:48:52 +0300
committerTimofey Titovets2016-11-08 04:48:52 +0300
commit00d6dbace1ace71b9e038daaf77c21b96103d891 (patch)
treed03dd7e777b982861897dd49b49980478f72c18e
downloadaur-00d6dbace1ace71b9e038daaf77c21b96103d891.tar.gz
Init
Signed-off-by: Timofey Titovets <nefelim4ag@gmail.com>
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD22
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6c5ce67fe172
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Tue Nov 8 01:48:32 UTC 2016
+pkgbase = ananicy-git
+ pkgdesc = League Of Legends: Install/Run wrapper
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/Nefelim4ag/League-Of-Legends
+ arch = any
+ license = GPL3
+ depends = wine-staging
+ depends = winetricks
+ depends = bash
+ source = ananicy-git::git://github.com/Nefelim4ag/League-Of-Legends.git#branch=master
+ md5sums = SKIP
+
+pkgname = ananicy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..beada1e5558e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Timofey Titovets <nefelim4ag@gmail.com>
+
+pkgname=ananicy-git
+pkgver=1.0
+pkgrel=1
+pkgdesc="League Of Legends: Install/Run wrapper"
+arch=('any')
+url="https://github.com/Nefelim4ag/League-Of-Legends"
+license=('GPL3')
+depends=('wine-staging' 'winetricks' 'bash')
+source=("$pkgname"::'git://github.com/Nefelim4ag/League-Of-Legends.git#branch=master')
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+package() {
+ cd "$srcdir/${pkgname}/"
+ ./install.sh PREFIX="$pkgdir"
+}