summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkyechou2020-12-24 13:15:29 -0600
committerkyechou2020-12-24 13:15:29 -0600
commit15cbd9683f3ec453b721063ff46a587f6430dec4 (patch)
tree3785e2b360c3aad913cf6049b3352200ed29a2f9
parent6188565bc711933f54743ef1efdab534bd203dae (diff)
downloadaur-15cbd9683f3ec453b721063ff46a587f6430dec4.tar.gz
Update versioning scheme
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8accdbb3161d..67c34391fb95 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = leagueoflegends-git
pkgdesc = League of Legends helper script
- pkgver = v0.10.12.r0.gc44d767
+ pkgver = 0.10.12.r0.gc44d767
pkgrel = 1
url = https://github.com/kyechou/leagueoflegends
arch = any
@@ -14,7 +14,7 @@ pkgbase = leagueoflegends-git
depends = lib32-libpulse
depends = wget
conflicts = leagueoflegends
- source = leagueoflegends-git::git+https://github.com/kyechou/leagueoflegends.git
+ source = leagueoflegends-git::git+https://github.com/kyechou/leagueoflegends
md5sums = SKIP
pkgname = leagueoflegends-git
diff --git a/PKGBUILD b/PKGBUILD
index 4c2a0a5ea7bc..c91d0c035977 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Timofey Titovets <nefelim4ag@gmail.com>
pkgname=leagueoflegends-git
-pkgver=v0.10.12.r0.gc44d767
+pkgver=0.10.12.r0.gc44d767
pkgrel=1
pkgdesc="League of Legends helper script"
arch=('any')
@@ -11,12 +11,16 @@ license=('GPL3')
depends=('wine-lol' 'winetricks' 'bash' 'lib32-gnutls' 'lib32-libldap'
'lib32-openal' 'lib32-libpulse' 'wget')
conflicts=('leagueoflegends')
-source=("$pkgname"::'git+https://github.com/kyechou/leagueoflegends.git')
+source=("$pkgname"::'git+https://github.com/kyechou/leagueoflegends')
md5sums=('SKIP')
pkgver() {
cd "$srcdir/$pkgname"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ if git describe --long --tags >/dev/null 2>&1; then
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ else
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git describe --always)"
+ fi
}
package() {