summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkyechou2018-12-02 20:02:40 -0600
committerkyechou2018-12-02 20:02:40 -0600
commita7acd99dc94610e31d07ba69e0cda88b1df79303 (patch)
treec85cf8a00e38c6f74dce6743c2ab345d5d61bd64
parentf64a621a0c3772d838418c8fd40e6671f2d1b659 (diff)
downloadaur-a7acd99dc94610e31d07ba69e0cda88b1df79303.tar.gz
Fix launcher and dependencies
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
-rw-r--r--leagueoflegends-git.install7
3 files changed, 10 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 194f24b97f2f..8af3dd72b9f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = leagueoflegends-git
pkgdesc = League Of Legends: Install/Run wrapper
- pkgver = 0.13.r14.g243a74d
+ pkgver = 0.13.r24.g08f238a
pkgrel = 1
url = https://github.com/Nefelim4ag/League-Of-Legends
- install = leagueoflegends-git.install
arch = any
license = GPL3
depends = wine
@@ -11,12 +10,11 @@ pkgbase = leagueoflegends-git
depends = bash
depends = lib32-gnutls
depends = lib32-libldap
+ depends = lib32-openal
+ depends = lib32-libpulse
depends = wget
- optdepends = lib32-libpulse: for audio
- optdepends = wine-staging: can work better
conflicts = leagueoflegends
- backup = etc/leagueoflegends.conf
- source = leagueoflegends-git::git://github.com/Nefelim4ag/League-Of-Legends.git#branch=master
+ source = leagueoflegends-git::git+https://github.com/Nefelim4ag/League-Of-Legends.git#branch=master
md5sums = SKIP
pkgname = leagueoflegends-git
diff --git a/PKGBUILD b/PKGBUILD
index b96b28fc89dc..6f4fc70ce373 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,24 @@
# Maintainer: Timofey Titovets <nefelim4ag@gmail.com>
pkgname=leagueoflegends-git
-pkgver=0.13.r14.g243a74d
+pkgver=0.13.r24.g08f238a
pkgrel=1
pkgdesc="League Of Legends: Install/Run wrapper"
arch=('any')
url="https://github.com/Nefelim4ag/League-Of-Legends"
license=('GPL3')
-depends=('wine' 'winetricks' 'bash' 'lib32-gnutls' 'lib32-libldap' 'wget')
-optdepends=('lib32-libpulse: for audio' 'wine-staging: can work better')
+depends=('wine' 'winetricks' 'bash' 'lib32-gnutls' 'lib32-libldap'
+ 'lib32-openal' 'lib32-libpulse' 'wget')
conflicts=('leagueoflegends')
-source=("$pkgname"::'git://github.com/Nefelim4ag/League-Of-Legends.git#branch=master')
+source=("$pkgname"::'git+https://github.com/Nefelim4ag/League-Of-Legends.git#branch=master')
md5sums=('SKIP')
-install=leagueoflegends-git.install
-backup=("etc/leagueoflegends.conf")
pkgver() {
- cd "$pkgname"
+ cd "$srcdir/$pkgname"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
- cd "$srcdir/${pkgname}/"
+ cd "$srcdir/$pkgname"
make install PREFIX="$pkgdir"
}
diff --git a/leagueoflegends-git.install b/leagueoflegends-git.install
deleted file mode 100644
index 4da592f66f42..000000000000
--- a/leagueoflegends-git.install
+++ /dev/null
@@ -1,7 +0,0 @@
-post_install(){
- echo "Take a Look at /etc/leagueoflegends.conf"
-}
-
-post_upgrade(){
- post_install
-}