summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatěj Grabovský2015-07-12 13:07:06 +0200
committerMatěj Grabovský2015-07-12 13:07:06 +0200
commit1b6498d9632705dba32d47128a0596f257d86119 (patch)
treed7db46c3573ee97d9d6f86dc217e36e8c3e1bbb0
downloadaur-1b6498d9632705dba32d47128a0596f257d86119.tar.gz
Transfer from old AUR
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD26
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..68db74f08cef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = lean-bin
+ pkgdesc = Lean Theorem Prover
+ pkgver = 0.2.0.20150430101621
+ pkgrel = 1
+ url = http://leanprover.github.io/
+ arch = x86_64
+ arch = i386
+ groups = base-devel
+ license = Apache
+ depends = lua>=5.2
+ optdepends = emacs: emacs mode
+ optdepends = ninja
+ conflicts = lean-git
+ source_x86_64 = https://launchpad.net/~leanprover/+archive/ubuntu/lean/+files/lean_0.2.0.20150430101621.gite8d894473ed8d57cdf2616e6aa1b7df1c589a6ca~14.10_amd64.deb
+ md5sums_x86_64 = 3318ee697f2b193d642336d3a2b79716
+ source_i386 = https://launchpad.net/~leanprover/+archive/ubuntu/lean/+files/lean_0.2.0.20150430101621.gite8d894473ed8d57cdf2616e6aa1b7df1c589a6ca~14.10_i386.deb
+ md5sums_i386 = 234c0cc6ea8019c61b86eb80fd7b6bd2
+
+pkgname = lean-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9058e3c43fc1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Matej Grabovsky <matej.grabovsky at gmail>
+# Contributor: Naman Bharadwaj <namanbharadwaj@gmail.com>
+
+pkgname=lean-bin
+pkgver=0.2.0.20150430101621
+pkgrel=1
+pkgdesc="Lean Theorem Prover"
+arch=('x86_64' 'i386')
+url="http://leanprover.github.io/"
+license=('Apache')
+groups=('base-devel')
+depends=('lua>=5.2')
+optdepends=('emacs: emacs mode' 'ninja')
+conflicts=('lean-git')
+source_x86_64=("https://launchpad.net/~leanprover/+archive/ubuntu/lean/+files/lean_0.2.0.20150430101621.gite8d894473ed8d57cdf2616e6aa1b7df1c589a6ca~14.10_amd64.deb")
+source_i386=("https://launchpad.net/~leanprover/+archive/ubuntu/lean/+files/lean_0.2.0.20150430101621.gite8d894473ed8d57cdf2616e6aa1b7df1c589a6ca~14.10_i386.deb")
+md5sums_x86_64=('3318ee697f2b193d642336d3a2b79716')
+md5sums_i386=('234c0cc6ea8019c61b86eb80fd7b6bd2')
+
+package() {
+ mkdir -p "$pkgname-$pkgver"
+ tar xf data.tar.xz -C "$pkgname-$pkgver"
+ find "$pkgname-$pkgver" -exec chmod 755 {} \;
+ cp -r "$pkgname-$pkgver"/* "$pkgdir"
+ ln -s /usr/lib/liblua.so "$pkgdir"/usr/lib/liblua5.2.so.0
+}