summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjmboris2015-07-06 23:11:32 +0200
committerjmboris2015-07-06 23:11:32 +0200
commitfeaae0b57b347f459d58981221f2b9cd9a669c2c (patch)
tree8ffa94e2c2350e3d3101462b271c6d9cf2ba07b1
downloadaur-feaae0b57b347f459d58981221f2b9cd9a669c2c.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD28
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..498371ff3ca6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = leanify
+ pkgdesc = lightweight lossless file minifier/optimizer
+ pkgver = 0.4.2
+ pkgrel = 1
+ url = https://github.com/JayXon/Leanify
+ arch = i686
+ arch = x86_64
+ license = MIT
+ source = https://github.com/JayXon/Leanify/releases/download/v0.4.2/leanify_linux32.tgz
+ md5sums = 826fffef7c07986e1a3c6427ea66938a
+
+pkgname = leanify
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d5e03141bdf2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+#Leanify was created by JayXon
+#https://github.com/JayXon
+#
+# aur package by: Juan Jaramillo <jmboris at gmail dot com>
+
+pkgname=leanify
+pkgver=0.4.2
+pkgrel=1
+pkgdesc="lightweight lossless file minifier/optimizer"
+arch=('i686' 'x86_64')
+url="https://github.com/JayXon/Leanify"
+license=('MIT')
+if [ ${CARCH} == 'x86_64' ]
+then
+source=(https://github.com/JayXon/Leanify/releases/download/v${pkgver}/leanify_linux64.tgz)
+md5sums=('8e57cfb818d14b942e6fda4b5d224b31')
+else
+source=(https://github.com/JayXon/Leanify/releases/download/v${pkgver}/leanify_linux32.tgz)
+md5sums=('826fffef7c07986e1a3c6427ea66938a')
+fi
+
+package() {
+
+ cd "$pkgdir"
+ install -dm 755 "$pkgdir/usr/bin/"
+ install -m755 "$srcdir/leanify" "$pkgdir/usr/bin/"
+
+}