summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Zhang2021-01-06 14:29:37 -0600
committerMichael Zhang2021-01-06 14:29:37 -0600
commite124b4bf47331ba4100517eb03fb2250bd304bf2 (patch)
tree0fd2d61c94091cded2c903cfed3dd8408f8150ba
downloadaur-e124b4bf47331ba4100517eb03fb2250bd304bf2.tar.gz
Adding leanshot v0.4.1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..54d2914c3ba8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = leanshot
+ pkgdesc = Screen capture for Linux.
+ pkgver = 0.4.1
+ pkgrel = 1
+ url = https://git.mzhang.io/michael/leanshot
+ arch = any
+ license = MIT
+ depends = rust
+ depends = python3
+ depends = libxcb
+ depends = xcb-util-image
+ source = https://git.mzhang.io/michael/leanshot/archive/v0.4.1.tar.gz
+ sha256sums = d0bb027e2205d36c827fdc30ac3ca7a833526773a735f63c94f5ab6af716c587
+
+pkgname = leanshot
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..08032f70dfee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Michael Zhang <mail@mzhang.io>
+
+pkgname=leanshot
+pkgver=0.4.1
+pkgrel=1
+pkgdesc='Screen capture for Linux.'
+url='https://git.mzhang.io/michael/leanshot'
+arch=('any')
+license=('MIT')
+depends=('rust' 'python3' 'libxcb' 'xcb-util-image')
+source=("https://git.mzhang.io/michael/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('d0bb027e2205d36c827fdc30ac3ca7a833526773a735f63c94f5ab6af716c587')
+
+build() {
+ cd "${pkgname}"
+ cargo build --release --locked --all-features --target-dir=target
+}
+
+package() {
+ cd "${pkgname}"
+ install -Dm 755 target/release/${pkgname} -t ${pkgdir}/usr/bin
+}