summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHe Qing(robot)2022-10-03 19:29:56 +0800
committerHe Qing(robot)2022-10-03 19:29:56 +0800
commit21bf1e4af74a7e72ab079f495c787757fff6b4bb (patch)
tree4689e212638bbb3083a43c963d1228a480e43666
parentff049860d6fd31a02c2004add4d5f0c7ef38afb0 (diff)
downloadaur-21bf1e4af74a7e72ab079f495c787757fff6b4bb.tar.gz
auto update to 0.15.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rwxr-xr-xauto_update_version.sh5
3 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4587daccf9c8..09f86a7d6ff4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = leapp-bin
pkgdesc = Leapp is a Desktop DevTool that handles the management and security of your cloud credentials for you, converted from .deb package
- pkgver = 0.14.3
+ pkgver = 0.15.0
pkgrel = 1
url = https://www.leapp.cloud/
arch = x86_64
@@ -17,7 +17,7 @@ pkgbase = leapp-bin
depends = at-spi2-core
depends = aws-session-manager-plugin
provides = leapp
- source = Leapp_0.14.3_amd64.deb::https://asset.noovolari.com/0.14.3/Leapp_0.14.3_amd64.deb
- sha512sums = 0ca27278626610b32c5fa0f6f150230af04a0169b66da7b595689aaec2042cdba665e9d4b0a106e6d9547bbdc5cfed6773387a6701e084696cdeabf53e97dcdb
+ source = Leapp_0.15.0_amd64.deb::https://asset.noovolari.com/0.15.0/Leapp_0.15.0_amd64.deb
+ sha512sums = 7c455cc813d991fa4900be5877125638c9010ce543b23f68315f48365bef71aeeb9fb4de665281cd963f41f3ad56b2aead21623ac476c508865e38170c0b8630
pkgname = leapp-bin
diff --git a/PKGBUILD b/PKGBUILD
index f85fa91bf1f6..ffdc88fd198d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=leapp-bin
_pkgname=leapp
-pkgver=0.14.3
+pkgver=0.15.0
_pkgdate=20220112
pkgrel=1
pkgdesc="Leapp is a Desktop DevTool that handles the management and security of your cloud credentials for you, converted from .deb package"
@@ -14,7 +14,7 @@ provides=("$_pkgname")
source=(
"Leapp_${pkgver}_amd64.deb::https://asset.noovolari.com/${pkgver}/Leapp_${pkgver}_amd64.deb"
)
-sha512sums=('0ca27278626610b32c5fa0f6f150230af04a0169b66da7b595689aaec2042cdba665e9d4b0a106e6d9547bbdc5cfed6773387a6701e084696cdeabf53e97dcdb')
+sha512sums=('7c455cc813d991fa4900be5877125638c9010ce543b23f68315f48365bef71aeeb9fb4de665281cd963f41f3ad56b2aead21623ac476c508865e38170c0b8630')
package() {
cd ${srcdir}
diff --git a/auto_update_version.sh b/auto_update_version.sh
index 6346378adce0..db4de2cf47ed 100755
--- a/auto_update_version.sh
+++ b/auto_update_version.sh
@@ -21,7 +21,10 @@ else
fi
done
rm -f Leapp_*_amd64.deb
- wget https://asset.noovolari.com/${github_ver}/Leapp_${github_ver}_amd64.deb || echo "can't download https://asset.noovolari.com/${github_ver}/Leapp_${github_ver}_amd64.deb" && exit 3
+ wget https://asset.noovolari.com/${github_ver}/Leapp_${github_ver}_amd64.deb
+ if [ $? -ne 0 ]; then
+ echo "can't download https://asset.noovolari.com/${github_ver}/Leapp_${github_ver}_amd64.deb" && exit 3
+ fi
sha512sum=$(sha512sum Leapp_${github_ver}_amd64.deb | awk '{printf $1}')
cp PKGBUILD.tpl PKGBUILD
cp .SRCINFO.tpl .SRCINFO