summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHe Qing(robot)2023-06-15 15:23:02 +0800
committerHe Qing(robot)2023-06-15 15:24:16 +0800
commit7c94a5577775d64bc3c827695e908528746f8bc8 (patch)
treee94f667f2a7eec6deda87454cb0c6188a94a0950
parent95015038a3feb272fedf41bc2e8c08ad6f526b20 (diff)
downloadaur-7c94a5577775d64bc3c827695e908528746f8bc8.tar.gz
update script
-rwxr-xr-xauto_update_version.sh8
1 files changed, 4 insertions, 4 deletions
diff --git a/auto_update_version.sh b/auto_update_version.sh
index db4de2cf47ed..d6b8959c2d25 100755
--- a/auto_update_version.sh
+++ b/auto_update_version.sh
@@ -20,12 +20,12 @@ else
echo "looks like the latest release from github is already exist." && exit 2
fi
done
- rm -f Leapp_*_amd64.deb
- wget https://asset.noovolari.com/${github_ver}/Leapp_${github_ver}_amd64.deb
+ rm -f /tmp/Leapp_*_amd64.deb
+ wget https://asset.noovolari.com/${github_ver}/Leapp_${github_ver}_amd64.deb -O /tmp/Leapp_${github_ver}_amd64.deb
if [ $? -ne 0 ]; then
echo "can't download https://asset.noovolari.com/${github_ver}/Leapp_${github_ver}_amd64.deb" && exit 3
fi
- sha512sum=$(sha512sum Leapp_${github_ver}_amd64.deb | awk '{printf $1}')
+ sha512sum=$(sha512sum /tmp/Leapp_${github_ver}_amd64.deb | awk '{printf $1}')
cp PKGBUILD.tpl PKGBUILD
cp .SRCINFO.tpl .SRCINFO
sed -i "s/VERSION/${github_ver}/g" PKGBUILD
@@ -35,6 +35,6 @@ else
git add .SRCINFO PKGBUILD
git commit -m "auto update to ${github_ver}"
git push
- rm -f Leapp_${github_ver}_amd64.deb
+ rm -f /tmp/Leapp_${github_ver}_amd64.deb
echo "${github_ver}" >> exist_vers
fi