summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHe Qing2024-01-11 17:56:38 +0800
committerHe Qing2024-01-11 17:56:38 +0800
commitdfb955b72f8021217e00156df659c96702a6da04 (patch)
tree007d3421223bf0a3191d68f3847a2fd9fc8b9a40
parent57e0ffd91104678139e4f8baec069e5063baca40 (diff)
downloadaur-dfb955b72f8021217e00156df659c96702a6da04.tar.gz
remove unused files
-rw-r--r--.SRCINFO.tpl23
-rw-r--r--PKGBUILD.tpl22
-rwxr-xr-xauto_update_version.sh40
3 files changed, 0 insertions, 85 deletions
diff --git a/.SRCINFO.tpl b/.SRCINFO.tpl
deleted file mode 100644
index b8dbd100ec21..000000000000
--- a/.SRCINFO.tpl
+++ /dev/null
@@ -1,23 +0,0 @@
-pkgbase = leapp-bin
- pkgdesc = Leapp is a Desktop DevTool that handles the management and security of your cloud credentials for you, converted from .deb package
- pkgver = VERSION
- pkgrel = 1
- url = https://www.leapp.cloud/
- arch = x86_64
- license = custom
- depends = gtk3
- depends = libxss
- depends = libnotify
- depends = nss
- depends = libxss
- depends = libxtst
- depends = xdg-utils
- depends = util-linux-libs
- depends = libsecret
- depends = at-spi2-core
- depends = aws-session-manager-plugin
- provides = leapp
- source = Leapp_VERSION_amd64.deb::https://asset.noovolari.com/VERSION/Leapp_VERSION_amd64.deb
- sha512sums = SHA512SUMS
-
-pkgname = leapp-bin
diff --git a/PKGBUILD.tpl b/PKGBUILD.tpl
deleted file mode 100644
index 0d1f7609449d..000000000000
--- a/PKGBUILD.tpl
+++ /dev/null
@@ -1,22 +0,0 @@
-# Maintainer: He Qing <qing@he.email>
-
-pkgname=leapp-bin
-_pkgname=leapp
-pkgver=VERSION
-_pkgdate=20220112
-pkgrel=1
-pkgdesc="Leapp is a Desktop DevTool that handles the management and security of your cloud credentials for you, converted from .deb package"
-arch=("x86_64")
-url="https://www.leapp.cloud/"
-license=('custom')
-depends=('gtk3' 'libxss' 'libnotify' 'nss' 'libxss' 'libxtst' 'xdg-utils' 'util-linux-libs' 'libsecret' 'at-spi2-core' 'aws-session-manager-plugin')
-provides=("$_pkgname")
-source=(
- "Leapp_${pkgver}_amd64.deb::https://asset.noovolari.com/${pkgver}/Leapp_${pkgver}_amd64.deb"
-)
-sha512sums=('SHA512SUMS')
-
-package() {
- cd ${srcdir}
- tar -xvf data.tar.xz -C "${pkgdir}"
-}
diff --git a/auto_update_version.sh b/auto_update_version.sh
deleted file mode 100755
index d6b8959c2d25..000000000000
--- a/auto_update_version.sh
+++ /dev/null
@@ -1,40 +0,0 @@
-#!/bin/bash
-# use crontab to auto update version
-# */7 * * * * ./auto_update_version.sh
-# get the latest release from github and commit change to aur
-
-cd $( dirname -- "$( readlink -f -- "$0" )" )
-
-aur_ver=$(cat PKGBUILD | grep "^pkgver=" | sed 's/pkgver=//')
-github_ver=$(curl --max-time 5 -sL https://api.github.com/repos/Noovolari/leapp/releases/latest | jq -r ".tag_name" | sed 's/v//g')
-
-if [ -z ${github_ver} ] || [ -z ${aur_ver} ]; then
- echo "runing error, could not get the right version" && exit 1
-fi
-
-if [ "${aur_ver}" == "${github_ver}" ]; then
- echo "leapp in aur already has the latest version."
-else
- for exist_ver in `cat exist_vers`; do
- if [ "${exist_ver}" == "${github_ver}" ]; then
- echo "looks like the latest release from github is already exist." && exit 2
- fi
- done
- rm -f /tmp/Leapp_*_amd64.deb
- wget https://asset.noovolari.com/${github_ver}/Leapp_${github_ver}_amd64.deb -O /tmp/Leapp_${github_ver}_amd64.deb
- if [ $? -ne 0 ]; then
- echo "can't download https://asset.noovolari.com/${github_ver}/Leapp_${github_ver}_amd64.deb" && exit 3
- fi
- sha512sum=$(sha512sum /tmp/Leapp_${github_ver}_amd64.deb | awk '{printf $1}')
- cp PKGBUILD.tpl PKGBUILD
- cp .SRCINFO.tpl .SRCINFO
- sed -i "s/VERSION/${github_ver}/g" PKGBUILD
- sed -i "s/VERSION/${github_ver}/g" .SRCINFO
- sed -i "s/SHA512SUMS/${sha512sum}/g" PKGBUILD
- sed -i "s/SHA512SUMS/${sha512sum}/g" .SRCINFO
- git add .SRCINFO PKGBUILD
- git commit -m "auto update to ${github_ver}"
- git push
- rm -f /tmp/Leapp_${github_ver}_amd64.deb
- echo "${github_ver}" >> exist_vers
-fi