summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-04-24 08:29:31 +0300
committerDimitris Kiziridis2020-04-24 08:29:31 +0300
commit8e17a59d9e888f7c09b90aa0319558e55f414819 (patch)
treea2c3b053bdd9e6dc4327c852c53910a9cc869142
downloadaur-8e17a59d9e888f7c09b90aa0319558e55f414819.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD17
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5bf3ba7a5281
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = leaps-bin
+ pkgdesc = A service for collaboratively editing your local files over a web UI, using operational transforms to ensure zero-collision synchronization across any number of editing clients
+ pkgver = 0.9.0
+ pkgrel = 1
+ url = https://github.com/Jeffail/leaps
+ arch = x86_64
+ license = MIT
+ provides = leaps
+ source = https://github.com/Jeffail/leaps/releases/download/v0.9.0/leaps_linux_amd64.tar.gz
+ sha256sums = 81a4dbb42fecf25b6728ba6ebc1225bb2e65ae949e8d0827e629c95acd463765
+
+pkgname = leaps-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..29d000994445
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=leaps-bin
+pkgver=0.9.0
+pkgrel=1
+pkgdesc="A service for collaboratively editing your local files over a web UI, using operational transforms to ensure zero-collision synchronization across any number of editing clients"
+arch=('x86_64')
+url='https://github.com/Jeffail/leaps'
+license=('MIT')
+provides=("${pkgname%-bin}")
+source=("${url}/releases/download/v${pkgver}/leaps_linux_amd64.tar.gz")
+sha256sums=('81a4dbb42fecf25b6728ba6ebc1225bb2e65ae949e8d0827e629c95acd463765')
+
+package() {
+ install -Dm755 "${srcdir}/${pkgname%-bin}_linux_amd64/bin/${pkgname%-bin}" \
+ "${pkgdir}/usr/bin/${pkgname%-bin}"
+} \ No newline at end of file