summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Merritt2018-05-11 09:44:46 -0700
committerBen Merritt2018-05-11 09:44:46 -0700
commitae7ace8ff78e6d4aea3d2d5197f4d13715c07267 (patch)
tree5c77ced0dc45cfda99e377d113aa55b8e5844a74
downloadaur-ae7ace8ff78e6d4aea3d2d5197f4d13715c07267.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD37
-rw-r--r--lectrote.desktop12
4 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6bd4d04993fa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = lectrote-bin
+ pkgdesc = The IF interpreter in an Electron shell (binary release)
+ pkgver = 1.3.1
+ pkgrel = 1
+ url = https://github.com/erkyrath/lectrote
+ arch = x86_64
+ license = MIT
+ depends = alsa-lib
+ depends = gconf
+ depends = gtk2
+ depends = libxtst
+ depends = libxss
+ depends = nss
+ provides = lectrote
+ source = https://github.com/erkyrath/lectrote/releases/download/lectrote-1.3.1/Lectrote-1.3.1-linux-x64.zip
+ source = lectrote.desktop
+ sha256sums = 67ae0d558f9a0bd2bdb9c76ab8e9d3ea89471f7c5ea7e28c63721cbfa4014e52
+ sha256sums = e7f8337c31734369daccef73ffbd6cf2f961998409edf355341ae13f2f7a5d7c
+
+pkgname = lectrote-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9e24cc4b36e9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*.zip
+/*.tar.xz
+/pkg
+/src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..89cb6b68e059
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Benjamin L. Merritt <blm768@gmail.com>
+pkgname=lectrote-bin
+pkgver=1.3.1
+pkgrel=1
+pkgdesc="The IF interpreter in an Electron shell (binary release)"
+arch=('x86_64')
+url="https://github.com/erkyrath/lectrote"
+license=('MIT')
+depends=('alsa-lib' 'gconf' 'gtk2' 'libxtst' 'libxss' 'nss')
+makedepends=()
+provides=('lectrote')
+install=
+changelog=
+source=(
+ "https://github.com/erkyrath/lectrote/releases/download/lectrote-$pkgver/Lectrote-$pkgver-linux-x64.zip"
+ "lectrote.desktop"
+)
+sha256sums=(
+ "67ae0d558f9a0bd2bdb9c76ab8e9d3ea89471f7c5ea7e28c63721cbfa4014e52"
+ "e7f8337c31734369daccef73ffbd6cf2f961998409edf355341ae13f2f7a5d7c"
+)
+
+package() {
+ cd Lectrote-linux-x64
+ _destdir="$pkgdir/usr/share/lectrote/"
+ mkdir -p "$_destdir"
+ cp -r * "$_destdir"
+ chmod a+x "$_destdir/Lectrote"
+
+ _licensedir="$pkgdir/usr/share/licenses/$pkgname"
+ mkdir -p "$_licensedir"
+ install -m 0644 LICENSE "$_licensedir"
+
+ mkdir -p "$pkgdir/usr/share/applications"
+ install -m 0644 ../lectrote.desktop "$pkgdir/usr/share/applications"
+}
+
diff --git a/lectrote.desktop b/lectrote.desktop
new file mode 100644
index 000000000000..bed6a19113ad
--- /dev/null
+++ b/lectrote.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+
+Type=Application
+Version=1.0
+Name=Lectrote
+GenericName=Interactive Fiction Player
+Comment=
+Path=/usr/share/lectrote
+Exec=Lectrote
+Icon=/usr/share/lectrote/resources/app/icon-128.png
+Terminal=false
+Categories=Games