summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Kojevnikov2016-01-15 19:27:45 +1000
committerAndrey Kojevnikov2016-01-15 19:27:45 +1000
commit0782681d5e71ed526ca44a2d47f5632e3896b464 (patch)
tree08a1a90cec0e57abb4c8134536712fa7123f186a
parent289848e80ea397711b1a1a895434c13577ac2148 (diff)
downloadaur-0782681d5e71ed526ca44a2d47f5632e3896b464.tar.gz
3.1.1
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD22
-rw-r--r--ledger.install17
-rw-r--r--ledger_git.diff105
4 files changed, 15 insertions, 150 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca57d6e3cc09..34060007da89 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,21 @@
+# Generated by mksrcinfo v8
+# Fri Jan 15 09:26:53 UTC 2016
pkgbase = ledger
pkgdesc = A double-entry accounting system with a command-line reporting interface.
- pkgver = 3.1
- pkgrel = 2
+ pkgver = 3.1.1
+ pkgrel = 1
url = http://www.ledger-cli.org
- install = ledger.install
arch = i686
arch = x86_64
license = BSD
makedepends = cmake
- makedepends = git
makedepends = python
- makedepends = texinfo
- makedepends = texlive-plainextra
- makedepends = icu>=55
depends = boost>=1.49
+ depends = gmp>=4.2.2
depends = mpfr>=2.4.0
- depends = pcre
- depends = expat
- depends = libedit
options = !libtool
- source = ledger-3.1.tar.gz::https://github.com/ledger/ledger/archive/v3.1.tar.gz
- source = ledger_git.diff
- md5sums = f4389aae3ba96eb5590784db7fa614ca
- md5sums = 8b7c6a5727d8ccc0e60851da7df9fbbb
+ source = ledger-3.1.1.tar.gz::https://github.com/ledger/ledger/archive/v3.1.1.tar.gz
+ md5sums = eae070cbbc1a40a277f1394d72ef0fe6
pkgname = ledger
diff --git a/PKGBUILD b/PKGBUILD
index 902c520179f1..5d4ea55ecd95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,34 +4,28 @@
# Contributor: Nathan Jones <nathanj at insightbb dot com>
pkgname=ledger
-pkgver=3.1
-pkgrel=2
+pkgver=3.1.1
+pkgrel=1
pkgdesc='A double-entry accounting system with a command-line reporting interface.'
arch=('i686' 'x86_64')
url='http://www.ledger-cli.org'
license=('BSD')
-depends=('boost>=1.49' 'mpfr>=2.4.0' 'pcre' 'expat' 'libedit')
-makedepends=('cmake' 'git' 'python' 'texinfo' 'texlive-plainextra' 'icu>=55')
+depends=('boost>=1.49' 'gmp>=4.2.2' 'mpfr>=2.4.0')
+makedepends=('cmake' 'python')
options=('!libtool')
-install="${pkgname}.install"
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ledger/${pkgname}/archive/v${pkgver}.tar.gz"
- 'ledger_git.diff')
-md5sums=('f4389aae3ba96eb5590784db7fa614ca'
- '8b7c6a5727d8ccc0e60851da7df9fbbb')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ledger/${pkgname}/archive/v${pkgver}.tar.gz")
+md5sums=('eae070cbbc1a40a277f1394d72ef0fe6')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- git clone --depth=1 https://github.com/${pkgname}/utfcpp.git lib/utfcpp # submodule excluded
- patch -Np1 -i ../ledger_git.diff # https://groups.google.com/forum/#!topic/ledger-cli/BMYK_bupv5Y
./acprep --prefix=/usr opt update
- cmake ./ -DCMAKE_INSTALL_LIBDIR=/usr/lib -DBUILD_EMACSLISP:BOOL=ON -DBUILD_DOCS:BOOL=ON
- make doc
+ cmake ./ -DCMAKE_INSTALL_LIBDIR=/usr/lib -DBUILD_EMACSLISP:BOOL=ON -DUSE_PYTHON:BOOL=ON -DBUILD_DOCS:BOOL=OFF
}
package() {
cd ${srcdir}/${pkgname}-${pkgver}
make DESTDIR=${pkgdir} install
- install -Dm644 ${srcdir}/${pkgname}-${pkgver}/doc/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ install -Dm644 ${srcdir}/${pkgname}-${pkgver}/LICENSE.md ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
}
# vim:set ts=2 sw=2 et:
diff --git a/ledger.install b/ledger.install
deleted file mode 100644
index f93d6b0b0603..000000000000
--- a/ledger.install
+++ /dev/null
@@ -1,17 +0,0 @@
-infodir="/usr/share/info"
-
-post_install() {
- install-info ${infodir}/ledger3.info ${infodir}/dir 2> /dev/null
- install-info ${infodir}/ledger-mode.info ${infodir}/dir 2> /dev/null
-}
-
-post_upgrade() {
- post_install $1
-}
-
-pre_remove() {
- install-info --delete ${infodir}/ledger3.info ${infodir}/dir 2> /dev/null
- install-info --delete ${infodir}/ledger-mode.info ${infodir}/dir 2> /dev/null
-}
-
-# vim:set ts=2 sw=2 et:
diff --git a/ledger_git.diff b/ledger_git.diff
deleted file mode 100644
index 539814476265..000000000000
--- a/ledger_git.diff
+++ /dev/null
@@ -1,105 +0,0 @@
-diff --git a/src/account.h b/src/account.h
-index 76e839e..0b55ce9 100644
---- a/src/account.h
-+++ b/src/account.h
-@@ -261,11 +261,7 @@ public:
- mutable optional<xdata_t> xdata_;
-
- bool has_xdata() const {
--#if BOOST_VERSION >= 105600
-- return xdata_ != NULL;
--#else
-- return xdata_;
--#endif
-+ return !!(xdata_);
- }
- void clear_xdata();
- xdata_t& xdata() {
-diff --git a/src/filters.cc b/src/filters.cc
-index 2f97a0e..b6530c0 100644
---- a/src/filters.cc
-+++ b/src/filters.cc
-@@ -707,7 +707,7 @@ namespace {
- insert_prices_in_map(price_map_t& _all_prices)
- : all_prices(_all_prices) {}
-
-- void operator()(datetime_t& date, const amount_t& price) {
-+ void operator()(const datetime_t& date, const amount_t& price) {
- all_prices.insert(price_map_t::value_type(date, price));
- }
- };
-diff --git a/src/item.h b/src/item.h
-index 458cb37..aa55e41 100644
---- a/src/item.h
-+++ b/src/item.h
-@@ -191,11 +191,7 @@ public:
- static bool use_aux_date;
-
- virtual bool has_date() const {
--#if BOOST_VERSION >= 105600
-- return _date != NULL;
--#else
-- return _date;
--#endif
-+ return !!(_date);
- }
-
- virtual date_t date() const {
-diff --git a/src/iterators.cc b/src/iterators.cc
-index 21bec5d..0225e21 100644
---- a/src/iterators.cc
-+++ b/src/iterators.cc
-@@ -96,7 +96,7 @@ namespace {
- TRACE_DTOR(create_price_xact);
- }
-
-- void operator()(datetime_t& date, const amount_t& price) {
-+ void operator()(const datetime_t& date, const amount_t& price) {
- xact_t * xact;
- string symbol = price.commodity().symbol();
-
-diff --git a/src/parser.h b/src/parser.h
-index e46fc71..25c4a7e 100644
---- a/src/parser.h
-+++ b/src/parser.h
-@@ -118,7 +118,7 @@ public:
-
- ptr_op_t parse(std::istream& in,
- const parse_flags_t& flags = PARSE_DEFAULT,
-- const optional<string>& original_string = NULL);
-+ const optional<string>& original_string = boost::none);
- };
-
- } // namespace ledger
-diff --git a/src/post.h b/src/post.h
-index 1e5fc56..7796293 100644
---- a/src/post.h
-+++ b/src/post.h
-@@ -205,11 +205,7 @@ public:
- mutable optional<xdata_t> xdata_;
-
- bool has_xdata() const {
--#if BOOST_VERSION >= 105600
-- return xdata_ != NULL;
--#else
-- return xdata_;
--#endif
-+ return !!(xdata_);
- }
- void clear_xdata() {
- xdata_ = none;
-diff --git a/src/times.h b/src/times.h
-index c1bfb1c..0cb05ff 100644
---- a/src/times.h
-+++ b/src/times.h
-@@ -568,11 +568,7 @@ public:
- void stabilize(const optional<date_t>& date = none);
-
- bool is_valid() const {
--#if BOOST_VERSION >= 105600
-- return start != NULL;
--#else
-- return start;
--#endif
-+ return !!(start);
- }