summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Kojevnikov2015-06-28 03:45:31 +1000
committerAndrey Kojevnikov2015-06-28 03:45:31 +1000
commitac38a21ec9f383b29a463ce807a6aa3b365f43c7 (patch)
treebf8f8a8d585f63c8eb8591566eef6a2a1e090921
downloadaur-ac38a21ec9f383b29a463ce807a6aa3b365f43c7.tar.gz
aur4
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD37
-rw-r--r--ledger.install17
-rw-r--r--ledger_git.diff105
4 files changed, 187 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ca57d6e3cc09
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = ledger
+ pkgdesc = A double-entry accounting system with a command-line reporting interface.
+ pkgver = 3.1
+ pkgrel = 2
+ url = http://www.ledger-cli.org
+ install = ledger.install
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = cmake
+ makedepends = git
+ makedepends = python
+ makedepends = texinfo
+ makedepends = texlive-plainextra
+ makedepends = icu>=55
+ depends = boost>=1.49
+ depends = mpfr>=2.4.0
+ depends = pcre
+ depends = expat
+ depends = libedit
+ options = !libtool
+ source = ledger-3.1.tar.gz::https://github.com/ledger/ledger/archive/v3.1.tar.gz
+ source = ledger_git.diff
+ md5sums = f4389aae3ba96eb5590784db7fa614ca
+ md5sums = 8b7c6a5727d8ccc0e60851da7df9fbbb
+
+pkgname = ledger
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..902c520179f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: korjjj <korjjj+aur[at]gmail[dot]com>
+# Contributor: TDY <tdy at archlinux dot info>
+# Contributor: Adam Ehlers Nyholm Thomsen <adament at gmail dot com>
+# Contributor: Nathan Jones <nathanj at insightbb dot com>
+
+pkgname=ledger
+pkgver=3.1
+pkgrel=2
+pkgdesc='A double-entry accounting system with a command-line reporting interface.'
+arch=('i686' 'x86_64')
+url='http://www.ledger-cli.org'
+license=('BSD')
+depends=('boost>=1.49' 'mpfr>=2.4.0' 'pcre' 'expat' 'libedit')
+makedepends=('cmake' 'git' 'python' 'texinfo' 'texlive-plainextra' 'icu>=55')
+options=('!libtool')
+install="${pkgname}.install"
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ledger/${pkgname}/archive/v${pkgver}.tar.gz"
+ 'ledger_git.diff')
+md5sums=('f4389aae3ba96eb5590784db7fa614ca'
+ '8b7c6a5727d8ccc0e60851da7df9fbbb')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ git clone --depth=1 https://github.com/${pkgname}/utfcpp.git lib/utfcpp # submodule excluded
+ patch -Np1 -i ../ledger_git.diff # https://groups.google.com/forum/#!topic/ledger-cli/BMYK_bupv5Y
+ ./acprep --prefix=/usr opt update
+ cmake ./ -DCMAKE_INSTALL_LIBDIR=/usr/lib -DBUILD_EMACSLISP:BOOL=ON -DBUILD_DOCS:BOOL=ON
+ make doc
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR=${pkgdir} install
+ install -Dm644 ${srcdir}/${pkgname}-${pkgver}/doc/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/ledger.install b/ledger.install
new file mode 100644
index 000000000000..f93d6b0b0603
--- /dev/null
+++ b/ledger.install
@@ -0,0 +1,17 @@
+infodir="/usr/share/info"
+
+post_install() {
+ install-info ${infodir}/ledger3.info ${infodir}/dir 2> /dev/null
+ install-info ${infodir}/ledger-mode.info ${infodir}/dir 2> /dev/null
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ install-info --delete ${infodir}/ledger3.info ${infodir}/dir 2> /dev/null
+ install-info --delete ${infodir}/ledger-mode.info ${infodir}/dir 2> /dev/null
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/ledger_git.diff b/ledger_git.diff
new file mode 100644
index 000000000000..539814476265
--- /dev/null
+++ b/ledger_git.diff
@@ -0,0 +1,105 @@
+diff --git a/src/account.h b/src/account.h
+index 76e839e..0b55ce9 100644
+--- a/src/account.h
++++ b/src/account.h
+@@ -261,11 +261,7 @@ public:
+ mutable optional<xdata_t> xdata_;
+
+ bool has_xdata() const {
+-#if BOOST_VERSION >= 105600
+- return xdata_ != NULL;
+-#else
+- return xdata_;
+-#endif
++ return !!(xdata_);
+ }
+ void clear_xdata();
+ xdata_t& xdata() {
+diff --git a/src/filters.cc b/src/filters.cc
+index 2f97a0e..b6530c0 100644
+--- a/src/filters.cc
++++ b/src/filters.cc
+@@ -707,7 +707,7 @@ namespace {
+ insert_prices_in_map(price_map_t& _all_prices)
+ : all_prices(_all_prices) {}
+
+- void operator()(datetime_t& date, const amount_t& price) {
++ void operator()(const datetime_t& date, const amount_t& price) {
+ all_prices.insert(price_map_t::value_type(date, price));
+ }
+ };
+diff --git a/src/item.h b/src/item.h
+index 458cb37..aa55e41 100644
+--- a/src/item.h
++++ b/src/item.h
+@@ -191,11 +191,7 @@ public:
+ static bool use_aux_date;
+
+ virtual bool has_date() const {
+-#if BOOST_VERSION >= 105600
+- return _date != NULL;
+-#else
+- return _date;
+-#endif
++ return !!(_date);
+ }
+
+ virtual date_t date() const {
+diff --git a/src/iterators.cc b/src/iterators.cc
+index 21bec5d..0225e21 100644
+--- a/src/iterators.cc
++++ b/src/iterators.cc
+@@ -96,7 +96,7 @@ namespace {
+ TRACE_DTOR(create_price_xact);
+ }
+
+- void operator()(datetime_t& date, const amount_t& price) {
++ void operator()(const datetime_t& date, const amount_t& price) {
+ xact_t * xact;
+ string symbol = price.commodity().symbol();
+
+diff --git a/src/parser.h b/src/parser.h
+index e46fc71..25c4a7e 100644
+--- a/src/parser.h
++++ b/src/parser.h
+@@ -118,7 +118,7 @@ public:
+
+ ptr_op_t parse(std::istream& in,
+ const parse_flags_t& flags = PARSE_DEFAULT,
+- const optional<string>& original_string = NULL);
++ const optional<string>& original_string = boost::none);
+ };
+
+ } // namespace ledger
+diff --git a/src/post.h b/src/post.h
+index 1e5fc56..7796293 100644
+--- a/src/post.h
++++ b/src/post.h
+@@ -205,11 +205,7 @@ public:
+ mutable optional<xdata_t> xdata_;
+
+ bool has_xdata() const {
+-#if BOOST_VERSION >= 105600
+- return xdata_ != NULL;
+-#else
+- return xdata_;
+-#endif
++ return !!(xdata_);
+ }
+ void clear_xdata() {
+ xdata_ = none;
+diff --git a/src/times.h b/src/times.h
+index c1bfb1c..0cb05ff 100644
+--- a/src/times.h
++++ b/src/times.h
+@@ -568,11 +568,7 @@ public:
+ void stabilize(const optional<date_t>& date = none);
+
+ bool is_valid() const {
+-#if BOOST_VERSION >= 105600
+- return start != NULL;
+-#else
+- return start;
+-#endif
++ return !!(start);
+ }