summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Kojevnikov2016-09-29 13:16:25 +0000
committerAndrey Kojevnikov2016-09-29 16:18:30 +0300
commitb1303b29e719133b4a1b970aa792ba035ab9a1a8 (patch)
treea603d261b126b306fb6d3c8f6201b438005d69ca
parent59058d6b99baa12f1132ca3aef3e357b138d3277 (diff)
downloadaur-b1303b29e719133b4a1b970aa792ba035ab9a1a8.tar.gz
3.1.1-3: boost 1.61 fix
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f518908007f5..2e614cd6b92a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Jan 20 18:09:41 UTC 2016
+# Thu Sep 29 13:15:29 UTC 2016
pkgbase = ledger
pkgdesc = A double-entry accounting system with a command-line reporting interface.
pkgver = 3.1.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/ledger/ledger
arch = i686
arch = x86_64
@@ -13,7 +13,9 @@ pkgbase = ledger
depends = boost
depends = libedit
source = ledger-3.1.1.tar.gz::https://github.com/ledger/ledger/archive/v3.1.1.tar.gz
+ source = ledger-boost-1.61.patch::https://github.com/ledger/ledger/commit/1856b8c4902498843f4da37a7aaeb2ce85acc1d3.patch
md5sums = eae070cbbc1a40a277f1394d72ef0fe6
+ md5sums = 004062eca8add315a125ecf1db39f2fb
pkgname = ledger
diff --git a/PKGBUILD b/PKGBUILD
index b80f38156308..e99d9e7f5828 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,18 +5,22 @@
pkgname=ledger
pkgver=3.1.1
-pkgrel=2
+pkgrel=3
pkgdesc='A double-entry accounting system with a command-line reporting interface.'
arch=('i686' 'x86_64')
url='https://github.com/ledger/ledger'
license=('BSD')
depends=('python2' 'boost' 'libedit')
makedepends=('cmake')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ledger/${pkgname}/archive/v${pkgver}.tar.gz")
-md5sums=('eae070cbbc1a40a277f1394d72ef0fe6')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ledger/${pkgname}/archive/v${pkgver}.tar.gz"
+"${pkgname}-boost-1.61.patch::https://github.com/ledger/${pkgname}/commit/1856b8c4902498843f4da37a7aaeb2ce85acc1d3.patch"
+)
+md5sums=('eae070cbbc1a40a277f1394d72ef0fe6'
+ '004062eca8add315a125ecf1db39f2fb')
prepare() {
cd ${srcdir}/${pkgname}-${pkgver}
+ patch -p1 < ${srcdir}/${pkgname}-boost-1.61.patch
sed -i '/enable_testing()\|add_subdirectory(test)/d' ./CMakeLists.txt
cmake ./ \
-DCMAKE_INSTALL_PREFIX:PATH=/usr \