summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAbdelhakim Qbaich2017-05-12 20:38:18 -0400
committerAbdelhakim Qbaich2017-05-12 20:38:18 -0400
commitbbcfce97c18934e028797c7e1b8feb7b37891fa4 (patch)
tree95e3b49e369469c93104cca1b641b8ac45a3e10d
parentb1303b29e719133b4a1b970aa792ba035ab9a1a8 (diff)
downloadaur-bbcfce97c18934e028797c7e1b8feb7b37891fa4.tar.gz
Switch to sha256sum and other various minor edits
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore13
-rw-r--r--PKGBUILD51
3 files changed, 27 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e614cd6b92a..29dd774bb388 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,8 @@
-# Generated by mksrcinfo v8
-# Thu Sep 29 13:15:29 UTC 2016
pkgbase = ledger
- pkgdesc = A double-entry accounting system with a command-line reporting interface.
+ pkgdesc = Double-entry accounting system with a command-line reporting interface
pkgver = 3.1.1
pkgrel = 3
- url = https://github.com/ledger/ledger
+ url = http://ledger-cli.org
arch = i686
arch = x86_64
license = BSD
@@ -14,8 +12,8 @@ pkgbase = ledger
depends = libedit
source = ledger-3.1.1.tar.gz::https://github.com/ledger/ledger/archive/v3.1.1.tar.gz
source = ledger-boost-1.61.patch::https://github.com/ledger/ledger/commit/1856b8c4902498843f4da37a7aaeb2ce85acc1d3.patch
- md5sums = eae070cbbc1a40a277f1394d72ef0fe6
- md5sums = 004062eca8add315a125ecf1db39f2fb
+ sha256sums = 90f06561ab692b192d46d67bc106158da9c6c6813cc3848b503243a9dfd8548a
+ sha256sums = bf694b022d5984caf49b3454c65e502dabbd657cc8b207f5f3cc677f0b630e6e
pkgname = ledger
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index b73905529f23..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,13 +0,0 @@
-*.tar
-*.tar.*
-*.jar
-*.exe
-*.msi
-*.zip
-*.tgz
-*.log
-*.log.*
-*.sig
-
-pkg/
-src/
diff --git a/PKGBUILD b/PKGBUILD
index e99d9e7f5828..08c4ef1a19d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,42 @@
-# Maintainer: korjjj <korjjj+aur[at]gmail[dot]com>
-# Contributor: TDY <tdy at archlinux dot info>
-# Contributor: Adam Ehlers Nyholm Thomsen <adament at gmail dot com>
-# Contributor: Nathan Jones <nathanj at insightbb dot com>
+# Maintainer: Abdelhakim Qbaich <abdelhakim@qbaich.com>
+# Contributor: korjjj <korjjj+aur@gmail.com>
+# Contributor: TDY <tdy@archlinux.info>
+# Contributor: Adam Ehlers Nyholm Thomsen <adament@gmail.com>
+# Contributor: Nathan Jones <nathanj@insightbb.com>
pkgname=ledger
pkgver=3.1.1
pkgrel=3
-pkgdesc='A double-entry accounting system with a command-line reporting interface.'
+pkgdesc='Double-entry accounting system with a command-line reporting interface'
arch=('i686' 'x86_64')
-url='https://github.com/ledger/ledger'
+url='http://ledger-cli.org'
license=('BSD')
depends=('python2' 'boost' 'libedit')
makedepends=('cmake')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ledger/${pkgname}/archive/v${pkgver}.tar.gz"
-"${pkgname}-boost-1.61.patch::https://github.com/ledger/${pkgname}/commit/1856b8c4902498843f4da37a7aaeb2ce85acc1d3.patch"
-)
-md5sums=('eae070cbbc1a40a277f1394d72ef0fe6'
- '004062eca8add315a125ecf1db39f2fb')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/ledger/$pkgname/archive/v$pkgver.tar.gz"
+ "$pkgname-boost-1.61.patch::https://github.com/ledger/$pkgname/commit/1856b8c4902498843f4da37a7aaeb2ce85acc1d3.patch")
+sha256sums=('90f06561ab692b192d46d67bc106158da9c6c6813cc3848b503243a9dfd8548a'
+ 'bf694b022d5984caf49b3454c65e502dabbd657cc8b207f5f3cc677f0b630e6e')
prepare() {
- cd ${srcdir}/${pkgname}-${pkgver}
- patch -p1 < ${srcdir}/${pkgname}-boost-1.61.patch
- sed -i '/enable_testing()\|add_subdirectory(test)/d' ./CMakeLists.txt
- cmake ./ \
+ cd "$pkgname-$pkgver"
+ sed -i '/enable_testing()\|add_subdirectory(test)/d' CMakeLists.txt
+ patch -p1 -i "$srcdir/$pkgname-boost-1.61.patch"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ cmake . \
-DCMAKE_INSTALL_PREFIX:PATH=/usr \
-DCMAKE_INSTALL_LIBDIR:PATH=lib \
- -DCMAKE_SKIP_RPATH:BOOL=TRUE \
- -DDISABLE_ASSERTS:BOOL=TRUE \
- -DBUILD_DEBUG:BOOL=FALSE \
- -DBUILD_DOCS:BOOL=FALSE \
-DUSE_PYTHON:BOOL=TRUE \
+ -DDISABLE_ASSERTS:BOOL=TRUE \
-DBUILD_EMACSLISP:BOOL=TRUE
-}
-
-build() {
- cd ${srcdir}/${pkgname}-${pkgver}
make
}
package() {
- cd ${srcdir}/${pkgname}-${pkgver}
- make DESTDIR=${pkgdir} install
- install -Dm644 ${srcdir}/${pkgname}-${pkgver}/LICENSE.md ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-
-# vim:set ts=2 sw=2 et: