summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFanch The System2020-04-20 16:16:04 +0200
committerFanch The System2020-04-20 16:16:04 +0200
commit741b8c01cc123dc9ee46e7eeb3b3c261f49297f4 (patch)
tree71dbbb5dee996fceb3b1e885947260c314e94a83
downloadaur-741b8c01cc123dc9ee46e7eeb3b3c261f49297f4.tar.gz
Update Version
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD44
-rw-r--r--apache.conf11
-rw-r--r--leed.install14
-rw-r--r--leed.perm.sh9
5 files changed, 101 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f0f1994191e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = leed
+ pkgdesc = Leed (short for Light Feed) is a minimalist RSS/ATOM aggregator which offers fast RSS consultation and non-intrusive features.
+ pkgver = 1.8.4
+ pkgrel = 1
+ url = https://github.com/LeedRSS/Leed
+ install = leed.install
+ arch = any
+ license = AGPL-3.0
+ makedepends = unzip
+ depends = php
+ depends = mariadb
+ optdepends = php-apache: to use the Apache web server
+ options = emptydirs
+ backup = etc/webapps/leed/apache.conf
+ source = leed-1.8.4.zip::https://github.com/LeedRSS/Leed/archive/v1.8.4.zip
+ source = apache.conf
+ source = leed.perm.sh
+ md5sums = e94088506f8e4fea6d9512e6e2bf718b
+ md5sums = 099b05b5761b964e60e8eb209f1fccf5
+ md5sums = 24cc8fa2aa47807bccb1c64d2f6b7198
+
+pkgname = leed
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43cbb8e41004
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+
+pkgname=leed
+pkgver=1.8.4
+pkgrel=1
+pkgdesc="Leed (short for Light Feed) is a minimalist RSS/ATOM aggregator which offers fast RSS consultation and non-intrusive features."
+arch=(any)
+url="https://github.com/LeedRSS/Leed"
+license=("AGPL-3.0")
+optdepends=('php-apache: to use the Apache web server')
+depends=("php" "mariadb")
+makedepends=("unzip")
+backup=("etc/webapps/leed/apache.conf")
+install=leed.install
+options=(emptydirs)
+
+source=("$pkgname-$pkgver.zip::https://github.com/LeedRSS/Leed/archive/v$pkgver.zip"
+ 'apache.conf'
+ 'leed.perm.sh')
+md5sums=('e94088506f8e4fea6d9512e6e2bf718b'
+ '099b05b5761b964e60e8eb209f1fccf5'
+ '24cc8fa2aa47807bccb1c64d2f6b7198')
+
+
+pkgver() {
+ curl -Is https://github.com/LeedRSS/Leed/releases/latest | awk -F'/' '/^location/ {print $NF}' | sed 's/v//' | sed 's/[^[:print:]]//'
+}
+
+
+
+package() {
+ ### install leed
+ mkdir -p "${pkgdir}/usr/share/webapps/leed"
+ cp -a Leed-$pkgver "${pkgdir}/usr/share/webapps/leed/."
+
+ ### default perm
+ find "${pkgdir}/usr/share/webapps/leed/" -type f -print0 | xargs -0 chmod 0640
+ find "${pkgdir}/usr/share/webapps/leed/" -type d -print0 | xargs -0 chmod 0750
+ install -D -m755 "${srcdir}/leed.perm.sh" "${pkgdir}/usr/bin/set-leed-perm"
+
+ ### apache conf (optionnal)
+ mkdir -p "${pkgdir}/etc/webapps/leed"
+ install -m644 "${srcdir}/apache.conf" "${pkgdir}/etc/webapps/leed/apache.conf"
+
+}
diff --git a/apache.conf b/apache.conf
new file mode 100644
index 000000000000..839b9cff2afe
--- /dev/null
+++ b/apache.conf
@@ -0,0 +1,11 @@
+IfModule mod_alias.c>
+ Alias /leed /usr/share/webapps/leed/
+</IfModule>
+
+<Directory /usr/share/webapps/leed/>
+ Options FollowSymlinks
+ AllowOverride all
+ Require all granted
+ php_admin_value open_basedir "/tmp/:/usr/share/pear/:/dev/urandom:/usr/share/webapps/leed/:/etc/webapps/leed"
+</Directory>
+
diff --git a/leed.install b/leed.install
new file mode 100644
index 000000000000..e5bdc87d17bd
--- /dev/null
+++ b/leed.install
@@ -0,0 +1,14 @@
+post_install () {
+ set-leed-perm
+ echo "**********"
+ echo "From your browser, go to the setup page install.php (eg your.domaine.fr/leed/install.php)"
+ echo "Once the installation is complete, remove the /usr/share/webapps/leed/install.php as a security measure."
+ echo "**********"
+}
+
+post_upgrade() {
+ set-leed-perm
+ echo "**********"
+ echo "Once the upgrade is complete, remove the /usr/share/webapps/leed/install.php as a security measure."
+ echo "**********"
+}
diff --git a/leed.perm.sh b/leed.perm.sh
new file mode 100644
index 000000000000..1ff26f8b37ff
--- /dev/null
+++ b/leed.perm.sh
@@ -0,0 +1,9 @@
+#!/bin/bash
+
+leed_path='/usr/share/webapps/leed'
+htuser='http'
+htgroup='http'
+
+find ${leed_path}/ -type f -print0 | xargs -0 chmod 0640
+find ${leed_path}/ -type d -print0 | xargs -0 chmod 0750
+chown -R ${htuser}:${htgroup} ${leed_path}/