summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Petrescu2019-01-20 08:44:07 -0500
committerAdrian Petrescu2019-01-20 08:44:07 -0500
commit632839504fd5f753b4c9db0cba74069b631ac226 (patch)
tree536163ee566b1e725daad895e10d4ca7a592deb4
parent0f9a97fadd04160fd21ad3e49e2cface2670f168 (diff)
downloadaur-632839504fd5f753b4c9db0cba74069b631ac226.tar.gz
pkgrel 2: pushed incorrect PKGBUILD last time, oops
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD41
2 files changed, 37 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f7135b5dd65..79b6f4747aea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = leela-zero-git
- pkgdesc = Go engine with no human-provided knowledge, modeled after the AlphaGo Zero paper.
+ pkgdesc = Go engine with no human-provided knowledge, modeled after the AlphaGo Zero paper. (next branch)
pkgver = 766
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/gcp/leela-zero
install = leela-zero-git.install
arch = x86_64
@@ -12,12 +12,19 @@ pkgbase = leela-zero-git
makedepends = ocl-icd
depends = glibc
depends = zlib
- depends = libopenblas
+ depends = openblas
depends = boost
- depends = opencl-nvidia
+ depends = opencl-driver
depends = qt5-base
+ provides = leela-zero
conflicts = leela-zero
- source = git+https://github.com/gcp/leela-zero#branch=next
+ source = leela-zero-git::git+https://github.com/gcp/leela-zero#branch=next
+ source = git+https://github.com/google/googletest.git
+ source = git+https://github.com/eigenteam/eigen-git-mirror
+ source = weights.txt.gz::http://zero.sjeng.org/best-network
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
md5sums = SKIP
pkgname = leela-zero-git
diff --git a/PKGBUILD b/PKGBUILD
index 4201ddc21e4e..37ff03531af7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,48 +4,57 @@
pkgname=leela-zero-git
_pkgname=leela-zero
pkgver=766
-pkgrel=1
-pkgdesc="Go engine with no human-provided knowledge, modeled after the AlphaGo Zero paper."
+pkgrel=2
+pkgdesc="Go engine with no human-provided knowledge, modeled after the AlphaGo Zero paper. (next branch)"
arch=('x86_64')
url="https://github.com/gcp/leela-zero"
license=('GPLv3')
-depends=('glibc' 'zlib' 'libopenblas' 'boost' 'opencl-nvidia' 'qt5-base')
+depends=('glibc' 'zlib' 'openblas' 'boost' 'opencl-driver' 'qt5-base')
makedepends=('git' 'opencl-headers' 'cmake' 'ocl-icd')
+provides=('leela-zero')
conflicts=('leela-zero')
install="$pkgname.install"
-source=("git+https://github.com/gcp/leela-zero#branch=next")
-md5sums=('SKIP')
+source=("${pkgname}::git+https://github.com/gcp/leela-zero#branch=next"
+ "git+https://github.com/google/googletest.git"
+ "git+https://github.com/eigenteam/eigen-git-mirror"
+ "weights.txt.gz::http://zero.sjeng.org/best-network")
+md5sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
- cd ${srcdir}/${_pkgname}
+ cd $srcdir/${_pkgname}
git rev-list --count HEAD
}
prepare() {
- cd ${srcdir}/${_pkgname}
- curl http://zero.sjeng.org/best-network | gunzip > weights_$(pkgver).txt
+ cd $srcdir/$pkgname
+ git submodule init
+ git config submodule.gtest.url "$srcdir"/googletest
+ git config submodule.src/Eigen.url "$srcdir"/eigen-git-mirror
+ git submodule update gtest src/Eigen
+ mkdir -p build
}
build() {
- cd ${srcdir}/${_pkgname}
- git submodule update --init --recursive
- mkdir -p build && cd build
- cmake .. || return 1
+ cd $srcdir/$pkgname/build
+ cmake ..
make leelaz
- cd ../autogtp
+ cd $srcdir/$pkgname/autogtp
qmake
make
}
check() {
- cd ${srcdir}/${_pkgname}/build
+ cd $srcdir/$pkgname/build
make tests
./tests
}
package() {
- cd ${srcdir}/${_pkgname}
+ cd $srcdir/$pkgname
install -Dm755 build/leelaz $pkgdir/usr/bin/leelaz
install -Dm755 autogtp/autogtp $pkgdir/usr/bin/autogtp
- install -Dm644 weights_$pkgver.txt $pkgdir/usr/share/leela-zero/networks/weights_$pkgver.txt
+ install -Dm644 $srcdir/weights.txt $pkgdir/usr/share/leela-zero/networks/weights.txt
}