summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpostblue2016-07-05 10:30:58 +0200
committerpostblue2016-07-05 10:30:58 +0200
commitd6a2c9b52cf388028074d0b8fd2d8f101fd9c5d6 (patch)
tree3f081e00cdd23fb70725354dacd898cb22faf8fb
downloadaur-d6a2c9b52cf388028074d0b8fd2d8f101fd9c5d6.tar.gz
Initial commit
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD46
-rw-r--r--legend-of-grimrock.desktop7
3 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..77dc2bfa1cd0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = legend-of-grimrock
+ pkgdesc = A 3D grid-based dungeon crawler inspired by classic 1980s and 1990s action role-playing games Dungeon Master, Eye of the Beholder and Ultima Underworld.
+ pkgver = 20130515
+ pkgrel = 1
+ url = http://www.grimrock.net/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = freeimage
+ depends = minizip
+ depends = sdl-hg
+ depends = libvorbis
+ depends = freetype2
+ depends = zlib
+ depends = openal
+ depends = libgl
+ depends = libx11
+ depends = libogg
+ depends = libxext
+ depends = desktop-file-utils
+ optdepends = libtxc_dxtn: For Mesa S3TC support.
+ source = local://LegendOfGrimrock-Linux-2013-05-15.sh
+ source = legend-of-grimrock.desktop
+ sha256sums = 005066be6ce12ba342e499369070113c6b66a9bea03c6ecb1e5fd0758eb0c39d
+ sha256sums = a989d2d0d896ec4adaf3d66e19050c519d9e58efc8d588a51ab0185283bf21fb
+
+pkgname = legend-of-grimrock
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06292d7552a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer:
+# guillaume hayot <postblue@postblue.info>
+# Contributors:
+# henning mueller <henning@orgizm.net>
+
+pkgname=legend-of-grimrock
+pkgdesc='A 3D grid-based dungeon crawler inspired by classic 1980s and 1990s action role-playing games Dungeon Master, Eye of the Beholder and Ultima Underworld.'
+url='http://www.grimrock.net/'
+_pkgdate=2013-05-15
+pkgver=20130515
+pkgrel=1
+arch=(i686 x86_64)
+license=(custom)
+PKGEXT=.pkg.tar
+depends=(
+ freeimage minizip sdl-hg libvorbis freetype2 zlib openal libgl libx11 libogg
+ libxext desktop-file-utils
+)
+optdepends=('libtxc_dxtn: For Mesa S3TC support.')
+source=(
+ "local://LegendOfGrimrock-Linux-$_pkgdate.sh"
+ $pkgname.desktop
+)
+
+[ "$CARCH" != "i686" ] && _arch=x86_64 || {
+ _arch=x86
+ depends+=(gcc-libs-multilib)
+}
+
+package() {
+ sh ${source[0]//::/} --tar xf
+
+ _target=$pkgdir/usr/share/$pkgname
+
+ mkdir -p $_target
+ lzma -d < instarchive_linux_$_arch | tar xf - -C $_target
+ lzma -d < instarchive_all | tar xf - -C $_target
+
+ mkdir -p $pkgdir/usr/bin
+ ln -s ../share/$pkgname/Grimrock.bin.$_arch $pkgdir/usr/bin/$pkgname
+
+ install -D $pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+}
+
+sha256sums=('005066be6ce12ba342e499369070113c6b66a9bea03c6ecb1e5fd0758eb0c39d'
+ 'a989d2d0d896ec4adaf3d66e19050c519d9e58efc8d588a51ab0185283bf21fb')
diff --git a/legend-of-grimrock.desktop b/legend-of-grimrock.desktop
new file mode 100644
index 000000000000..cbc4ce25922d
--- /dev/null
+++ b/legend-of-grimrock.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Categories=Game;RolePlaying;
+Encoding=UTF-8
+Name=Legend of Grimrock
+Exec=/usr/bin/legend-of-grimrock
+Icon=/usr/share/legend-of-grimrock/grimrock.png
+Type=Application