summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSanskritFritz2015-06-14 00:39:03 +0200
committerSanskritFritz2015-06-14 00:39:03 +0200
commit6350a1ed1bace4a412ef4ad2df9c17c212d3348c (patch)
tree9cd3256ae107cf96dda258e3a411f13064ed3e76
downloadaur-legend-of-kyrandia-3.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--Kyrandia3.jpgbin0 -> 5029 bytes
-rw-r--r--PKGBUILD68
-rw-r--r--kyrandia3.install10
4 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..47df9968ab7e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = legend-of-kyrandia-3
+ pkgdesc = A classic adventure game, played in ScummVM.
+ pkgver = 3.0
+ pkgrel = 7
+ url = http://www.emuparadise.me/ScummVM_Games/The_Legend_of_Kyrandia_3_Malcolm%27s_Revenge_(CD_DOS,_Multilanguage)/96018
+ install = kyrandia3.install
+ arch = any
+ license = custom-freeware
+ license = Abandonware
+ depends = scummvm
+ noextract = legend-of-kyrandia-3.zip
+ source = legend-of-kyrandia-3.zip::http://50.7.161.234/bks/new/ScummVM/Working/The%20Legend%20of%20Kyrandia%203%20Malcolm's%20Revenge%20(CD%20DOS,%20Multilanguage).zip
+ source = Kyrandia3.jpg
+ source = http://scummvm.svn.sourceforge.net/svnroot/scummvm/scummvm/tags/release-1-2-1/dists/engine-data/kyra.dat
+ sha1sums = c54ef1f6feea67081b77f49c5c2a641d4968f680
+ sha1sums = 9ef63a5de779052aec25bda3fdfec1feac4488b8
+ sha1sums = 1827c7532174322f02c2683c8a15dbc7d1d69412
+
+pkgname = legend-of-kyrandia-3
+
diff --git a/Kyrandia3.jpg b/Kyrandia3.jpg
new file mode 100644
index 000000000000..3dcf8f296d76
--- /dev/null
+++ b/Kyrandia3.jpg
Binary files differ
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2d8fc31748ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# Contributor: Jens Staal <staal1978@gmail.com>
+# abbradar (AUR)
+
+pkgname="legend-of-kyrandia-3"
+pkgver="3.0"
+pkgrel=7
+pkgdesc="A classic adventure game, played in ScummVM."
+url='http://www.emuparadise.me/ScummVM_Games/The_Legend_of_Kyrandia_3_Malcolm%27s_Revenge_(CD_DOS,_Multilanguage)/96018'
+arch=('any')
+license=('custom-freeware' 'Abandonware')
+install='kyrandia3.install'
+depends=('scummvm')
+source=("$pkgname.zip::http://50.7.161.234/bks/new/ScummVM/Working/The%20Legend%20of%20Kyrandia%203%20Malcolm's%20Revenge%20(CD%20DOS,%20Multilanguage).zip"
+ "Kyrandia3.jpg"
+ "http://scummvm.svn.sourceforge.net/svnroot/scummvm/scummvm/tags/release-1-2-1/dists/engine-data/kyra.dat")
+noextract=("$pkgname.zip")
+_pkgabbrev="Kyrandia3"
+_exe="kyra3"
+_icon="Kyrandia3.jpg"
+
+prepare() {
+ cd "$srcdir"
+ mkdir kyrandia
+ bsdtar -xf $pkgname.zip -C "kyrandia"
+}
+
+package() {
+ cd "$srcdir"
+ mkdir -p -m755 "$pkgdir/opt/scummvm/$_pkgabbrev"
+ cp -ar $srcdir/kyrandia/* "$pkgdir/opt/scummvm/$_pkgabbrev"
+ cp -arL "$srcdir/kyra.dat" "$pkgdir/opt/scummvm/$_pkgabbrev/KYRA.DAT"
+ cp -arL "$srcdir/$_icon" "$pkgdir/opt/scummvm/$_pkgabbrev"
+
+ #ok, let's use a script to start the game
+
+ mkdir -p -m755 /$pkgdir/usr/bin/
+
+ printf "#!/bin/bash
+if whereis scummvm>/dev/null 2>&1;
+ then
+ mkdir -p ~/.scummvm/$_pkgabbrev
+ scummvm -F --savepath=~/.scummvm/$_pkgabbrev --path=/opt/scummvm/$_pkgabbrev/ $_exe
+ else
+ echo '==> Please get sure to have ScummVM installed and have it in your PATH array.'
+ fi
+exit \$?" >> /$pkgdir/usr/bin/$_pkgabbrev
+
+ chmod +x /$pkgdir/usr/bin/$_pkgabbrev
+
+ # Automatic generation of a .desktop file
+
+ mkdir -p -m755 "$pkgdir/usr/share/applications/"
+
+ printf "[Desktop Entry]
+Version=$pkgver
+Type=Application
+Name=$pkgname
+Comment=$pkgdesc
+Exec=/usr/bin/$_pkgabbrev
+Icon=/opt/$_pkgabbrev/$_icon
+Categories=Game;
+Terminal=false
+StartupNotify=false" >> /$pkgdir/usr/share/applications/$_pkgabbrev.desktop
+}
+
+sha1sums=('c54ef1f6feea67081b77f49c5c2a641d4968f680'
+ '9ef63a5de779052aec25bda3fdfec1feac4488b8'
+ '1827c7532174322f02c2683c8a15dbc7d1d69412')
diff --git a/kyrandia3.install b/kyrandia3.install
new file mode 100644
index 000000000000..b2715f201127
--- /dev/null
+++ b/kyrandia3.install
@@ -0,0 +1,10 @@
+post_install() {
+ post_upgrade;
+}
+
+post_upgrade() {
+ echo "This game release with direct link was generously provided by emuparadise.me. Thanks!"
+ echo
+ echo "==> To play the game simply type"
+ echo "==> Kyrandia3"
+}