summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis Sheremet2020-08-13 22:38:19 +0500
committerDenis Sheremet2020-08-13 22:38:19 +0500
commit4c7976dc8ed9838091871adf2d3695bc7515f73d (patch)
tree43c6382975d75f3ca29c3caa3a1825518f4b2c00
downloadaur-4c7976dc8ed9838091871adf2d3695bc7515f73d.tar.gz
first
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1414f21ddca6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = legendary-run-git
+ pkgdesc = bash script to check updates and launch a game using legendary
+ pkgver = r2.2cd5616
+ pkgrel = 1
+ url = https://gitlab.com/lesf0/legendary-run
+ arch = any
+ license = Apache
+ makedepends = git
+ depends = legendary
+ depends = zenity
+ provides = legendary-run-git
+ conflicts = legendary-run-git
+ source = legendary-run::git+https://gitlab.com/lesf0/legendary-run.git
+ md5sums = SKIP
+
+pkgname = legendary-run-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6585484b2d94
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Denis Sheremet <me@lxlz.space>
+pkgname=legendary-run-git # '-bzr', '-git', '-hg' or '-svn'
+pkgver=r2.2cd5616
+pkgrel=1
+pkgdesc="bash script to check updates and launch a game using legendary"
+arch=('any')
+url="https://gitlab.com/lesf0/legendary-run"
+license=('Apache')
+groups=()
+depends=('legendary' 'zenity')
+makedepends=('git')
+provides=("${pkgname%-VCS}")
+conflicts=("${pkgname%-VCS}")
+replaces=()
+backup=()
+options=()
+install=
+source=("${pkgname%-git}::git+https://gitlab.com/lesf0/legendary-run.git")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -DT "${pkgname%-git}.sh" "$pkgdir/usr/bin/${pkgname%-git}"
+} \ No newline at end of file