summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesse Jaara2015-06-22 01:06:15 +0300
committerJesse Jaara2015-06-22 01:06:15 +0300
commit79e02e72f3e8ff98cbeb84a982150afd56c6073d (patch)
tree0b6d8b0cd7de0a2ad69a744d7d8a16407c8ddb0c
downloadaur-79e02e72f3e8ff98cbeb84a982150afd56c6073d.tar.gz
Import and update Legend of Edgar
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
-rw-r--r--legendofedgar.install12
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3b5372eff415
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = legendofedgar
+ pkgdesc = 2D platformer: Venture across the world, battle fearsome creatures and solve puzzles to rescue your father.
+ pkgver = 1.21
+ pkgrel = 1
+ url = http://sourceforge.net/projects/legendofedgar/
+ install = legendofedgar.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = sdl_image
+ depends = sdl_mixer
+ depends = sdl_ttf
+ depends = hicolor-icon-theme
+ source = https://github.com/riksweeney/edgar/releases/download/1.21/edgar-1.21-1.tar.gz
+ md5sums = 89b786bfcf81767a9447ddd397b943d5
+
+pkgname = legendofedgar
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fdef72502d3a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+#Maintainer: Jesse Jaara <gmail.com: jesse.jaara>
+
+pkgname=legendofedgar
+pkgver=1.21
+pkgrel=1
+pkgdesc="2D platformer: Venture across the world, battle fearsome creatures and solve puzzles to rescue your father."
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/legendofedgar/"
+license=('GPL')
+depends=('sdl_image' 'sdl_mixer' 'sdl_ttf' 'hicolor-icon-theme')
+install=legendofedgar.install
+source=("https://github.com/riksweeney/edgar/releases/download/${pkgver}/edgar-${pkgver}-1.tar.gz")
+md5sums=('89b786bfcf81767a9447ddd397b943d5')
+
+build() {
+ cd "${srcdir}/edgar-${pkgver}"
+
+ sed -e 's|$(PREFIX)/share/games/edgar/|$(PREFIX)/share/edgar/|' -i makefile
+ make
+}
+
+package()
+{
+ cd "${srcdir}/edgar-${pkgver}"
+
+ make DESTDIR="${pkgdir}" BIN_DIR="${pkgdir}/usr/bin/" DATA_DIR="${pkgdir}/usr/share/edgar/" install
+}
+
diff --git a/legendofedgar.install b/legendofedgar.install
new file mode 100644
index 000000000000..5c5f4bff1b2e
--- /dev/null
+++ b/legendofedgar.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}