summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbegin-theadventure2023-07-22 03:46:18 +0200
committerbegin-theadventure2023-07-22 03:46:18 +0200
commit75b29f04e5e3de613de17bd592b754014fb6dd53 (patch)
treea9de5ca9fb1a3e7c53367e042204512c5aa4f2c2
downloadaur-75b29f04e5e3de613de17bd592b754014fb6dd53.tar.gz
1.7.0
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD57
-rwxr-xr-xlegion+23
-rw-r--r--legion+.desktop8
-rw-r--r--legion+.xml28
5 files changed, 137 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6b48f2699adf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = legion+
+ pkgdesc = Asset Extraction tool for Apex Legends and Titanfall 2 (Wine)
+ pkgver = 1.7.0
+ pkgrel = 1
+ url = https://github.com/r-ex/LegionPlus
+ arch = x86_64
+ license = GPL3
+ makedepends = imagemagick
+ depends = wine
+ source = https://github.com/r-ex/LegionPlus/releases/download/1.7.0/Legion+1.7.0.zip
+ source = https://raw.githubusercontent.com/r-ex/LegionPlus/1.7.0/Resources/LegionIcon.ico
+ source = legion+.xml
+ source = legion+.desktop
+ source = legion+
+ sha256sums = ec36829016fc2e67630c9a17f79db327d9680d8f21c43b01541f25a351f6f75f
+ sha256sums = SKIP
+ sha256sums = 97668eab79f4093b5394909f8daae76bf5bf6587319941bd0e832271d5a9d395
+ sha256sums = 25965e4d92ecff88258f4c25d0f94657b95e8b1e9693cebc761921b02aab132c
+ sha256sums = c500e69a853d3617204bb904accdae1adcc6e33595ad86f156c080495eb71474
+
+pkgname = legion+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..79de2c75ea48
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: begin-theadventure <begin-thecontact.ncncb at dralias dot com>
+
+pkgname=legion+
+pkgver=1.7.0
+pkgrel=1
+pkgdesc='Asset Extraction tool for Apex Legends and Titanfall 2 (Wine)'
+arch=('x86_64')
+url='https://github.com/r-ex/LegionPlus'
+license=('GPL3')
+depends=('wine')
+makedepends=('imagemagick')
+source=("$url/releases/download/$pkgver/Legion+$pkgver.zip"
+ "https://raw.githubusercontent.com/r-ex/LegionPlus/$pkgver/Resources/LegionIcon.ico"
+ "$pkgname.xml"
+ "$pkgname.desktop"
+ "$pkgname")
+sha256sums=('ec36829016fc2e67630c9a17f79db327d9680d8f21c43b01541f25a351f6f75f'
+ 'SKIP'
+ '97668eab79f4093b5394909f8daae76bf5bf6587319941bd0e832271d5a9d395'
+ '25965e4d92ecff88258f4c25d0f94657b95e8b1e9693cebc761921b02aab132c'
+ 'c500e69a853d3617204bb904accdae1adcc6e33595ad86f156c080495eb71474')
+
+prepare() {
+ echo "! WARNING, this package installs symlinks to the home directory in ~/.local/share/legion+"
+ echo "! because the application creates files in the same folder it's opened and must have write access to them"
+
+ convert LegionIcon.ico -strip LegionIcon.png
+}
+
+package() {
+ # Install icons
+ install -Dm644 LegionIcon-0.png "$pkgdir/usr/share/icons/hicolor/256x256/apps/$pkgname.png"
+ install -Dm644 LegionIcon-1.png "$pkgdir/usr/share/icons/hicolor/128x128/apps/$pkgname.png"
+ install -Dm644 LegionIcon-2.png "$pkgdir/usr/share/icons/hicolor/64x64/apps/$pkgname.png"
+ install -Dm644 LegionIcon-3.png "$pkgdir/usr/share/icons/hicolor/48x48/apps/$pkgname.png"
+ install -Dm644 LegionIcon-4.png "$pkgdir/usr/share/icons/hicolor/32x32/apps/$pkgname.png"
+ install -Dm644 LegionIcon-5.png "$pkgdir/usr/share/icons/hicolor/16x16/apps/$pkgname.png"
+
+ # Create a folder
+ mkdir -p "$pkgdir/usr/share/legion+"
+ # Install
+ install -Dm644 $pkgname.xml -t "$pkgdir/usr/share/mime/packages"
+ install -Dm644 $pkgname.desktop -t "$pkgdir/usr/share/applications"
+ install -Dm755 $pkgname -t "$pkgdir/usr/bin"
+ mv mileswin64.dll LegionPlus.exe binkawin64.dll "$pkgdir/usr/share/legion+"
+
+
+ echo "! WARNING, this package installs symlinks to the home directory in ~/.local/share/legion+"
+ echo "! because the application creates files in the same folder it's opened and must have write access to them"
+ #! Create a folder in the home directory (if it doesn't exist)
+ mkdir -p $HOME/.local/share/legion+
+
+ #! Symlinks for the home directory
+ ln -fs /usr/share/legion+/binkawin64.dll $HOME/.local/share/legion+
+ ln -fs /usr/share/legion+/mileswin64.dll $HOME/.local/share/legion+
+ ln -fs /usr/share/legion+/LegionPlus.exe $HOME/.local/share/legion+
+}
diff --git a/legion+ b/legion+
new file mode 100755
index 000000000000..6e355282a4fe
--- /dev/null
+++ b/legion+
@@ -0,0 +1,23 @@
+#!/bin/bash
+export WINEPREFIX="$HOME/.local/share/legion+/wineprefix"
+export WINEDEBUG=-all
+
+declare -a args
+
+for arg; do
+ if [[ "${arg:0:1}" = "-" ]]; then
+ args+=("${arg/#-//}")
+ else
+ args+=("$(winepath -w "$arg")")
+ fi
+done
+
+wine $HOME/.local/share/legion+/LegionPlus.exe "${args[@]}"
+EXIT=$?
+
+if [[ $EXIT -ne 0 ]]; then
+ echo "Error: Legion+ failed to launch!"
+ echo -e "If Legion+ didn't start, you should try deleting your Legion+ Wine prefix and restart:"
+ echo "rm -dr ~/.local/share/legion+/wineprefix"
+ exit $EXIT
+fi
diff --git a/legion+.desktop b/legion+.desktop
new file mode 100644
index 000000000000..88cfb019c8c9
--- /dev/null
+++ b/legion+.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Name=Legion+
+Comment=Asset Extraction tool for Apex Legends and Titanfall
+Exec=legion+ %f
+Icon=legion+
+StartupWMClass=Legion+
+MimeType=model/vnd.valve.source.compiled-map;application/rpak;audio/mbnk;
diff --git a/legion+.xml b/legion+.xml
new file mode 100644
index 000000000000..acc11f618938
--- /dev/null
+++ b/legion+.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
+
+ <mime-type type="model/vnd.valve.source.compiled-map">
+ <comment>The Source Engine Map File Format</comment>
+ <glob pattern="*.bsp"/>
+ <magic priority="100">
+ <match value="0x50534272" type="little32" offset="0"/>
+ </magic>
+ </mime-type>
+
+ <mime-type type="application/rpak">
+ <comment>Respawn Pak Archive Format</comment>
+ <glob pattern="*.rpak"/>
+ <magic priority="100">
+ <match value="0x6b615052" type="little32" offset="0"/>
+ </magic>
+ </mime-type>
+
+ <mime-type type="audio/mbnk">
+ <comment>Miles Sound System 10 Audio Bank</comment>
+ <glob pattern="*.mbnk"/>
+ <magic priority="100">
+ <match value="0x43424e4b" type="little32" offset="0"/>
+ </magic>
+ </mime-type>
+
+</mime-info>