summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbegin-theadventure2023-09-20 11:37:23 +0200
committerbegin-theadventure2023-09-20 11:37:23 +0200
commit9f7fe4fada14104d62292f383cd774e830a7371d (patch)
tree1c88bddbc61906725867dce83ef5e315a3c154aa
parent6e1e00f794b5cf5939d02f642535f7ee2d7fa6dd (diff)
downloadaur-9f7fe4fada14104d62292f383cd774e830a7371d.tar.gz
1.8.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
2 files changed, 13 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e810f256887f..afc813b4048c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = legion+
pkgdesc = Asset Extraction tool for Apex Legends and Titanfall 2 (Wine)
- pkgver = 1.7.0
- pkgrel = 9
+ pkgver = 1.8.0
+ pkgrel = 1
url = https://github.com/r-ex/LegionPlus
arch = x86_64
license = GPL3
makedepends = imagemagick
depends = wine
- source = https://github.com/r-ex/LegionPlus/releases/download/1.7.0/Legion+1.7.0.zip
- source = https://raw.githubusercontent.com/r-ex/LegionPlus/1.7.0/Resources/LegionIcon.ico
+ source = https://github.com/r-ex/LegionPlus/releases/download/1.8.0/Legion+1.8.0.zip
+ source = 1.8.0-LegionIcon.ico::https://raw.githubusercontent.com/r-ex/LegionPlus/1.8.0/Resources/LegionIcon.ico
source = legion+.xml
source = legion+.desktop
source = legion+
- sha256sums = ec36829016fc2e67630c9a17f79db327d9680d8f21c43b01541f25a351f6f75f
- sha256sums = 2b879b3c28598a39127417a6c0f047559841cc63f28b174e1a2c25532cbdfd4e
+ sha256sums = c9eb00382727f39370e981be222b8f5427c12333bcad4284d333619a2e067a54
+ sha256sums = SKIP
sha256sums = 86e01fd95376f33b22ed16fd53b9d3cebe4f902711a9709eb583d71fc94d12e5
sha256sums = 5c57644fc35bd713fa32586b512d3741536d1fa2c6641c4b0d399d02ab58cab0
sha256sums = 5f3632aaabda872fe67975c0837b9d87f620fa41eb846490efa57186e3860b05
diff --git a/PKGBUILD b/PKGBUILD
index d0bcdd419bfe..2092ea05516f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: begin-theadventure <begin-thecontact.ncncb at dralias dot com>
pkgname=legion+
-pkgver=1.7.0
-pkgrel=9
+pkgver=1.8.0
+pkgrel=1
pkgdesc='Asset Extraction tool for Apex Legends and Titanfall 2 (Wine)'
arch=('x86_64')
url='https://github.com/r-ex/LegionPlus'
@@ -10,12 +10,12 @@ license=('GPL3')
depends=('wine')
makedepends=('imagemagick')
source=("$url/releases/download/$pkgver/Legion+$pkgver.zip"
- "https://raw.githubusercontent.com/r-ex/LegionPlus/$pkgver/Resources/LegionIcon.ico"
+ "$pkgver-LegionIcon.ico::https://raw.githubusercontent.com/r-ex/LegionPlus/$pkgver/Resources/LegionIcon.ico"
"$pkgname.xml"
"$pkgname.desktop"
"$pkgname")
-sha256sums=('ec36829016fc2e67630c9a17f79db327d9680d8f21c43b01541f25a351f6f75f'
- '2b879b3c28598a39127417a6c0f047559841cc63f28b174e1a2c25532cbdfd4e'
+sha256sums=('c9eb00382727f39370e981be222b8f5427c12333bcad4284d333619a2e067a54'
+ 'SKIP'
'86e01fd95376f33b22ed16fd53b9d3cebe4f902711a9709eb583d71fc94d12e5'
'5c57644fc35bd713fa32586b512d3741536d1fa2c6641c4b0d399d02ab58cab0'
'5f3632aaabda872fe67975c0837b9d87f620fa41eb846490efa57186e3860b05')
@@ -25,21 +25,14 @@ prepare() {
echo "! because Legion+ creates files in the same folder it's opened and must have write access to them"
sleep 2
- convert LegionIcon.ico -strip $pkgname.png
+ convert $pkgver-LegionIcon.ico -strip $pkgname.png
}
package() {
- # Install icons
- install -Dm644 $pkgname-0.png "$pkgdir/usr/share/icons/hicolor/256x256/apps/$pkgname.png"
- install -Dm644 $pkgname-1.png "$pkgdir/usr/share/icons/hicolor/128x128/apps/$pkgname.png"
- install -Dm644 $pkgname-2.png "$pkgdir/usr/share/icons/hicolor/64x64/apps/$pkgname.png"
- install -Dm644 $pkgname-3.png "$pkgdir/usr/share/icons/hicolor/48x48/apps/$pkgname.png"
- install -Dm644 $pkgname-4.png "$pkgdir/usr/share/icons/hicolor/32x32/apps/$pkgname.png"
- install -Dm644 $pkgname-5.png "$pkgdir/usr/share/icons/hicolor/16x16/apps/$pkgname.png"
-
# Create a folder
mkdir -p "$pkgdir/usr/share/legion+"
# Install
+ install -Dm644 $pkgname.png "$pkgdir/usr/share/icons/hicolor/256x256/apps/$pkgname.png"
install -Dm644 $pkgname.xml -t "$pkgdir/usr/share/mime/packages"
install -Dm644 $pkgname.desktop -t "$pkgdir/usr/share/applications"
install -Dm755 $pkgname -t "$pkgdir/usr/bin"