summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFernandez Ludovic2019-01-05 06:13:55 +0100
committerFernandez Ludovic2019-01-05 06:13:55 +0100
commit7a01c77a868dc4c0c7b1f91c4bbb8d3ccd9e54db (patch)
tree25ecdf00d8e5ffddf4d3392e03ebb2abc115133e
downloadaur-7a01c77a868dc4c0c7b1f91c4bbb8d3ccd9e54db.tar.gz
feat: v1.2.1
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD38
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..636cdb8ab50d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = lego
+ pkgdesc = Lets Encrypt client and ACME library written in Go
+ pkgver = v1.2.1
+ pkgrel = 1
+ url = https://github.com/xenolf/lego
+ arch = x86_64
+ arch = i686
+ arch = armv7h
+ arch = aarch64
+ license = MIT
+ depends = git
+ provides = lego
+ conflicts = lego
+ conflicts = lego-git
+ source_x86_64 = https://github.com/xenolf/lego/releases/download/v1.2.1/lego_v1.2.1_linux_amd64.tar.gz
+ sha256sums_x86_64 = ee8252c442e13cac40a2dcdeead9cc5812c44c393e72b39695d428b9275a0509
+ source_i686 = https://github.com/xenolf/lego/releases/download/v1.2.1/lego_v1.2.1_linux_386.tar.gz
+ sha256sums_i686 = 9c521e43aa6e9eded05e54d3751028972b506614a8aae67faf9c2b50fb9f1e68
+ source_armv7h = https://github.com/xenolf/lego/releases/download/v1.2.1/lego_v1.2.1_linux_armv7.tar.gz
+ sha256sums_armv7h = 9527c73be0b8ca1f9bddf8e0556d9c04c4e5be57a178d78f34d8536712306166
+ source_aarch64 = https://github.com/xenolf/lego/releases/download/v1.2.1/lego_v1.2.1_linux_arm64.tar.gz
+ sha256sums_aarch64 = b1b57d72a62882afcbbe18076a1c8ace2d581db4535947033d62b2b81ff50c9f
+
+pkgname = lego
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..dbe2c62ea8e8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+LICENSE
+prm_linux-*
+src/
+pkg/
+
+*.pkg.tar*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..693d6586c375
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Fernandez Ludovic <lfernandez dot dev at gmail dot com>
+
+pkgname='lego'
+pkgver=v1.2.1
+pkgrel=1
+pkgdesc='Lets Encrypt client and ACME library written in Go'
+url='https://github.com/xenolf/lego'
+arch=('x86_64' 'i686' 'armv7h' 'aarch64')
+license=('MIT')
+provides=("${pkgname}")
+conflicts=("${pkgname}" "${pkgname}-git")
+
+depends=(
+ 'git'
+)
+
+makedepends=()
+
+source_x86_64=("https://github.com/xenolf/lego/releases/download/${pkgver}/lego_${pkgver}_linux_amd64.tar.gz")
+sha256sums_x86_64=('ee8252c442e13cac40a2dcdeead9cc5812c44c393e72b39695d428b9275a0509')
+
+source_i686=("https://github.com/xenolf/lego/releases/download/${pkgver}/lego_${pkgver}_linux_386.tar.gz")
+sha256sums_i686=('9c521e43aa6e9eded05e54d3751028972b506614a8aae67faf9c2b50fb9f1e68')
+
+source_armv7h=("https://github.com/xenolf/lego/releases/download/${pkgver}/lego_${pkgver}_linux_armv7.tar.gz")
+sha256sums_armv7h=('9527c73be0b8ca1f9bddf8e0556d9c04c4e5be57a178d78f34d8536712306166')
+
+source_aarch64=("https://github.com/xenolf/lego/releases/download/${pkgver}/lego_${pkgver}_linux_arm64.tar.gz")
+sha256sums_aarch64=('b1b57d72a62882afcbbe18076a1c8ace2d581db4535947033d62b2b81ff50c9f')
+
+package() {
+ # Bin
+ rm -f "${pkgdir}"/usr/bin/lego
+ install -Dm755 "${srcdir}/lego" "${pkgdir}/usr/bin/lego"
+
+ # License
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}