summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Cuneo2023-07-09 22:10:08 +1000
committerMatt Cuneo2023-07-09 22:10:08 +1000
commitee2d68ed5cee2f3f03bf08237f4a4d96de8f8650 (patch)
treeccbafde82825418247f7dfc69e474b87a42acde3
downloadaur-ee2d68ed5cee2f3f03bf08237f4a4d96de8f8650.tar.gz
Initial package
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD22
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..97940918e612
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-lemmony
+ pkgdesc = A better 'All' browsing experience for Lemmy instances
+ pkgver = 0.0.5
+ pkgrel = 1
+ url = https://github.com/jheidecker/lemmony
+ arch = any
+ license = MIT
+ makedepends = python-build
+ makedepends = python-installer
+ depends = python-certifi
+ depends = python-charset-normalizer
+ depends = python-idna
+ depends = python-requests
+ depends = python-urllib3
+ source = https://github.com/jheidecker/lemmony/archive/refs/tags/v0.0.5.tar.gz
+ sha256sums = d4b134464039c95c6b61ce6f3d5e877c045c6207bad40662e9749874b3294cc9
+
+pkgname = python-lemmony
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9315f1cc37ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Matt Cuneo <m@cuneo.au>
+_pkgname=lemmony
+pkgname="python-$_pkgname"
+pkgver=0.0.5
+pkgrel=1
+pkgdesc="A better 'All' browsing experience for Lemmy instances"
+arch=('any')
+url="https://github.com/jheidecker/$_pkgname"
+license=('MIT')
+depends=('python-certifi' 'python-charset-normalizer' 'python-idna' 'python-requests' 'python-urllib3')
+makedepends=(python-build python-installer)
+source=("https://github.com/jheidecker/$_pkgname/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('d4b134464039c95c6b61ce6f3d5e877c045c6207bad40662e9749874b3294cc9')
+
+build() {
+ cd $_pkgname-$pkgver
+ python -m build
+}
+package() {
+ cd $_pkgname-$pkgver
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}