summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornumToStr2022-04-21 15:09:35 +0530
committernumToStr2022-04-21 15:10:21 +0530
commit1b9b86b6664d636059d96bd832252bc469fd2df5 (patch)
tree816583f528d4eca42f1320eec2b6f07c4e3e7f1e
downloadaur-1b9b86b6664d636059d96bd832252bc469fd2df5.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD24
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..948326db9fd4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = lemmy-help
+ pkgdesc = Generate vim help doc from emmylua
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/numToStr/lemmy-help
+ arch = x86_64
+ arch = aarch64
+ arch = armv7
+ license = GPL
+ provides = lemmy-help
+ conflicts = lemmy-help
+ source_x86_64 = https://github.com/numToStr/lemmy-help/releases/download/0.0.1/lemmy-help-x86_64-unknown-linux-gnu.tar.gz
+ md5sums_x86_64 = SKIP
+ source_aarch64 = https://github.com/numToStr/lemmy-help/releases/download/0.0.1/lemmy-help-aarch64-unknown-linux-gnu.tar.gz
+ md5sums_aarch64 = SKIP
+ source_armv7 = https://github.com/numToStr/lemmy-help/releases/download/0.0.1/lemmy-help-armv7-unknown-linux-gnueabihf.tar.gz
+ md5sums_armv7 = SKIP
+
+pkgname = lemmy-help
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..84435e72ef68
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: numToStr <sudo@vikasraj.dev>
+
+pkgname=lemmy-help
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="Generate vim help doc from emmylua"
+arch=('x86_64' 'aarch64' 'armv7')
+url=https://github.com/numToStr/lemmy-help
+license=('GPL')
+provides=($pkgname)
+conflicts=($pkgname)
+
+source_x86_64=("$url/releases/download/$pkgver/$pkgname-x86_64-unknown-linux-gnu.tar.gz")
+md5sums_x86_64=(SKIP)
+
+source_armv7=("$url/releases/download/$pkgver/$pkgname-armv7-unknown-linux-gnueabihf.tar.gz")
+md5sums_armv7=(SKIP)
+
+source_aarch64=("$url/releases/download/$pkgver/$pkgname-aarch64-unknown-linux-gnu.tar.gz")
+md5sums_aarch64=(SKIP)
+
+package() {
+ install -Dm755 "${srcdir}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+}