summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCoelacanthus2020-06-13 14:31:23 +0800
committerCoelacanthus2020-06-13 14:31:23 +0800
commit39c8448d85c8e9e48d9dba057023c1e39bc989bc (patch)
treebf2c87123859c9c0c61e1a0a47427f7ec6fdfd77
parente7c71349c68ea86d6e8d850bf00c1e667c6a1ad7 (diff)
downloadaur-39c8448d85c8e9e48d9dba057023c1e39bc989bc.tar.gz
update
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD36
-rwxr-xr-x[-rw-r--r--]lemon-lime.desktop40
3 files changed, 43 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ced58d6ca96..f157d37d8865 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = lemon-lime
pkgdesc = 为了 OI 比赛而生的基于 Lemon 的轻量评测系统 | A tiny judging environment for OI contest based on Project_LemonPlus
pkgver = 0.2.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/iotang/Project_LemonLime
arch = x86_64
license = GPL3
depends = qt5-base
provides = lemon-lime
conflicts = lemon-lime-git
- source = https://github.com/iotang/Project_LemonLime/archive/v0.2.2.tar.gz
- source = https://github.com/itay-grudev/SingleApplication/archive/bae7c331ca7203a242e4533ba859c0c6016521ba/SingleApplication-bae7c331ca7203a242e4533ba859c0c6016521ba.tar.gz
+ source = LemonLime::git+https://github.com/iotang/Project_LemonLime
+ source = singleapplication::git+https://github.com/itay-grudev/SingleApplication
source = lemon-lime.desktop
- md5sums = 12904a15e10d9f3fde6730de9f57a298
- md5sums = 2a664159199854bf89c6bd1b46b1bfaf
- md5sums = 168d064b2c784975c30b30c27ba18062
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = 9502bfa470c41577c750314515bba6f0
pkgname = lemon-lime
diff --git a/PKGBUILD b/PKGBUILD
index 6e9e97d59ed6..f63f477931ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,8 @@
pkgname=lemon-lime
pkgver=0.2.2
-pkgrel=1
+pkgrel=2
epoch=
-_commit=bae7c331ca7203a242e4533ba859c0c6016521ba
pkgdesc="为了 OI 比赛而生的基于 Lemon 的轻量评测系统 | A tiny judging environment for OI contest based on Project_LemonPlus"
arch=(x86_64)
url="https://github.com/iotang/Project_LemonLime"
@@ -21,23 +20,32 @@ backup=()
options=()
install=
changelog=
-source=("https://github.com/iotang/Project_LemonLime/archive/v${pkgver}.tar.gz"
- "https://github.com/itay-grudev/SingleApplication/archive/$_commit/SingleApplication-$_commit.tar.gz"
- "lemon-lime.desktop"
- )
+source=(
+ 'LemonLime::git+https://github.com/iotang/Project_LemonLime'
+ 'singleapplication::git+https://github.com/itay-grudev/SingleApplication'
+ 'lemon-lime.desktop'
+)
noextract=()
-md5sums=('12904a15e10d9f3fde6730de9f57a298'
- '2a664159199854bf89c6bd1b46b1bfaf'
- '168d064b2c784975c30b30c27ba18062')
+md5sums=('SKIP'
+ 'SKIP'
+ '9502bfa470c41577c750314515bba6f0')
validpgpkeys=()
prepare() {
- cp -r SingleApplication-$_commit/* Project_LemonLime-$pkgver/singleapplication
-
+ cd "${srcdir}/LemonLime"
+ git checkout "v${pkgver}"
+ sed -i '/unix:QMAKE_LFLAGS += -no-pie/d' lemon.pro
+ git submodule init
+ submodules=('singleapplication')
+ for module in ${submodules[@]}; do
+ git config submodule."$module".url "${srcdir}/$module"
+ done
+
+ git submodule update
}
build() {
- cd "Project_LemonLime-$pkgver"
+ cd "${srcdir}/LemonLime"
#./configure --prefix=/usr
g++ watcher_unix.cpp -o watcher_unix -O2
qmake lemon.pro
@@ -46,12 +54,12 @@ build() {
}
check() {
- cd "Project_LemonLime-$pkgver"
+ cd "${srcdir}/LemonLime"
make -k check
}
package() {
- cd "Project_LemonLime-$pkgver"
+ cd "${srcdir}/LemonLime"
install -D -m755 lemon "$pkgdir/usr/bin/$pkgname"
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
diff --git a/lemon-lime.desktop b/lemon-lime.desktop
index dd3f719d5e93..183af915f4b8 100644..100755
--- a/lemon-lime.desktop
+++ b/lemon-lime.desktop
@@ -1,30 +1,20 @@
+#!/usr/bin/env xdg-open
[Desktop Entry]
-
-# The type as listed above
-Type=Application
-
-# The version of the desktop entry specification to which this file complies
Version=1.0
-
-# The name of the application
Name=LemonLime
-
-# A comment which can/will be used as a tooltip
+Type=Application
+GenericName=A tiny judging environment for OI contest
+GenericName[zh_CN]=为了 OI 比赛而生的轻量评测系统
+GenericName[zh_TW]=為了 OI 比賽而生的輕量評測系統
+GenericName[ja]=OI競争のための軽量評価システム
Comment=A tiny judging environment for OI contest based on Project_LemonPlus
-
-# The path to the folder in which the executable is run
-Path=/usr/bin/
-
-# The executable of the application, possibly with arguments.
-Exec=lemon-lime
-
-# The name of the icon that will be used to display this entry
-Icon=/usr/share/pixmaps/lemon-lime.png
-
-# Describes whether this application needs to be run in a terminal or not
-Terminal=false
-
-# Describes the categories in which this entry should be shown
+Comment[zh_CN]=为了 OI 比赛而生的基于 Lemon + LemonPlus 的轻量评测系统
+Comment[zh_TW]=為了 OI 比賽而生的基於 Lemon + LemonPlus 的輕量評測系統
+GenericName[ja]=Lemon + LemonPlusに基づくOI競争用の軽量評価システム
+Keywords=OI;Qt;Judge;
+Keywords[zh_CN]=OI;Qt;评测;
+Keywords[ja]=OI;Qt;評価;
Categories=Tools;
-
-
+Terminal=false
+Exec=lemon-lime
+Icon=lemon-lime