summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorayalhw2020-01-27 16:14:19 +0800
committerayalhw2020-01-27 16:14:19 +0800
commit6fe458bf5b9e571b6bd472e24dcc54419de44659 (patch)
tree5ee2a1b52727e3811dceb859f7991c1a104209b1
downloadaur-6fe458bf5b9e571b6bd472e24dcc54419de44659.tar.gz
Update
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD71
-rw-r--r--lemon-lime.desktop30
4 files changed, 122 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..66b7813eb485
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = lemon-lime
+ pkgdesc = 为了 OI 比赛而生的基于 Lemon 的轻量评测系统 | A tiny judging environment for OI contest based on Project_LemonPlus
+ pkgver = v.0.1.0120
+ pkgrel = 1
+ url = https://github.com/iotang/Project_LemonLime
+ arch = x86_64
+ license = GPL3
+ depends = qt5-base
+ provides = lemon-lime
+ conflicts = lemon-lime-git
+ source = yt-popball::git+https://github.com/iotang/Project_LemonLime.git
+ source = lemon-lime.desktop
+ md5sums = SKIP
+ md5sums = 168d064b2c784975c30b30c27ba18062
+
+pkgname = lemon-lime
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9acdf966c1a9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.tar.gz
+*.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..939621d22349
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,71 @@
+# Maintainer: Coelacanthus <liuhongwu2003@outlook.com>
+
+pkgname=lemon-lime
+pkgver=v.0.1.0120
+pkgrel=1
+epoch=
+pkgdesc="为了 OI 比赛而生的基于 Lemon 的轻量评测系统 | A tiny judging environment for OI contest based on Project_LemonPlus"
+arch=(x86_64)
+url="https://github.com/iotang/Project_LemonLime"
+license=('GPL3')
+groups=()
+depends=('qt5-base')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=("lemon-lime")
+conflicts=("lemon-lime-git")
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=('yt-popball::git+https://github.com/iotang/Project_LemonLime.git'
+ "lemon-lime.desktop"
+ )
+noextract=()
+md5sums=('SKIP'
+ '168d064b2c784975c30b30c27ba18062'
+ )
+validpgpkeys=()
+
+pkgver() {
+ cd "$srcdir/Project_LemonLime"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+# Git, tags available
+# printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+
+# Git, no tags available
+# printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+
+}
+
+prepare() {
+ cd "$srcdir/Project_LemonLime"
+
+}
+
+build() {
+ cd "$srcdir/Project_LemonLime"
+ #./configure --prefix=/usr
+ g++ watcher_unix.cpp -o watcher_unix -O2
+ qmake lemon.pro
+ make
+
+}
+
+check() {
+ cd "$srcdir/Project_LemonLime"
+ make -k check
+}
+
+package() {
+ cd "$srcdir/Project_LemonLime"
+ install -D -m755 lemon "$pkgdir/usr/bin/$pkgname"
+
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D -m644 pics/icon.png "$pkgdir/usr/share/pixmaps/lemon-lime.png"
+ install -D -m644 $srcdir/$pkgname.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -D -m644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+ #install -D -m644 Changelog.md "$pkgdir/usr/share/doc/$pkgname/Changelog.md"
+}
diff --git a/lemon-lime.desktop b/lemon-lime.desktop
new file mode 100644
index 000000000000..dd3f719d5e93
--- /dev/null
+++ b/lemon-lime.desktop
@@ -0,0 +1,30 @@
+[Desktop Entry]
+
+# The type as listed above
+Type=Application
+
+# The version of the desktop entry specification to which this file complies
+Version=1.0
+
+# The name of the application
+Name=LemonLime
+
+# A comment which can/will be used as a tooltip
+Comment=A tiny judging environment for OI contest based on Project_LemonPlus
+
+# The path to the folder in which the executable is run
+Path=/usr/bin/
+
+# The executable of the application, possibly with arguments.
+Exec=lemon-lime
+
+# The name of the icon that will be used to display this entry
+Icon=/usr/share/pixmaps/lemon-lime.png
+
+# Describes whether this application needs to be run in a terminal or not
+Terminal=false
+
+# Describes the categories in which this entry should be shown
+Categories=Tools;
+
+