summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCoelacanthus2022-02-07 14:58:08 +0800
committerCoelacanthus2022-02-07 14:58:08 +0800
commita6ab6d1c14912677ad15312fdfbb38e96c11ba92 (patch)
treedbdb68ada8872873a8c1c4b5cb7ce8ad627559b8
parente4c335641467dab831a1328e69cc8977b7976542 (diff)
downloadaur-a6ab6d1c14912677ad15312fdfbb38e96c11ba92.tar.gz
upgpkg: lemon-lime-git enable debug
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD53
2 files changed, 29 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9728b20ae0f5..f5055fdd64a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lemon-lime-git
pkgdesc = 为了 OI 比赛而生的基于 Lemon 的轻量评测系统 | A tiny judging environment for OI contest based on Project_LemonPlus
- pkgver = 0.3.0.dev118.r391.0023c4e
+ pkgver = 0.3.2.1.209523.r45767b5.
pkgrel = 1
epoch = 1
url = https://github.com/Project-LemonLime/Project_LemonLime
@@ -20,6 +20,8 @@ pkgbase = lemon-lime-git
optdepends = python: Python support
provides = lemon-lime
conflicts = lemon-lime
+ options = debug
+ options = strip
source = Project_LemonLime::git+https://github.com/Project-LemonLime/Project_LemonLime.git
source = SingleApplication::git+https://github.com/itay-grudev/SingleApplication.git
source = Testlib-for-Lemons::git+https://github.com/GitPinkRabbit/Testlib-for-Lemons.git
@@ -28,4 +30,3 @@ pkgbase = lemon-lime-git
b2sums = SKIP
pkgname = lemon-lime-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 8c0d3a4bc8da..8d4081d07b23 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=lemon-lime-git
_pkgname=lemon-lime
-pkgver=0.3.0.dev118.r391.0023c4e
+pkgver=0.3.2.1.209523.r45767b5.
pkgrel=1
epoch=1
pkgdesc="为了 OI 比赛而生的基于 Lemon 的轻量评测系统 | A tiny judging environment for OI contest based on Project_LemonPlus"
@@ -22,59 +22,58 @@ provides=("lemon-lime")
conflicts=("lemon-lime")
replaces=()
backup=()
-options=()
+options=(debug strip)
install=
changelog=
source=('Project_LemonLime::git+https://github.com/Project-LemonLime/Project_LemonLime.git'
- 'SingleApplication::git+https://github.com/itay-grudev/SingleApplication.git'
- 'Testlib-for-Lemons::git+https://github.com/GitPinkRabbit/Testlib-for-Lemons.git'
- )
+ 'SingleApplication::git+https://github.com/itay-grudev/SingleApplication.git'
+ 'Testlib-for-Lemons::git+https://github.com/GitPinkRabbit/Testlib-for-Lemons.git'
+ )
noextract=()
b2sums=('SKIP'
'SKIP'
- 'SKIP'
- )
+ 'SKIP')
validpgpkeys=()
pkgver() {
- cd "$srcdir/Project_LemonLime"
-# Git, tags available
- #printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g;s/^v//g')"
- __versuffix=$(cat ./makespec/VERSIONSUFFIX)
+ cd "$srcdir/Project_LemonLime"
+ # Git, tags available
+ #printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g;s/^v//g')"
+ __versuffix=$(cat ./makespec/VERSIONSUFFIX)
printf "%s.%s%s.r%s.%s" $(cat ./makespec/VERSION) ${__versuffix##-} $(cat ./makespec/BUILDVERSION) $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
}
prepare() {
- cd "$srcdir/Project_LemonLime"
+ cd "$srcdir/Project_LemonLime"
git submodule init
submodules=('SingleApplication')
for module in ${submodules[@]}; do
git config submodule."3rdparty/$module".url "${srcdir}/$module"
done
- git config submodule."assets/Testlib-for-Lemons".url "${srcdir}/Testlib-for-Lemons"
+ git config submodule."assets/Testlib-for-Lemons".url "${srcdir}/Testlib-for-Lemons"
git submodule update
}
build() {
- cd "$srcdir/Project_LemonLime"
- cmake . \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -GNinja \
- -DCMAKE_INSTALL_PREFIX=${pkgdir}/usr \
- -DLEMON_BUILD_INFO="Build for Arch Linux (Git Version)" \
- -DLEMON_BUILD_EXTRA_INFO="Build on $(uname -a | cut -d " " -f3,13)" \
- -DEMBED_TRANSLATIONS=OFF \
- -DEMBED_DOCS=OFF
- ninja
+ cd "$srcdir/Project_LemonLime"
+ cmake -S . -B build \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -GNinja \
+ -DCMAKE_INSTALL_PREFIX=${pkgdir}/usr \
+ -DLEMON_BUILD_INFO="Build for Arch Linux (Git Version)" \
+ -DLEMON_BUILD_EXTRA_INFO="Build on $(uname -a | cut -d " " -f3,13)" \
+ -DEMBED_TRANSLATIONS=OFF \
+ -DEMBED_DOCS=OFF
+ ninja -C build
}
package() {
- cd "$srcdir/Project_LemonLime"
- ninja install
- install -D -m644 README.md "$pkgdir/usr/share/doc/$_pkgname/README.md"
- #install -D -m644 Changelog.md "$pkgdir/usr/share/doc/$pkgname/Changelog.md"
+ cd "$srcdir/Project_LemonLime"
+ ninja -C build install
+ install -D -m644 README.md "$pkgdir/usr/share/doc/$_pkgname/README.md"
+ #install -D -m644 Changelog.md "$pkgdir/usr/share/doc/$pkgname/Changelog.md"
}