summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCoelacanthus2021-02-17 20:31:19 +0800
committerCoelacanthus2021-02-17 20:31:19 +0800
commite4c335641467dab831a1328e69cc8977b7976542 (patch)
tree31958a586aa769bf06b6a9e23581340ecbdf699c
parentd487742bdf3af8ae7622bb46ef2a29cdc272430d (diff)
downloadaur-e4c335641467dab831a1328e69cc8977b7976542.tar.gz
upgpkg: lemon-lime-git update testlib
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ccc3dafcba6e..9728b20ae0f5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lemon-lime-git
pkgdesc = 为了 OI 比赛而生的基于 Lemon 的轻量评测系统 | A tiny judging environment for OI contest based on Project_LemonPlus
- pkgver = 0.3.0.118.r389.557ff10
+ pkgver = 0.3.0.dev118.r391.0023c4e
pkgrel = 1
epoch = 1
url = https://github.com/Project-LemonLime/Project_LemonLime
@@ -22,8 +22,10 @@ pkgbase = lemon-lime-git
conflicts = lemon-lime
source = Project_LemonLime::git+https://github.com/Project-LemonLime/Project_LemonLime.git
source = SingleApplication::git+https://github.com/itay-grudev/SingleApplication.git
- sha512sums = SKIP
- sha512sums = SKIP
+ source = Testlib-for-Lemons::git+https://github.com/GitPinkRabbit/Testlib-for-Lemons.git
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
pkgname = lemon-lime-git
diff --git a/PKGBUILD b/PKGBUILD
index 6ecdabee361b..8c0d3a4bc8da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=lemon-lime-git
_pkgname=lemon-lime
-pkgver=0.3.0.118.r389.557ff10
+pkgver=0.3.0.dev118.r391.0023c4e
pkgrel=1
epoch=1
pkgdesc="为了 OI 比赛而生的基于 Lemon 的轻量评测系统 | A tiny judging environment for OI contest based on Project_LemonPlus"
@@ -27,10 +27,12 @@ install=
changelog=
source=('Project_LemonLime::git+https://github.com/Project-LemonLime/Project_LemonLime.git'
'SingleApplication::git+https://github.com/itay-grudev/SingleApplication.git'
+ 'Testlib-for-Lemons::git+https://github.com/GitPinkRabbit/Testlib-for-Lemons.git'
)
noextract=()
-sha512sums=('SKIP'
- 'SKIP'
+b2sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
)
validpgpkeys=()
@@ -38,7 +40,8 @@ pkgver() {
cd "$srcdir/Project_LemonLime"
# Git, tags available
#printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g;s/^v//g')"
- printf "%s.%s.r%s.%s" $(cat ./makespec/VERSION) $(cat ./makespec/BUILDVERSION) $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+ __versuffix=$(cat ./makespec/VERSIONSUFFIX)
+ printf "%s.%s%s.r%s.%s" $(cat ./makespec/VERSION) ${__versuffix##-} $(cat ./makespec/BUILDVERSION) $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
}
@@ -50,6 +53,8 @@ prepare() {
git config submodule."3rdparty/$module".url "${srcdir}/$module"
done
+ git config submodule."assets/Testlib-for-Lemons".url "${srcdir}/Testlib-for-Lemons"
+
git submodule update
}