summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCoelacanthus2024-05-13 21:19:08 +0800
committerCoelacanthus2024-05-13 21:19:08 +0800
commitf40a31fef37c930b7b0e01ec0ab2152cb46089d0 (patch)
treed8f64d26a0aa1e5cb3bf5c360c0db122e7b8e8c5
parentcd40b17b6af989bc4ecde21c97dfbd87eb786d8c (diff)
downloadaur-f40a31fef37c930b7b0e01ec0ab2152cb46089d0.tar.gz
lemon-lime-git: tweak style
Signed-off-by: Coelacanthus <CoelacanthusHex@gmail.com>
-rw-r--r--PKGBUILD55
1 files changed, 30 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 34e8561ef760..d0a951a12ff0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,41 +2,48 @@
pkgname=lemon-lime-git
_pkgname=lemon-lime
-pkgver=0.3.2.1.209523.r45767b5.
+pkgver=0.3.5alpha2.r31.g5be9374
pkgrel=1
epoch=1
pkgdesc="为了 OI 比赛而生的基于 Lemon 的轻量评测系统 | A tiny judging environment for OI contest based on Project_LemonPlus"
arch=('x86_64' 'i686')
url="https://github.com/Project-LemonLime/Project_LemonLime"
license=('GPL-3.0-or-later')
-depends=('qt5-base' 'hicolor-icon-theme')
-makedepends=('git' 'qt5-tools' 'cmake' 'ninja')
-optdepends=('gcc: C and C++ support'
- 'fpc: Pascal support'
- 'java-environment: Java support'
+depends=('gcc-libs'
+ 'glibc'
+ 'hicolor-icon-theme'
+ 'qt5-base'
+ 'xdg-utils'
+ )
+makedepends=('cmake'
+ 'git'
+ 'ninja'
+ 'qt5-tools'
+ )
+optdepends=('fpc: Pascal support'
'freebasic: BASIC support'
+ 'gcc: C and C++ support'
+ 'java-environment: Java support'
'python: Python support')
-provides=("lemon-lime")
-conflicts=("lemon-lime")
-source=('Project_LemonLime::git+https://github.com/Project-LemonLime/Project_LemonLime.git'
- 'SingleApplication::git+https://github.com/itay-grudev/SingleApplication.git'
- 'Testlib-for-Lemons::git+https://github.com/GitPinkRabbit/Testlib-for-Lemons.git'
- )
+provides=('lemon-lime')
+conflicts=('lemon-lime')
+
+source=(Project_LemonLime::git+https://github.com/Project-LemonLime/Project_LemonLime.git
+ SingleApplication::git+https://github.com/itay-grudev/SingleApplication.git
+ Testlib-for-Lemons::git+https://github.com/GitPinkRabbit/Testlib-for-Lemons.git
+ )
+
b2sums=('SKIP'
'SKIP'
'SKIP')
pkgver() {
- cd "$srcdir/Project_LemonLime"
- # Git, tags available
- #printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g;s/^v//g')"
- __versuffix=$(cat ./makespec/VERSIONSUFFIX)
- printf "%s.%s%s.r%s.%s" $(cat ./makespec/VERSION) ${__versuffix##-} $(cat ./makespec/BUILDVERSION) $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
-
+ cd "Project_LemonLime"
+ git describe --long --tags --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-//;s/-/./g'
}
prepare() {
- cd "$srcdir/Project_LemonLime"
+ cd "Project_LemonLime"
git submodule init
submodules=('SingleApplication')
for module in ${submodules[@]}; do
@@ -49,11 +56,10 @@ prepare() {
}
build() {
- cd "$srcdir/Project_LemonLime"
- cmake -S . -B build \
+ cmake -S Project_LemonLime -B build \
-DCMAKE_BUILD_TYPE=None \
-GNinja \
- -DCMAKE_INSTALL_PREFIX=${pkgdir}/usr \
+ -DCMAKE_INSTALL_PREFIX="$pkgdir/usr" \
-DLEMON_BUILD_INFO="Build for Arch Linux (Git Version)" \
-DLEMON_BUILD_EXTRA_INFO="Build on $(uname -a | cut -d " " -f3,13)" \
-DEMBED_TRANSLATIONS=OFF \
@@ -63,8 +69,7 @@ build() {
}
package() {
- cd "$srcdir/Project_LemonLime"
ninja -C build install
- install -D -m644 README.md "$pkgdir/usr/share/doc/$_pkgname/README.md"
- #install -D -m644 Changelog.md "$pkgdir/usr/share/doc/$pkgname/Changelog.md"
}
+
+# vim: set ts=4 sw=4 et: