summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan Chan2019-05-31 21:53:17 +0100
committerRyan Chan2019-05-31 21:53:17 +0100
commit1e4ea687b25836dc2dec107346eb28b512f7b8a4 (patch)
treee13a7e361d0d9ec0e4ce0defdabe1a85ad516031
downloadaur-1e4ea687b25836dc2dec107346eb28b512f7b8a4.tar.gz
Add version 0.3.3 of output script for lemonbar
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD27
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2f0cc1e915dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = lemons
+ pkgdesc = Output script for lemonbar
+ pkgver = 0.3.3
+ pkgrel = 1
+ url = https://git.sr.ht/~rycwo/lemons
+ arch = any
+ license = custom:Unlicense
+ depends = bash
+ depends = lemonbar-xft-git
+ depends = ttf-font-awesome-4
+ depends = acpi
+ depends = alsa-utils
+ depends = pulseaudio
+ depends = pulseaudio-alsa
+ depends = bspwm
+ optdepends = ttf-dejavu: for a nice default font
+ source = https://git.sr.ht/~rycwo/lemons/archive/0.3.3.tar.gz
+ sha256sums = c283cc705d0fcbe5a00189257611303d6b8faacb174080d9b8b1052b30377c3f
+
+pkgname = lemons
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7b092346e423
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..477db59a2301
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Ryan Chan <ryan at rycwo dot xyz>
+
+pkgname="lemons"
+pkgver="0.3.3"
+pkgrel=1
+pkgdesc="Output script for lemonbar"
+arch=("any")
+url="https://git.sr.ht/~rycwo/lemons"
+license=("custom:Unlicense")
+depends=(
+ "bash"
+ "lemonbar-xft-git"
+ "ttf-font-awesome-4"
+ "acpi"
+ "alsa-utils"
+ "pulseaudio"
+ "pulseaudio-alsa"
+ "bspwm")
+optdepends=("ttf-dejavu: for a nice default font")
+source=("https://git.sr.ht/~rycwo/""$pkgname""/archive/""$pkgver"".tar.gz")
+sha256sums=('c283cc705d0fcbe5a00189257611303d6b8faacb174080d9b8b1052b30377c3f')
+
+package() {
+ cd "$srcdir""/""$pkgname""-""$pkgver"
+ install -Dm644 LICENSE "$pkgdir""/usr/share/licenses/""$pkgname""/LICENSE"
+ install -Dm755 lemons "$pkgdir""/usr/bin/lemons"
+}