summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUwe Koloska2015-07-07 23:35:58 +0200
committerUwe Koloska2015-07-07 23:35:58 +0200
commit55cee84659e7c32f038413a1d0020d1ffd2ea800 (patch)
tree14e69318391e42e3080531582ac9b9c8264b2539
downloadaur-55cee84659e7c32f038413a1d0020d1ffd2ea800.tar.gz
Initial import
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD51
-rw-r--r--cmake-boost.patch19
-rw-r--r--cmake-find.patch11
-rw-r--r--cmake-wxgtk.patch10
-rw-r--r--lenmus-src.patch22
-rw-r--r--lenmus-unittest.patch11
7 files changed, 157 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..84813af82930
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = lenmus
+ pkgdesc = A free program to learn music
+ pkgver = 5.3.1
+ pkgrel = 2
+ url = http://lenmus.sourceforge.net/en/phonascus/intro
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = bzr
+ makedepends = boost
+ makedepends = unittestpp
+ depends = portmidi
+ depends = freetype2
+ depends = wxgtk2.8
+ depends = sqlite3
+ depends = boost-libs
+ depends = liblomse>=0.14.0
+ optdepends = timidity++: for sound without external midi player
+ source = http://downloads.sourceforge.net/lenmus/lenmus_5.3.1.tar.gz
+ source = cmake-boost.patch
+ source = cmake-find.patch
+ source = cmake-wxgtk.patch
+ source = lenmus-src.patch
+ source = lenmus-unittest.patch
+ md5sums = 76e0e24c63246aa43f241f683e181973
+ md5sums = 17ce17d77ed2d065156f535d1438a30f
+ md5sums = 4dfbbbf1a1a34ff8d53767a5f2744ee7
+ md5sums = 923d4c27a992d5a9c0590e3529665a57
+ md5sums = 6593c53701f071271bdb35410df58c06
+ md5sums = c4a3546fd2078c72a3b1306dabfc9d2b
+
+pkgname = lenmus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a56c9a0cc145
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Uwe Koloska <kolewu@koloro.de>
+# Contributor: Chris Chapman <chris dot chapman at aggiemail dot usu dot edu>
+
+pkgname=lenmus
+pkgver=5.3.1
+pkgrel=2
+pkgdesc="A free program to learn music"
+arch=('i686' 'x86_64')
+url="http://lenmus.sourceforge.net/en/phonascus/intro"
+license=('GPL')
+depends=('portmidi' 'freetype2' 'wxgtk2.8' 'sqlite3' 'boost-libs' 'liblomse>=0.14.0')
+optdepends=('timidity++: for sound without external midi player')
+makedepends=('bzr' 'boost' 'unittestpp')
+
+source=("http://downloads.sourceforge.net/lenmus/${pkgname}_${pkgver}.tar.gz"
+ 'cmake-boost.patch'
+ 'cmake-find.patch'
+ 'cmake-wxgtk.patch'
+ 'lenmus-src.patch'
+ 'lenmus-unittest.patch')
+md5sums=('76e0e24c63246aa43f241f683e181973'
+ '17ce17d77ed2d065156f535d1438a30f'
+ '4dfbbbf1a1a34ff8d53767a5f2744ee7'
+ '923d4c27a992d5a9c0590e3529665a57'
+ '6593c53701f071271bdb35410df58c06'
+ 'c4a3546fd2078c72a3b1306dabfc9d2b')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ patch < "${srcdir}/cmake-boost.patch" || return 1
+ patch -p0 < "${srcdir}/cmake-find.patch" || return 1
+ patch -p0 < "${srcdir}/cmake-wxgtk.patch" || return 1
+ patch -p0 < "${srcdir}/lenmus-src.patch" || return 1
+ patch -p0 < "${srcdir}/lenmus-unittest.patch" || return 1
+
+ cd "$srcdir"
+ rm -rf build
+ mkdir build
+
+ cd build
+ cmake -G "Unix Makefiles" -DCMAKE_INSTALL_PREFIX=/usr ../${pkgname}-${pkgver}/
+
+ make -j$(nproc) || return 1
+}
+
+package() {
+ cd "${srcdir}/build"
+
+ make DESTDIR="${pkgdir}/" install
+}
diff --git a/cmake-boost.patch b/cmake-boost.patch
new file mode 100644
index 000000000000..1e849226d9f4
--- /dev/null
+++ b/cmake-boost.patch
@@ -0,0 +1,19 @@
+--- CMakeLists-orig.txt 2013-05-02 18:04:36.000000000 +0200
++++ CMakeLists.txt 2015-04-09 23:22:39.735065332 +0200
+@@ -310,14 +310,14 @@
+
+ # Check for Boost >= 1.42.0
+ set(Boost_ADDITIONAL_VERSIONS "1.42" "1.42.0" "1.43" "1.43.0" "1.44" "1.44.0"
+- "1.45" "1.45.0" "1.46" "1.46.0" "1.47" "1.47.0" "1.48" "1.48.0""1.49" "1.49.0"
++ "1.45" "1.45.0" "1.46" "1.46.0" "1.47" "1.47.0" "1.48" "1.48.0" "1.49" "1.49.0"
+ "1.50" "1.50.0" "1.51" "1.51.0" "1.52" "1.52.0" )
+ #set(Boost_USE_STATIC_LIBS OFF)
+ #set(Boost_USE_MULTITHREADED OFF)
+ #set(Boost_USE_STATIC_RUNTIME OFF)
+ #set(Boost_DEBUG TRUE)
+
+-find_package(Boost 1.42.0 COMPONENTS date_time thread REQUIRED)
++find_package(Boost 1.42.0 COMPONENTS date_time thread system REQUIRED)
+ if(Boost_FOUND)
+ include_directories(${Boost_INCLUDE_DIRS})
+ link_libraries( ${Boost_LIBRARIES} )
diff --git a/cmake-find.patch b/cmake-find.patch
new file mode 100644
index 000000000000..c0fc7bfae573
--- /dev/null
+++ b/cmake-find.patch
@@ -0,0 +1,11 @@
+--- cmake-modules/FindLomse.cmake.orig 2013-06-09 02:08:19.288227029 +0200
++++ cmake-modules/FindLomse.cmake 2013-06-09 02:07:56.305747005 +0200
+@@ -29,7 +29,7 @@
+ )
+
+ find_library(LOMSE_LIBRARY
+- NAMES liblomse liblomse.a
++ NAMES liblomse.so liblomse.a
+ PATHS
+ /usr/lib/
+ /usr/local/lib
diff --git a/cmake-wxgtk.patch b/cmake-wxgtk.patch
new file mode 100644
index 000000000000..624a9e7c701c
--- /dev/null
+++ b/cmake-wxgtk.patch
@@ -0,0 +1,10 @@
+--- CMakeLists-orig.txt 2015-04-09 21:03:19.194764238 +0200
++++ CMakeLists.txt 2015-04-09 23:13:58.753179132 +0200
+@@ -260,6 +260,7 @@
+
+ # Check for wxWidgets
+ # http://docs.wxwidgets.org/2.8/wx_librarieslist.html
++set( wxWidgets_CONFIG_EXECUTABLE "wx-config-2.8" )
+ find_package(wxWidgets REQUIRED)
+ IF(wxWidgets_FOUND)
+ #include_directories( ${wxWidgets_INCLUDE_DIRS} )
diff --git a/lenmus-src.patch b/lenmus-src.patch
new file mode 100644
index 000000000000..365b1be86be0
--- /dev/null
+++ b/lenmus-src.patch
@@ -0,0 +1,22 @@
+--- include/lenmus_main_frame.h.orig 2013-04-03 02:39:19.290558529 +0200
++++ include/lenmus_main_frame.h 2013-04-03 02:39:29.833496561 +0200
+@@ -25,7 +25,6 @@
+ #include "lenmus_standard_header.h"
+ #include "lenmus_injectors.h"
+ #include "lenmus_canvas.h"
+-#include "lenmus_test_runner.h"
+ #include "lenmus_dlg_debug.h"
+ #include "lenmus_events.h"
+ #include "lenmus_metronome.h"
+
+--- include/lenmus_test_runner.h.orig 2012-11-30 17:03:57.000000000 +0100
++++ include/lenmus_test_runner.h 2013-04-03 00:29:09.678911430 +0200
+@@ -24,7 +24,7 @@
+ #include <iostream>
+
+ #include <UnitTest++.h>
+-#include <TestReporter.h>
++#include <UnitTest++/TestReporter.h>
+
+
+
diff --git a/lenmus-unittest.patch b/lenmus-unittest.patch
new file mode 100644
index 000000000000..4be532b9b9b5
--- /dev/null
+++ b/lenmus-unittest.patch
@@ -0,0 +1,11 @@
+--- include/lenmus_test_runner.h~ 2015-04-09 21:03:19.198097455 +0200
++++ include/lenmus_test_runner.h 2015-04-09 23:06:32.135360458 +0200
+@@ -24,7 +24,7 @@
+ #include <iostream>
+
+ #include <UnitTest++.h>
+-#include <UnitTest++/TestReporter.h>
++#include <TestReporter.h>
+
+
+