summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUwe Koloska2022-02-16 23:24:31 +0100
committerUwe Koloska2022-02-16 23:24:31 +0100
commit75084df2854977aaff625e1745250a6008f585fc (patch)
tree0b9bc01904ae0bbb239bd9d3c6ec2d7e88b605c2
parent3d9952b9fdd35647be9a476fc87a26567c11e903 (diff)
downloadaur-75084df2854977aaff625e1745250a6008f585fc.tar.gz
new version 6.0.0
-rw-r--r--.SRCINFO15
-rw-r--r--0001-FindPortMidi.patch13
-rw-r--r--PKGBUILD24
3 files changed, 38 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4d12c0d03c4..7cddee63d700 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,22 @@
pkgbase = lenmus
pkgdesc = A free program for learning music
- pkgver = 5.6.2
- pkgrel = 2
+ pkgver = 6.0.0
+ pkgrel = 1
url = http://www.lenmus.org/
arch = i686
arch = x86_64
license = GPL
makedepends = unittestpp
- makedepends = cmake>=3.1
+ makedepends = cmake
depends = portmidi
- depends = wxgtk2
+ depends = wxgtk3
depends = sqlite3
depends = fluidsynth
depends = soundfont-fluid
optdepends = timidity++: for sound without external midi player
- source = https://github.com/lenmus/lenmus/archive/Release_5.6.2.tar.gz
- sha256sums = 72af23c1f5d4b543cece326b50d7e8b9fb1f9da8e64e7ec65e6f88c2c3c77c6c
+ source = https://github.com/lenmus/lenmus/archive/Release_6.0.0.tar.gz
+ source = 0001-FindPortMidi.patch
+ sha256sums = 235a44a04e827fb9a118073ffcc92dc3714df073b7c67e915b860d3a8480e4fd
+ sha256sums = 43d92d3022cc2d57f35c9b6fde4997fa2dac8e0ff40afdc4078230b0aefb360f
pkgname = lenmus
-
diff --git a/0001-FindPortMidi.patch b/0001-FindPortMidi.patch
new file mode 100644
index 000000000000..17b13948bdcd
--- /dev/null
+++ b/0001-FindPortMidi.patch
@@ -0,0 +1,13 @@
+--- cmake-modules/FindPortMidi__orig.cmake 2022-02-16 22:55:59.475034657 +0100
++++ cmake-modules/FindPortMidi.cmake 2022-02-16 23:04:41.224419310 +0100
+@@ -62,8 +62,10 @@
+ )
+ #porttime is an independent package
+ set(DISTROS_USING_PORTTIME
++ Arch
+ Debian
+ LinuxMint
++ ManjaroLinux
+ Ubuntu
+ )
+
diff --git a/PKGBUILD b/PKGBUILD
index af2818bb9856..c21be9e8e13d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,36 @@
# Contributor: Chris Chapman <chris dot chapman at aggiemail dot usu dot edu>
pkgname=lenmus
-pkgver=5.6.2
-pkgrel=2
+pkgver=6.0.0
+pkgrel=1
pkgdesc="A free program for learning music"
arch=('i686' 'x86_64')
url="http://www.lenmus.org/"
license=('GPL')
-depends=('portmidi' 'wxgtk2' 'sqlite3' 'fluidsynth' 'soundfont-fluid')
+depends=('portmidi' 'wxgtk3' 'sqlite3' 'fluidsynth' 'soundfont-fluid')
optdepends=('timidity++: for sound without external midi player')
-makedepends=('unittestpp' 'cmake>=3.1')
+makedepends=('unittestpp' 'cmake')
-source=("https://github.com/lenmus/lenmus/archive/Release_${pkgver}.tar.gz")
-sha256sums=('72af23c1f5d4b543cece326b50d7e8b9fb1f9da8e64e7ec65e6f88c2c3c77c6c')
+source=("https://github.com/lenmus/lenmus/archive/Release_${pkgver}.tar.gz"
+ "0001-FindPortMidi.patch")
+sha256sums=('235a44a04e827fb9a118073ffcc92dc3714df073b7c67e915b860d3a8480e4fd'
+ '43d92d3022cc2d57f35c9b6fde4997fa2dac8e0ff40afdc4078230b0aefb360f')
+
+prepare() {
+ cd "$srcdir"/${pkgname}-Release_${pkgver}
+ rm cmake-modules/FindSQLite3.cmake
+ patch -p0 -i "$srcdir/0001-FindPortMidi.patch"
+}
build() {
cd "$srcdir"
+
rm -rf build
mkdir build
cd build
- cmake -G "Unix Makefiles" -DCMAKE_INSTALL_PREFIX=/usr "../${pkgname}-Release_${pkgver}/"
+ WX_CONFIG=wx-config-gtk3 cmake -G "Unix Makefiles" \
+ -DCMAKE_INSTALL_PREFIX=/usr "../${pkgname}-Release_${pkgver}/"
make -j$(nproc) || return 1
}