summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUwe Koloska2015-12-13 01:21:05 +0100
committerUwe Koloska2015-12-13 01:21:05 +0100
commit8cb561e2ee4135ba276d9fc6b1593c96721aa92a (patch)
tree96792de69a933b5624b67d43ee3ebafec49c4ed8
parentbd1f0b93a930e588bc3d33ecc50baf8f22f9878c (diff)
downloadaur-8cb561e2ee4135ba276d9fc6b1593c96721aa92a.tar.gz
new version 5.3.2 now includes liblomse
unfortunately there is no direct download for this version of lenmus and the cloning of the repository takes a very long time -- so be patient
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD31
-rw-r--r--cmake-boost.patch16
-rw-r--r--cmake-freetype.patch11
-rw-r--r--lenmus-src.patch22
-rw-r--r--lenmus-unittest.patch11
6 files changed, 38 insertions, 74 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6aa692f7fb99..251cd5511c5f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,35 +1,32 @@
# Generated by mksrcinfo v8
-# Sat Dec 12 17:02:13 UTC 2015
+# Sun Dec 13 00:20:41 UTC 2015
pkgbase = lenmus
pkgdesc = A free program to learn music
- pkgver = 5.3.1
- pkgrel = 3
+ pkgver = 5.3.2
+ pkgrel = 4
url = http://lenmus.sourceforge.net/en/phonascus/intro
arch = i686
arch = x86_64
license = GPL
+ makedepends = bzr
makedepends = boost
makedepends = unittestpp
makedepends = cmake>=2.8
depends = portmidi
- depends = freetype2
depends = wxgtk2.8
depends = sqlite3
depends = boost-libs
- depends = liblomse>=0.14.0
optdepends = timidity++: for sound without external midi player
- source = https://launchpad.net/lenmus/trunk/5.3.1/+download/lenmus_5.3.1.tar.gz
+ source = bzr+lp:lenmus#revision=Release_5.3.2
source = cmake-boost.patch
source = cmake-find.patch
+ source = cmake-freetype.patch
source = cmake-wxgtk.patch
- source = lenmus-src.patch
- source = lenmus-unittest.patch
- md5sums = 76e0e24c63246aa43f241f683e181973
- md5sums = 17ce17d77ed2d065156f535d1438a30f
+ md5sums = SKIP
+ md5sums = 2deed1b6d5fb615a88c849fa5db671c1
md5sums = 4dfbbbf1a1a34ff8d53767a5f2744ee7
+ md5sums = c406113341ec3f5bdc87573a62d1954b
md5sums = 923d4c27a992d5a9c0590e3529665a57
- md5sums = 6593c53701f071271bdb35410df58c06
- md5sums = c4a3546fd2078c72a3b1306dabfc9d2b
pkgname = lenmus
diff --git a/PKGBUILD b/PKGBUILD
index e6931453cb7f..73021032203c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,44 +2,41 @@
# Contributor: Chris Chapman <chris dot chapman at aggiemail dot usu dot edu>
pkgname=lenmus
-pkgver=5.3.1
-pkgrel=3
+pkgver=5.3.2
+pkgrel=4
pkgdesc="A free program to learn music"
arch=('i686' 'x86_64')
url="http://lenmus.sourceforge.net/en/phonascus/intro"
license=('GPL')
-depends=('portmidi' 'freetype2' 'wxgtk2.8' 'sqlite3' 'boost-libs' 'liblomse>=0.14.0')
+depends=('portmidi' 'wxgtk2.8' 'sqlite3' 'boost-libs')
optdepends=('timidity++: for sound without external midi player')
-makedepends=('boost' 'unittestpp' 'cmake>=2.8')
+makedepends=('bzr' 'boost' 'unittestpp' 'cmake>=2.8')
-source=("https://launchpad.net/lenmus/trunk/${pkgver}/+download/${pkgname}_${pkgver}.tar.gz"
+source=("bzr+lp:${pkgname}#revision=Release_${pkgver}"
'cmake-boost.patch'
'cmake-find.patch'
- 'cmake-wxgtk.patch'
- 'lenmus-src.patch'
- 'lenmus-unittest.patch')
-md5sums=('76e0e24c63246aa43f241f683e181973'
- '17ce17d77ed2d065156f535d1438a30f'
+ 'cmake-freetype.patch'
+ 'cmake-wxgtk.patch')
+md5sums=('SKIP'
+ '2deed1b6d5fb615a88c849fa5db671c1'
'4dfbbbf1a1a34ff8d53767a5f2744ee7'
- '923d4c27a992d5a9c0590e3529665a57'
- '6593c53701f071271bdb35410df58c06'
- 'c4a3546fd2078c72a3b1306dabfc9d2b')
+ 'c406113341ec3f5bdc87573a62d1954b'
+ '923d4c27a992d5a9c0590e3529665a57')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}"
patch < "${srcdir}/cmake-boost.patch" || return 1
patch -p0 < "${srcdir}/cmake-find.patch" || return 1
+ patch -p0 < "${srcdir}/cmake-freetype.patch" || return 1
patch -p0 < "${srcdir}/cmake-wxgtk.patch" || return 1
- patch -p0 < "${srcdir}/lenmus-src.patch" || return 1
- patch -p0 < "${srcdir}/lenmus-unittest.patch" || return 1
cd "$srcdir"
rm -rf build
mkdir build
cd build
- cmake -G "Unix Makefiles" -DCMAKE_INSTALL_PREFIX=/usr ../${pkgname}-${pkgver}/
+ cmake -G "Unix Makefiles" -DCMAKE_INSTALL_PREFIX=/usr ../${pkgname}/
make -j$(nproc) || return 1
}
diff --git a/cmake-boost.patch b/cmake-boost.patch
index 1e849226d9f4..e0e0556ee647 100644
--- a/cmake-boost.patch
+++ b/cmake-boost.patch
@@ -1,19 +1,11 @@
---- CMakeLists-orig.txt 2013-05-02 18:04:36.000000000 +0200
-+++ CMakeLists.txt 2015-04-09 23:22:39.735065332 +0200
-@@ -310,14 +310,14 @@
+--- CMakeLists.txt.orig 2015-12-12 22:38:34.398441603 +0100
++++ CMakeLists.txt 2015-12-12 22:46:36.112515218 +0100
+@@ -327,7 +327,7 @@
# Check for Boost >= 1.42.0
set(Boost_ADDITIONAL_VERSIONS "1.42" "1.42.0" "1.43" "1.43.0" "1.44" "1.44.0"
- "1.45" "1.45.0" "1.46" "1.46.0" "1.47" "1.47.0" "1.48" "1.48.0""1.49" "1.49.0"
+ "1.45" "1.45.0" "1.46" "1.46.0" "1.47" "1.47.0" "1.48" "1.48.0" "1.49" "1.49.0"
- "1.50" "1.50.0" "1.51" "1.51.0" "1.52" "1.52.0" )
+ "1.50" "1.50.0" "1.51" "1.51.0" "1.52" "1.52.0" "1.53" "1.53.0" "1.54" "1.54.0" )
#set(Boost_USE_STATIC_LIBS OFF)
#set(Boost_USE_MULTITHREADED OFF)
- #set(Boost_USE_STATIC_RUNTIME OFF)
- #set(Boost_DEBUG TRUE)
-
--find_package(Boost 1.42.0 COMPONENTS date_time thread REQUIRED)
-+find_package(Boost 1.42.0 COMPONENTS date_time thread system REQUIRED)
- if(Boost_FOUND)
- include_directories(${Boost_INCLUDE_DIRS})
- link_libraries( ${Boost_LIBRARIES} )
diff --git a/cmake-freetype.patch b/cmake-freetype.patch
new file mode 100644
index 000000000000..06f04e948953
--- /dev/null
+++ b/cmake-freetype.patch
@@ -0,0 +1,11 @@
+--- cmake-modules/FindFreetype.cmake.orig 2015-12-12 23:38:01.303307876 +0100
++++ cmake-modules/FindFreetype.cmake 2015-12-12 23:40:29.945032519 +0100
+@@ -55,6 +55,8 @@
+ /sw/include
+ /opt/local/include
+ /usr/freeware/include
++ /usr/include
++ PATH_SUFFIXES freetype2
+ )
+
+ FIND_PATH(FREETYPE_INCLUDE_DIR_freetype2 freetype/config/ftheader.h
diff --git a/lenmus-src.patch b/lenmus-src.patch
deleted file mode 100644
index 365b1be86be0..000000000000
--- a/lenmus-src.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- include/lenmus_main_frame.h.orig 2013-04-03 02:39:19.290558529 +0200
-+++ include/lenmus_main_frame.h 2013-04-03 02:39:29.833496561 +0200
-@@ -25,7 +25,6 @@
- #include "lenmus_standard_header.h"
- #include "lenmus_injectors.h"
- #include "lenmus_canvas.h"
--#include "lenmus_test_runner.h"
- #include "lenmus_dlg_debug.h"
- #include "lenmus_events.h"
- #include "lenmus_metronome.h"
-
---- include/lenmus_test_runner.h.orig 2012-11-30 17:03:57.000000000 +0100
-+++ include/lenmus_test_runner.h 2013-04-03 00:29:09.678911430 +0200
-@@ -24,7 +24,7 @@
- #include <iostream>
-
- #include <UnitTest++.h>
--#include <TestReporter.h>
-+#include <UnitTest++/TestReporter.h>
-
-
-
diff --git a/lenmus-unittest.patch b/lenmus-unittest.patch
deleted file mode 100644
index 4be532b9b9b5..000000000000
--- a/lenmus-unittest.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- include/lenmus_test_runner.h~ 2015-04-09 21:03:19.198097455 +0200
-+++ include/lenmus_test_runner.h 2015-04-09 23:06:32.135360458 +0200
-@@ -24,7 +24,7 @@
- #include <iostream>
-
- #include <UnitTest++.h>
--#include <UnitTest++/TestReporter.h>
-+#include <TestReporter.h>
-
-
-