summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUwe Koloska2022-09-24 01:51:30 +0200
committerUwe Koloska2022-09-24 01:51:30 +0200
commit97e40849067a2207813a629399380d0e4416d254 (patch)
tree236bdfddab100a1210762615b9f11d17238fae85
parentd97018de462bd2e4207995aa990036304b2aaf3c (diff)
downloadaur-97e40849067a2207813a629399380d0e4416d254.tar.gz
New version 6.0.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
2 files changed, 9 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0bf5675e32b9..af02fcbbd633 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lenmus
pkgdesc = A free program for learning music
- pkgver = 6.0.0
- pkgrel = 3
+ pkgver = 6.0.1
+ pkgrel = 1
url = http://www.lenmus.org/
arch = i686
arch = x86_64
@@ -15,11 +15,7 @@ pkgbase = lenmus
depends = fluidsynth
depends = soundfont-fluid
optdepends = timidity++: for sound without external midi player
- source = https://github.com/lenmus/lenmus/archive/Release_6.0.0.tar.gz
- source = 0001-FindPortMidi.patch
- source = 0001-Fix-SetHTMLBackgroundImage.patch
- sha256sums = 235a44a04e827fb9a118073ffcc92dc3714df073b7c67e915b860d3a8480e4fd
- sha256sums = 43d92d3022cc2d57f35c9b6fde4997fa2dac8e0ff40afdc4078230b0aefb360f
- sha256sums = 07719a0807d002370ea9f4331af7405e0bef55d221f3302c25e7a572b2ba7488
+ source = https://github.com/lenmus/lenmus/archive/Release_6.0.1.tar.gz
+ sha256sums = 1fa5b8edc468c800598845aa809b4a4e93058ed13af40bfacd037c44d1c4bc1d
pkgname = lenmus
diff --git a/PKGBUILD b/PKGBUILD
index 1492836673f0..be0c7206f16b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Chris Chapman <chris dot chapman at aggiemail dot usu dot edu>
pkgname=lenmus
-pkgver=6.0.0
-pkgrel=3
+pkgver=6.0.1
+pkgrel=1
pkgdesc="A free program for learning music"
arch=('i686' 'x86_64')
url="http://www.lenmus.org/"
@@ -12,18 +12,12 @@ depends=('portmidi' 'wxwidgets-gtk3' 'sqlite3' 'fluidsynth' 'soundfont-fluid')
optdepends=('timidity++: for sound without external midi player')
makedepends=('unittestpp' 'cmake' 'lsb-release')
-source=("https://github.com/lenmus/lenmus/archive/Release_${pkgver}.tar.gz"
- "0001-FindPortMidi.patch"
- "0001-Fix-SetHTMLBackgroundImage.patch")
-sha256sums=('235a44a04e827fb9a118073ffcc92dc3714df073b7c67e915b860d3a8480e4fd'
- '43d92d3022cc2d57f35c9b6fde4997fa2dac8e0ff40afdc4078230b0aefb360f'
- '07719a0807d002370ea9f4331af7405e0bef55d221f3302c25e7a572b2ba7488')
+source=("https://github.com/lenmus/lenmus/archive/Release_${pkgver}.tar.gz")
+sha256sums=('1fa5b8edc468c800598845aa809b4a4e93058ed13af40bfacd037c44d1c4bc1d')
prepare() {
cd "$srcdir"/${pkgname}-Release_${pkgver}
rm cmake-modules/FindSQLite3.cmake
- patch -p0 -i "$srcdir/0001-FindPortMidi.patch"
- patch -p1 -i "$srcdir/0001-Fix-SetHTMLBackgroundImage.patch"
}
build() {
@@ -33,7 +27,7 @@ build() {
mkdir build
cd build
- WX_CONFIG=wx-config-gtk3 cmake -G "Unix Makefiles" \
+ cmake -G "Unix Makefiles" \
-DCMAKE_INSTALL_PREFIX=/usr "../${pkgname}-Release_${pkgver}/"
make -j$(nproc) || return 1