summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUwe Koloska2020-05-20 22:41:57 +0200
committerUwe Koloska2020-05-20 22:41:57 +0200
commitad59c0c45dbb5cee4616e6ebddf41bf1cea23c77 (patch)
tree7cba377d48446a0527fac138b971006cb2d720ee
parentfaf37b7f6df40a030ccd920fea762d23df83cd26 (diff)
downloadaur-ad59c0c45dbb5cee4616e6ebddf41bf1cea23c77.tar.gz
new version 5.6.2
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD27
-rw-r--r--cmake-lomse.patch10
4 files changed, 23 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ec57f219bf3..c1b51008f850 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,21 @@
-# Generated by mksrcinfo v8
-# Sun Aug 21 14:15:02 UTC 2016
pkgbase = lenmus
- pkgdesc = A free program to learn music
- pkgver = 5.4.2
- pkgrel = 8
- url = http://www.lenmus.org/en/phonascus/intro
+ pkgdesc = A free program for learning music
+ pkgver = 5.6.2
+ pkgrel = 1
+ url = http://www.lenmus.org/
arch = i686
arch = x86_64
license = GPL
- makedepends = boost
makedepends = unittestpp
- makedepends = cmake>=2.8
+ makedepends = cmake>=3.1
depends = portmidi
depends = wxgtk
depends = sqlite3
- depends = boost-libs
+ depends = fluidsynth
+ depends = soundfont-fluid
optdepends = timidity++: for sound without external midi player
- source = https://codeload.github.com/lenmus/lenmus/tar.gz/Release_5.4.2
- source = 0001-Fixes-in-Lomse-for-compiling-with-C-11.patch
- source = 0001-More-fixes-for-C-11.patch
- md5sums = 0b1adb4e187f6dc08b0dc03029c68f4d
- md5sums = 4ee9268720acaa2ced3a7a782701e71d
- md5sums = 760082915af45d0999eee8d7a73284fe
+ source = https://github.com/lenmus/lenmus/archive/Release_5.6.2.tar.gz
+ sha256sums = 72af23c1f5d4b543cece326b50d7e8b9fb1f9da8e64e7ec65e6f88c2c3c77c6c
pkgname = lenmus
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5845fae5091c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+/src/
+/pkg/
+/*.log
+/*.tar.gz
+/*.pkg.tar.xz
+/forensic_log.txt
diff --git a/PKGBUILD b/PKGBUILD
index ea40017c3b1e..d0d7d8f92aa7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,18 @@
# Contributor: Chris Chapman <chris dot chapman at aggiemail dot usu dot edu>
pkgname=lenmus
-pkgver=5.4.2
-pkgrel=8
-pkgdesc="A free program to learn music"
+pkgver=5.6.2
+pkgrel=1
+pkgdesc="A free program for learning music"
arch=('i686' 'x86_64')
-url="http://www.lenmus.org/en/phonascus/intro"
+url="http://www.lenmus.org/"
license=('GPL')
-depends=('portmidi' 'wxgtk' 'sqlite3' 'boost-libs')
+depends=('portmidi' 'wxgtk' 'sqlite3' 'fluidsynth' 'soundfont-fluid')
optdepends=('timidity++: for sound without external midi player')
-makedepends=('boost' 'unittestpp' 'cmake>=2.8')
+makedepends=('unittestpp' 'cmake>=3.1')
-source=("https://codeload.github.com/lenmus/lenmus/tar.gz/Release_${pkgver}"
- 0001-Fixes-in-Lomse-for-compiling-with-C-11.patch
- 0001-More-fixes-for-C-11.patch)
-md5sums=('0b1adb4e187f6dc08b0dc03029c68f4d'
- '4ee9268720acaa2ced3a7a782701e71d'
- '760082915af45d0999eee8d7a73284fe')
-
-prepare() {
- cd "$srcdir/${pkgname}-Release_${pkgver}/"
-
- patch -p1 -i "$srcdir/0001-Fixes-in-Lomse-for-compiling-with-C-11.patch"
- patch -p1 -i "$srcdir/0001-More-fixes-for-C-11.patch"
-}
+source=("https://github.com/lenmus/lenmus/archive/Release_${pkgver}.tar.gz")
+sha256sums=('72af23c1f5d4b543cece326b50d7e8b9fb1f9da8e64e7ec65e6f88c2c3c77c6c')
build() {
cd "$srcdir"
diff --git a/cmake-lomse.patch b/cmake-lomse.patch
deleted file mode 100644
index 6542b355d1cc..000000000000
--- a/cmake-lomse.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- CMakeLists__orig.txt 2015-12-15 01:06:54.653713447 +0100
-+++ CMakeLists.txt 2015-12-15 01:06:58.563577916 +0100
-@@ -314,6 +314,7 @@
- ${LOMSE_ROOT_DIR}/src/agg/font_freetype
- ${LOMSE_ROOT_DIR}/packages/utfcpp
- ${LOMSE_ROOT_DIR}/packages/minizip
-+ ${LOMSE_ROOT_DIR}/packages
- )
- message("LOMSE: Not using Lomse library, but building with its sources")
- else()