summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Duarte2023-04-28 13:19:20 +0100
committerGonçalo Duarte2023-04-28 13:19:20 +0100
commitbcc36eea96d813379508b100f2dd1b9d23fcf360 (patch)
tree8d7b50d1074bef30adc6cd7a0e4dd99ad8fbf2be
parent2bef2a855d0e379dd983b369a2dc9eaaea555135 (diff)
downloadaur-bcc36eea96d813379508b100f2dd1b9d23fcf360.tar.gz
apply changes
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD32
2 files changed, 18 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 220a113d0af7..a3201c1f9910 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = lenovolegionlinux-dkms-git
pkgdesc = LenovoLegionLinux (LLL) brings additional drivers and tools for Lenovo Legion series laptops to Linuxgit clone ssh://aur@aur.archlinux.org/pkgbase.git. PLEASE READ THE REPO BEFORE INSTALL THIS PACKAGE!!!
- pkgver = r01.d0b59ab
+ pkgver = r250.d0b59ab
pkgrel = 1
url = https://github.com/johnfanv2/LenovoLegionLinux
install = lenovolegionlinux.install
arch = x86_64
license = GPL
makedepends = git
- makedepends = linux-headers
- makedepends = base-devel
+ makedepends = dkms
+ makedepends = lm_sensors
makedepends = i2c-tools
makedepends = dmidecode
makedepends = python-build
diff --git a/PKGBUILD b/PKGBUILD
index 0bb622423135..bc7650265343 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
# Maintainer: johnfanv2 <https://github.com/johnfanv2>
_pkgname=lenovolegionlinux-dkms
pkgname=${_pkgname}-git
-pkgver=r01.d0b59ab
+pkgver=r250.d0b59ab
pkgrel=1
pkgdesc="LenovoLegionLinux (LLL) brings additional drivers and tools for Lenovo Legion series laptops to Linux. PLEASE READ THE REPO BEFORE INSTALL THIS PACKAGE!!!"
arch=("x86_64")
url="https://github.com/johnfanv2/LenovoLegionLinux"
license=('GPL')
makedepends=("git"
- "linux-headers"
- "base-devel"
+ "dkms"
+ "lm_sensors"
"i2c-tools"
"dmidecode"
"python-build"
@@ -22,11 +22,15 @@ makedepends=("git"
optdepends=(
"legion-fan-utils-linux-git: Systemd service that will apply a given profile"
)
-options=(!makeflags !buildflags !strip)
source=("${_pkgname}::git+https://github.com/johnfanv2/LenovoLegionLinux")
sha256sums=('SKIP')
install="lenovolegionlinux.install"
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+}
+
prepare() {
cd "$_pkgname"
pkgver_commit=$(echo $pkgver | cut -c 5-)
@@ -39,24 +43,18 @@ build() {
python -m build
}
package() {
- cd "${srcdir}/${_pkgname}"
- mkdir -p $pkgdir/usr/{local,lib/modules/$(uname -r)/kernel/drivers/platform/x86/}
- mkdir -p $pkgdir/usr/share/{applications/,icons/,polkit-1/actions/}
- mkdir -p $pkgdir/usr/src/$_pkgname-1.0.0
- mkdir -p $pkgdir/etc/pacman.d/hooks
-
cd "${srcdir}/${_pkgname}/kernel_module/"
- cp -r * $pkgdir/usr/src/$_pkgname-1.0.0/
- install -Dm644 dkms.conf $pkgdir/usr/src/$_pkgname-1.0.0/dkms.conf
+ cp -r {issue-warning.sh,legion-laptop-unused-snippets.c,legion-laptop.c,Makefile} ${pkgdir}/usr/src/$_pkgname-1.0.0/
+ install -Dm644 dkms.conf ${pkgdir}/usr/src/$_pkgname-1.0.0/dkms.conf
cd "${srcdir}/${_pkgname}/deploy/"
- install -Dm644 LenovoLegionLinux.hook $pkgdir/etc/pacman.d/hooks/LenovoLegionLinux.hook
+ install -Dm644 LenovoLegionLinux.hook ${pkgdir}/etc/pacman.d/hooks/LenovoLegionLinux.hook
cd "${srcdir}/${_pkgname}/python/legion_linux"
install -Dm775 legion_gui.desktop "${pkgdir}/usr/share/applications/"
- install -Dm775 legion_logo.png "${pkgdir}/usr/share/icons/legion_logo.png"
- install -Dm775 legion_gui.policy "${pkgdir}/usr/share/polkit-1/actions/"
+ install -Dm644 legion_logo.png "${pkgdir}/usr/share/pixmaps/legion_logo.png"
+ install -Dm644 legion_gui.policy "${pkgdir}/usr/share/polkit-1/actions/"
- python -m pip install --isolated --root="$pkgdir" --ignore-installed --no-deps -e .
- mv $pkgdir/usr/bin $pkgdir/usr/local/ #move from /usr/bin to /usr/local/bin (for legion_gui.desktop to work)
+ python -m pip install --isolated --root="${pkgdir}" --ignore-installed --no-deps -e .
+ mv ${pkgdir}/usr/bin ${pkgdir}/usr/local/ #move from /usr/bin to /usr/local/bin (for legion_gui.desktop to work)
}