summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorspider-mario2019-04-07 22:16:30 +0200
committerspider-mario2019-04-07 22:16:30 +0200
commit65c93c44c2ec7f5eac976fc29a210dfcb1699da6 (patch)
treee24e9a2e44b3417be615e917dccc9eab6ca5ee36
downloadaur-65c93c44c2ec7f5eac976fc29a210dfcb1699da6.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD18
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..387634cf0ec4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = lens_calibrate
+ pkgdesc = Script to calculate lens calibration data for the lensfun project
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://gitlab.com/cryptomilk/lens_calibrate
+ arch = any
+ license = GPL3
+ depends = python-exiv2>=0.2.1
+ depends = python-numpy
+ depends = python-scipy
+ depends = python-pypdf2
+ depends = darktable>=2.4.0
+ depends = hugin>=2018
+ depends = imagemagick
+ depends = gnuplot
+ source = git+https://gitlab.com/cryptomilk/lens_calibrate.git#tag=lens_calibrate-0.1.0
+ sha512sums = SKIP
+
+pkgname = lens_calibrate
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4df76baf1a0b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: spider-mario <spidermario@free.fr>
+pkgname=lens_calibrate
+pkgver=0.1.0
+pkgrel=1
+epoch=
+pkgdesc='Script to calculate lens calibration data for the lensfun project'
+arch=('any')
+url="https://gitlab.com/cryptomilk/lens_calibrate"
+license=('GPL3')
+groups=()
+depends=('python-exiv2>=0.2.1' 'python-numpy' 'python-scipy' 'python-pypdf2' 'darktable>=2.4.0' 'hugin>=2018' 'imagemagick' 'gnuplot')
+source=("git+https://gitlab.com/cryptomilk/lens_calibrate.git#tag=$pkgname-$pkgver")
+sha512sums=('SKIP')
+
+package() {
+ cd "$pkgname"
+ install -Dm755 lens_calibrate.py "$pkgdir"/usr/bin/lens_calibrate
+}